Need help getting scanner to work via VNC - Redhat

This is a discussion on Need help getting scanner to work via VNC - Redhat ; I am running Fedora 8 with HP Officejet 5610xi all-in-one (printer, scanner, fax). When I logon to the computer directly (i.e. display : 0), I have no problem using the scanner part of the Officejet. xsane will automatically detect the ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Need help getting scanner to work via VNC

  1. Need help getting scanner to work via VNC

    I am running Fedora 8 with HP Officejet 5610xi all-in-one (printer,
    scanner, fax). When I logon to the computer directly (i.e. display :
    0), I have no problem using the scanner part of the Officejet. xsane
    will automatically detect the device and allow me to scan.

    But when I start a vnc session and connect to the linux box using
    vncviewer from another machine (display session is :1), xsane reports
    "no device" when I launch it within the vnc session.

    The strange thing is I can print without any problem from the same vnc
    session.

    What should I do to make xsane detect the scanner?

    Thanks in advance.

    Ken

  2. Re: Need help getting scanner to work via VNC

    On Apr 25, 12:27*pm, Ken Jones wrote:
    > I am running Fedora 8 with HP Officejet 5610xi all-in-one (printer,
    > scanner, fax). When I logon to the computer directly (i.e. display :
    > 0), I have no problem using the scanner part of the Officejet. xsane
    > will automatically detect the device and allow me to scan.
    >
    > But when I start a vnc session and connect to the linux box using
    > vncviewer from another machine (display session is :1), xsane reports
    > "no device" when I launch it within the vnc session.
    >
    > The strange thing is I can print without any problem from the same vnc
    > session.
    >
    > What should I do to make xsane detect the scanner?
    >
    > Thanks in advance.
    >
    > Ken


    Also, is there a way in Fedora 8 to connect to display session :0 via
    vnc? I am unable to find such configuration setting. Somebody showed
    me it is very easy to do in OpenSuSE 10.x. In OpenSuSE, there is a
    checkbox in the Display configuration to allow connection to display
    session :0 via vnc.

    Thanks again.

    Ken

  3. Re: Need help getting scanner to work via VNC

    On Apr 25, 12:48 pm, Ken Jones wrote:
    > On Apr 25, 12:27 pm, Ken Jones wrote:
    >
    >
    >
    > > I am runningFedora8 with HPOfficejet5610xi all-in-one (printer,
    > > scanner, fax). When I logon to the computer directly (i.e. display :
    > > 0), I have noproblemusing the scanner part of theOfficejet. xsane
    > > will automatically detect the device and allow me to scan.

    >
    > > But when I start a vnc session and connect to the linux box using
    > > vncviewer from another machine (display session is :1), xsane reports
    > > "no device" when I launch it within the vnc session.

    >
    > > The strange thing is I can print without anyproblemfrom the same vnc
    > > session.

    >
    > > What should I do to make xsane detect the scanner?

    >
    > > Thanks in advance.

    >
    > > Ken

    >
    > Also, is there a way inFedora8 to connect to display session :0 via
    > vnc? I am unable to find such configuration setting. Somebody showed
    > me it is very easy to do in OpenSuSE 10.x. In OpenSuSE, there is a
    > checkbox in the Display configuration to allow connection to display
    > session :0 via vnc.
    >
    > Thanks again.
    >
    > Ken


    Any help is appreciated. Please advise if this posting is in the wrong
    group and suggest the appropriate group.

    Thanks,
    Ken

  4. Re: Need help getting scanner to work via VNC

    On Apr 30, 8:14 am, Ken Jones wrote:
    > On Apr 25, 12:48 pm,KenJones wrote:
    >
    >
    >
    > > On Apr 25, 12:27 pm,KenJones wrote:

    >
    > > > I am runningFedora8 with HPOfficejet5610xi all-in-one (printer,
    > > > scanner, fax). When I logon to the computer directly (i.e. display :
    > > > 0), I have noproblemusing the scanner part of theOfficejet. xsane
    > > > will automatically detect the device and allow me to scan.

    >
    > > > But when I start a vnc session and connect to the linux box using
    > > > vncviewer from another machine (display session is :1), xsane reports
    > > > "no device" when I launch it within the vnc session.

    >
    > > > The strange thing is I can print without anyproblemfrom the same vnc
    > > > session.

    >
    > > > What should I do to make xsane detect the scanner?

    >
    > > > Thanks in advance.

    >
    > > >Ken

    >
    > > Also, is there a way inFedora8 to connect to display session :0 via
    > > vnc? I am unable to find such configuration setting. Somebody showed
    > > me it is very easy to do in OpenSuSE 10.x. In OpenSuSE, there is a
    > > checkbox in the Display configuration to allow connection to display
    > > session :0 via vnc.

    >
    > > Thanks again.

    >
    > >Ken

    >
    > Any help is appreciated. Please advise if this posting is in the wrong
    > group and suggest the appropriate group.
    >
    > Thanks,Ken


    I tried a few things and still could not get it to work. Going back to
    Windows XP for now where everything works as expected.

    Will try again when Fedora 9 comes out.

    Ken

+ Reply to Thread