Re: software to survey Access Points in Fedora 8? - Redhat

This is a discussion on Re: software to survey Access Points in Fedora 8? - Redhat ; On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote: > /sbin/iwlist ap Thanks for that info. Still no good. For some reason it is reporting no access points. More than likely due to the fact that the card is "inactive," ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Re: software to survey Access Points in Fedora 8?

  1. Re: software to survey Access Points in Fedora 8?

    On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote:

    > /sbin/iwlist ap



    Thanks for that info.

    Still no good. For some reason it is reporting no access points. More
    than likely due to the fact that the card is "inactive," but I cannot
    activate it for an unknown reason






  2. Re: software to survey Access Points in Fedora 8?

    GeekBoy wrote:
    > On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote:
    >
    >> /sbin/iwlist ap

    >
    >
    > Thanks for that info.
    >
    > Still no good. For some reason it is reporting no access points. More
    > than likely due to the fact that the card is "inactive," but I cannot
    > activate it for an unknown reason
    >
    >
    >
    >
    >

    I presume you have the madwifi module installed and running. It was an
    atheros card? lsmod should include ath_pci.

  3. Re: software to survey Access Points in Fedora 8?

    On Tue, 22 Apr 2008 07:58:30 +1000, zappa wrote:

    > GeekBoy wrote:
    >> On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote:
    >>
    >>> /sbin/iwlist ap

    >>
    >>
    >> Thanks for that info.
    >>
    >> Still no good. For some reason it is reporting no access points. More
    >> than likely due to the fact that the card is "inactive," but I cannot
    >> activate it for an unknown reason
    >>
    >>
    >>
    >>
    >>

    > I presume you have the madwifi module installed and running. It was an
    > atheros card? lsmod should include ath_pci.





    No. madwifi is not installed yet for the reason I was digging for on a
    web site and wanted to confer first with others..seems like a crappy way
    to get it running.

    I havew to check lsmod...never messed with it.

    "Fixing Fedora 8 wireless problem

    http://coyotesg.blogspot.com/

    Fedora 8's wireless is really disappointing.

    So far, bugs findings include

    1. wpa_supplicant is buggy & cannot connect.
    2. default ath_5k driver conflicts with madwifi driver from livna
    3. network manager is also buggy.

    I have a DLink G520 using the atheros chipset. Here is how I managed to
    get it working.
    Note: This method will give you a fixed ip 192.168.0.17(or dhcp ip if you
    like) & the startup
    files will connect you to your preferred wireless network without any
    manual intervention by users
    like using network manager, which does not work anyway.

    1. Blacklist ath_5k in /etc/modprobe.conf & /etc/modprobe.d/blacklist.
    2. Installed kmod-madwifi from livna
    3. disabled network manager as it will interfere with the configuration
    below.
    4. updated wpa_supplicant

    Tricky steps:

    5. Previous version of Fedora before 8, atheros chipset is recognized as
    ath0. In
    Fedora 8, this does not work. Atheros chispet is recognized as wlan0. So,
    I have
    changed all previous reference to ath0 to wlan0.
    6. I removed the ath_5k driver from kernel as some suggested. Not sure if
    this is
    absolutely necessary though.
    7. At /etc/rc5.d, there is this file SXXwpa_supplicant. My case, XX=12.
    Change it to a bigger
    no. I changed it to 98. Reason being, wpa_supplicant was started before
    other services &
    so it does not work. S98wpa_supplicant makes wpa_supplicant starts after
    most other services.
    8. 4 files to be modified/created

    /etc/sysconfig/network-scripts/ifcfg-wlan0
    /etc/dhclient-wlan0.conf
    /etc/sysconfig/wpa_supplicant
    /etc/wpa_supplicant/wpa_supplicant.conf


    My configuration files are as follow:"


    From :

    http://forums.fedoraforum.org/showthread.php?t=172718


  4. Re: software to survey Access Points in Fedora 8?

    GeekBoy wrote:
    > On Tue, 22 Apr 2008 07:58:30 +1000, zappa wrote:
    >
    >> GeekBoy wrote:
    >>> On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote:
    >>>
    >>>> /sbin/iwlist ap
    >>>
    >>> Thanks for that info.
    >>>
    >>> Still no good. For some reason it is reporting no access points. More
    >>> than likely due to the fact that the card is "inactive," but I cannot
    >>> activate it for an unknown reason
    >>>
    >>>
    >>>
    >>>
    >>>

    >> I presume you have the madwifi module installed and running. It was an
    >> atheros card? lsmod should include ath_pci.

    >
    >
    >
    >
    > No. madwifi is not installed yet for the reason I was digging for on a
    > web site and wanted to confer first with others..seems like a crappy way
    > to get it running.
    >
    > I havew to check lsmod...never messed with it.
    >
    > "Fixing Fedora 8 wireless problem
    >
    > http://coyotesg.blogspot.com/
    >
    > Fedora 8's wireless is really disappointing.
    >
    > So far, bugs findings include
    >
    > 1. wpa_supplicant is buggy & cannot connect.
    > 2. default ath_5k driver conflicts with madwifi driver from livna
    > 3. network manager is also buggy.
    >
    > I have a DLink G520 using the atheros chipset. Here is how I managed to
    > get it working.
    > Note: This method will give you a fixed ip 192.168.0.17(or dhcp ip if you
    > like) & the startup
    > files will connect you to your preferred wireless network without any
    > manual intervention by users
    > like using network manager, which does not work anyway.
    >
    > 1. Blacklist ath_5k in /etc/modprobe.conf & /etc/modprobe.d/blacklist.
    > 2. Installed kmod-madwifi from livna
    > 3. disabled network manager as it will interfere with the configuration
    > below.
    > 4. updated wpa_supplicant
    >
    > Tricky steps:
    >
    > 5. Previous version of Fedora before 8, atheros chipset is recognized as
    > ath0. In
    > Fedora 8, this does not work. Atheros chispet is recognized as wlan0. So,
    > I have
    > changed all previous reference to ath0 to wlan0.
    > 6. I removed the ath_5k driver from kernel as some suggested. Not sure if
    > this is
    > absolutely necessary though.
    > 7. At /etc/rc5.d, there is this file SXXwpa_supplicant. My case, XX=12.
    > Change it to a bigger
    > no. I changed it to 98. Reason being, wpa_supplicant was started before
    > other services &
    > so it does not work. S98wpa_supplicant makes wpa_supplicant starts after
    > most other services.
    > 8. 4 files to be modified/created
    >
    > /etc/sysconfig/network-scripts/ifcfg-wlan0
    > /etc/dhclient-wlan0.conf
    > /etc/sysconfig/wpa_supplicant
    > /etc/wpa_supplicant/wpa_supplicant.conf
    >
    >
    > My configuration files are as follow:"
    >
    >
    > From :
    >
    > http://forums.fedoraforum.org/showthread.php?t=172718
    >

    One resource is http://madwifi.org/wiki/UserDocs/FirstTimeHowTo
    Also have a look at the livna repository. It includes three packages
    kmod-madwifi, kmod-madwifi-2.6.24.4-64.fc8 or whatever kernel version
    you use & madwifi. Installing these packages should get madwifi onto
    your system without building from scratch.
    I have no trouble with fc8 and the atheros chipset.

  5. Re: software to survey Access Points in Fedora 8?


    "zappa" wrote in message
    news:jPmdnf8oOoBe1pDVnZ2dnUVZ_vSdnZ2d@internode...
    > GeekBoy wrote:
    >> On Tue, 22 Apr 2008 07:58:30 +1000, zappa wrote:
    >>
    >>> GeekBoy wrote:
    >>>> On Mon, 21 Apr 2008 18:16:37 +1000, zappa wrote:
    >>>>
    >>>>> /sbin/iwlist ap
    >>>>
    >>>> Thanks for that info.
    >>>>
    >>>> Still no good. For some reason it is reporting no access points. More
    >>>> than likely due to the fact that the card is "inactive," but I cannot
    >>>> activate it for an unknown reason
    >>>>
    >>>>
    >>>>
    >>>>
    >>> I presume you have the madwifi module installed and running. It was an
    >>> atheros card? lsmod should include ath_pci.

    >>
    >>
    >>
    >>
    >> No. madwifi is not installed yet for the reason I was digging for on a
    >> web site and wanted to confer first with others..seems like a crappy way
    >> to get it running.
    >>
    >> I havew to check lsmod...never messed with it.
    >>
    >> "Fixing Fedora 8 wireless problem
    >>
    >> http://coyotesg.blogspot.com/
    >>
    >> Fedora 8's wireless is really disappointing.
    >>
    >> So far, bugs findings include
    >>
    >> 1. wpa_supplicant is buggy & cannot connect.
    >> 2. default ath_5k driver conflicts with madwifi driver from livna
    >> 3. network manager is also buggy.
    >>
    >> I have a DLink G520 using the atheros chipset. Here is how I managed to
    >> get it working.
    >> Note: This method will give you a fixed ip 192.168.0.17(or dhcp ip if you
    >> like) & the startup
    >> files will connect you to your preferred wireless network without any
    >> manual intervention by users
    >> like using network manager, which does not work anyway.
    >>
    >> 1. Blacklist ath_5k in /etc/modprobe.conf & /etc/modprobe.d/blacklist.
    >> 2. Installed kmod-madwifi from livna
    >> 3. disabled network manager as it will interfere with the configuration
    >> below.
    >> 4. updated wpa_supplicant
    >>
    >> Tricky steps:
    >>
    >> 5. Previous version of Fedora before 8, atheros chipset is recognized as
    >> ath0. In
    >> Fedora 8, this does not work. Atheros chispet is recognized as wlan0. So,
    >> I have
    >> changed all previous reference to ath0 to wlan0.
    >> 6. I removed the ath_5k driver from kernel as some suggested. Not sure if
    >> this is
    >> absolutely necessary though.
    >> 7. At /etc/rc5.d, there is this file SXXwpa_supplicant. My case, XX=12.
    >> Change it to a bigger
    >> no. I changed it to 98. Reason being, wpa_supplicant was started before
    >> other services &
    >> so it does not work. S98wpa_supplicant makes wpa_supplicant starts after
    >> most other services.
    >> 8. 4 files to be modified/created
    >>
    >> /etc/sysconfig/network-scripts/ifcfg-wlan0
    >> /etc/dhclient-wlan0.conf
    >> /etc/sysconfig/wpa_supplicant
    >> /etc/wpa_supplicant/wpa_supplicant.conf
    >>
    >>
    >> My configuration files are as follow:"
    >>
    >>
    >> From :
    >>
    >> http://forums.fedoraforum.org/showthread.php?t=172718
    >>

    > One resource is http://madwifi.org/wiki/UserDocs/FirstTimeHowTo
    > Also have a look at the livna repository. It includes three packages
    > kmod-madwifi, kmod-madwifi-2.6.24.4-64.fc8 or whatever kernel version you
    > use & madwifi. Installing these packages should get madwifi onto your
    > system without building from scratch.
    > I have no trouble with fc8 and the atheros chipset.



    Thanks for that info. I will have a look and get back on by Tuesday night or
    Wednesday.



+ Reply to Thread