Updates - Redhat

This is a discussion on Updates - Redhat ; I am running RHEL ES4 and I am trying to download and install the update called postgresql-python but when I do that, I get a warning saying that it requires libpq.so.3 and then bombs out. I cannot find libpq.so.3 in ...

+ Reply to Thread
Results 1 to 14 of 14

Thread: Updates

  1. Updates

    I am running RHEL ES4 and I am trying to download and install the
    update called postgresql-python but when I do that, I get a warning
    saying that it requires libpq.so.3 and then bombs out. I cannot find
    libpq.so.3 in the list of available updates. Not sure what to do...
    Anyone have a suggestion?

    Thanks.

  2. Re: Updates

    In news:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    dexteroc typed:

    > I am running RHEL ES4 and I am trying to download and install the
    > update called postgresql-python but when I do that, I get a warning
    > saying that it requires libpq.so.3 and then bombs out. I cannot find
    > libpq.so.3 in the list of available updates. Not sure what to do...
    > Anyone have a suggestion?


    "yum install postgresql-python" will resolve the dependencies.



  3. Re: Updates

    ynotssor wrote:
    > In news:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    > dexteroc typed:
    >
    >
    >>I am running RHEL ES4 and I am trying to download and install the
    >>update called postgresql-python but when I do that, I get a warning
    >>saying that it requires libpq.so.3 and then bombs out. I cannot find
    >>libpq.so.3 in the list of available updates. Not sure what to do...
    >>Anyone have a suggestion?

    >
    >
    > "yum install postgresql-python" will resolve the dependencies.
    >
    >

    Dear ynotssor,


    Shouldn't it be.

    up2date postgresql-python


    Yum is used on CentOS or RHEL 5.x


    Kind regards,


    Jan Gerrit

  4. Re: Updates

    On Mar 26, 10:17 pm, Jan Gerrit Kootstra
    wrote:
    > ynotssor wrote:
    > > Innews:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    > > dexteroc typed:

    >
    > >>I am running RHEL ES4 and I am trying to download and install the
    > >>update called postgresql-python but when I do that, I get a warning
    > >>saying that it requires libpq.so.3 and then bombs out. I cannot find
    > >>libpq.so.3 in the list of available updates. Not sure what to do...
    > >>Anyone have a suggestion?

    >
    > > "yum install postgresql-python" will resolve the dependencies.

    >
    > Dear ynotssor,
    >
    > Shouldn't it be.
    >
    > up2date postgresql-python
    >
    > Yum is used on CentOS or RHEL 5.x
    >
    > Kind regards,
    >
    > Jan Gerrit



    Hi Jan,

    I tried up2date postgresql-python and I get the message below...

    Unresolvable chain of dependencies:
    postgresql-python 7.4.19-1.el4_6.1 requires libpq.so.3

  5. Re: Updates

    On Mar 27, 8:33 am, dexteroc wrote:
    > On Mar 26, 10:17 pm, Jan Gerrit Kootstra
    > wrote:
    >
    >
    >
    > > ynotssor wrote:
    > > > Innews:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    > > > dexteroc typed:

    >
    > > >>I am running RHEL ES4 and I am trying to download and install the
    > > >>update called postgresql-python but when I do that, I get a warning
    > > >>saying that it requires libpq.so.3 and then bombs out. I cannot find
    > > >>libpq.so.3 in the list of available updates. Not sure what to do...
    > > >>Anyone have a suggestion?

    >
    > > > "yum install postgresql-python" will resolve the dependencies.

    >
    > > Dear ynotssor,

    >
    > > Shouldn't it be.

    >
    > > up2date postgresql-python

    >
    > > Yum is used on CentOS or RHEL 5.x

    >
    > > Kind regards,

    >
    > > Jan Gerrit

    >
    > Hi Jan,
    >
    > I tried up2date postgresql-python and I get the message below...
    >
    > Unresolvable chain of dependencies:
    > postgresql-python 7.4.19-1.el4_6.1 requires libpq.so.3



    Then when I do:

    [root /]# up2date libpq.so.3

    Fetching Obsoletes list for channel: rhel-i386-es-4...

    Fetching rpm headers...
    ########################################

    Name Version Rel
    ----------------------------------------------------------

    The following packages you requested were not found:
    libpq.so.3

  6. Re: Updates

    On Mar 27, 8:33 am, dexteroc wrote:
    > On Mar 26, 10:17 pm, Jan Gerrit Kootstra
    > wrote:
    >
    >
    >
    > > ynotssor wrote:
    > > > Innews:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    > > > dexteroc typed:

    >
    > > >>I am running RHEL ES4 and I am trying to download and install the
    > > >>update called postgresql-python but when I do that, I get a warning
    > > >>saying that it requires libpq.so.3 and then bombs out. I cannot find
    > > >>libpq.so.3 in the list of available updates. Not sure what to do...
    > > >>Anyone have a suggestion?

    >
    > > > "yum install postgresql-python" will resolve the dependencies.

    >
    > > Dear ynotssor,

    >
    > > Shouldn't it be.

    >
    > > up2date postgresql-python

    >
    > > Yum is used on CentOS or RHEL 5.x

    >
    > > Kind regards,

    >
    > > Jan Gerrit

    >
    > Hi Jan,
    >
    > I tried up2date postgresql-python and I get the message below...
    >
    > Unresolvable chain of dependencies:
    > postgresql-python 7.4.19-1.el4_6.1 requires libpq.so.3


    Then I tried:

    [root /]# up2date libpq.so.3

    Fetching Obsoletes list for channel: rhel-i386-es-4...

    Fetching rpm headers...
    ########################################

    Name Version Rel
    ----------------------------------------------------------

    The following packages you requested were not found:
    libpq.so.3

  7. Re: Updates

    In news:25828827-2bd4-4e55-a8bf-7e569d10c1dd@e23g2000prf.googlegroups.com,
    dexteroc typed:

    > Unresolvable chain of dependencies:
    > postgresql-python 7.4.19-1.el4_6.1 requires libpq.so.3


    You need to add the rpmforge repositories, which is/are where the
    libpqxx.i386 and libpqxx-devel.i386 packages reside.
    http://apt.sw.be/redhat/el4/en/ will get you started on the right absolute
    path, but since you appear to be in California you might prefer
    http://rh-mirror.linux.iastate.edu/p...redhat/el4/en/

    Mssr. Kootstra can no doubt advise you on how to add the repository and
    mirrors to /etc/sysconfig/rhn/up2date, as I've long ago forsaken up2date in
    favour of yum, which makes adding repositories and their mirrors quite
    simple, as well as automatically downloading from the fastest available
    mirror. I also prefer free software.




  8. Re: Updates

    ynotssor wrote:
    > In news:25828827-2bd4-4e55-a8bf-7e569d10c1dd@e23g2000prf.googlegroups.com,
    > dexteroc typed:
    >
    >
    >>Unresolvable chain of dependencies:
    >>postgresql-python 7.4.19-1.el4_6.1 requires libpq.so.3

    >
    >
    > You need to add the rpmforge repositories, which is/are where the
    > libpqxx.i386 and libpqxx-devel.i386 packages reside.
    > http://apt.sw.be/redhat/el4/en/ will get you started on the right absolute
    > path, but since you appear to be in California you might prefer
    > http://rh-mirror.linux.iastate.edu/p...redhat/el4/en/
    >
    > Mssr. Kootstra can no doubt advise you on how to add the repository and
    > mirrors to /etc/sysconfig/rhn/up2date, as I've long ago forsaken up2date in
    > favour of yum, which makes adding repositories and their mirrors quite
    > simple, as well as automatically downloading from the fastest available
    > mirror. I also prefer free software.
    >
    >
    >

    Dear ynotssor,


    Mr. Kootstra is not able to advise on how to add repositories to update.
    Thank you for pointing out that it can be done.

    Mr. Kootstra just points Mssr ynotssor out that yum is not the standard
    update tools on RHEL 4.

    CentOS uses yum in version 4 and 5, but RHEL introduced yum in RHEL 5.0.

    I use RHEL 5.1, so cannot experiment with up2date repositories.


    Kind regards,


    Jan Gerrit Kootstra

  9. Re: Updates

    In news:829a$47ec2e54$5039d21b$25903@news.chello.nl,
    Jan Gerrit Kootstra typed:

    > Dear ynotssor,


    I am not your "dear".



  10. Re: Updates

    ynotssor wrote:
    > In news:829a$47ec2e54$5039d21b$25903@news.chello.nl,
    > Jan Gerrit Kootstra typed:
    >
    >
    >>Dear ynotssor,

    >
    >
    > I am not your "dear".
    >
    >

    Ok your arogancy "Esteemed?"

  11. Re: Updates

    In news:6129b$47ec8e62$5039d21b$29594@news.chello.nl,
    Jan Gerrit Kootstra typed:

    > Ok your arogancy "Esteemed?"


    I find your attitude to be condescending and insulting, so shove it up your
    ass.





  12. Re: Updates

    ynotssor wrote:
    > In news:6129b$47ec8e62$5039d21b$29594@news.chello.nl,
    > Jan Gerrit Kootstra typed:
    >
    >
    >>Ok your arogancy "Esteemed?"

    >
    >
    > I find your attitude to be condescending and insulting, so shove it up your
    > ass.
    >
    >
    >
    >

    ynotssor,


    You started to attack my lack of knowledge of your local costums by say
    you were not my dear.

    I admit my response was over the top.

    In the Netherlands it is costum to say "Beste name of person" if you do
    not want to be to formal. This is translated in the dictionary I use by
    "Dear name of person".


    Sorry for the possible insult,


    Jan Gerrit Kootstra

  13. Re: Updates

    Jan Gerrit Kootstra wrote:
    > ynotssor wrote:
    >> In
    >> news:404a675f-8308-4b66-beed-204afdb602f2@u10g2000prn.googlegroups.com,
    >> dexteroc typed:
    >>
    >>
    >>> I am running RHEL ES4 and I am trying to download and install the
    >>> update called postgresql-python but when I do that, I get a warning
    >>> saying that it requires libpq.so.3 and then bombs out. I cannot find
    >>> libpq.so.3 in the list of available updates. Not sure what to do...
    >>> Anyone have a suggestion?

    >>
    >>
    >> "yum install postgresql-python" will resolve the dependencies.
    >>
    >>

    > Dear ynotssor,
    >
    >
    > Shouldn't it be.
    >
    > up2date postgresql-python
    >
    >
    > Yum is used on CentOS or RHEL 5.x


    If you're smart, you set up one machine to mirror the up2date repository from
    RedHat, and set up that machine as a local Yum web server using the yum
    utilities from CentOS. Seriously, up2date should have been shot through the
    head years ago, and RedHat discarded it with RHEL 5, although their
    'yum-rhn-plugin' suffers many of the foibles of up2date.

  14. Re: Updates

    In news:8e5d7$47ed72c3$5039d21b$28744@news.chello.nl,
    Jan Gerrit Kootstra typed:

    >>> Ok your arogancy "Esteemed?"

    >>
    >> I find your attitude to be condescending and insulting, so shove it
    >> up your ass.

    >
    > You started to attack my lack of knowledge of your local costums by
    > say you were not my dear.
    >
    > I admit my response was over the top.
    >
    > In the Netherlands it is costum to say "Beste name of person" if you
    > do not want to be to formal. This is translated in the dictionary I
    > use by "Dear name of person".
    >
    > Sorry for the possible insult,


    As a trained reader of German dialects and their modes of address including
    Plattdeutsch, I'll accept your apology, while noting that it does nothing to
    explain your insult in the initial quote above.



+ Reply to Thread