Re: yum help - Redhat

This is a discussion on Re: yum help - Redhat ; Ok, I'm running Fedora Core 2 now, but when I try to use yum to update, I get: Ah ha! For some reason it was looking for redhat packages. I'm ran yum update and it: root@tagging [~]# yum update Gathering ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: Re: yum help

  1. Re: yum help

    Ok, I'm running Fedora Core 2 now, but when I try to use yum to update, I
    get:

    Ah ha! For some reason it was looking for redhat packages.

    I'm ran yum update and it:

    root@tagging [~]# yum update
    Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    ...Package redhat-config-mouse needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-network-tui needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-bind needs /usr/bin/python2.2, this is not available.
    Package redhat-config-nfs needs /usr/bin/python2.2, this is not available.
    Package redhat-config-samba needs /usr/bin/python2.2, this is not available.
    Package redhat-config-securitylevel needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-date needs /usr/bin/python2.2, this is not available.
    Package redhat-config-keyboard needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-kickstart needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-language needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-users needs /usr/bin/python2.2, this is not available.
    Package redhat-config-soundcard needs /usr/bin/python2.2, this is not
    available.
    Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not
    available.
    Package imap needs libcom_err.so.3, this is not available.
    Package pine needs libcom_err.so.3, this is not available.
    root@tagging [~]



  2. Re: yum help

    On Fri, 18 Feb 2005 22:47:06 +0000 Danny M. wrote:

    > Ok, I'm running Fedora Core 2 now, but when I try to use yum to update, I
    > get:
    >
    > Ah ha! For some reason it was looking for redhat packages.
    >
    > I'm ran yum update and it:
    >
    > root@tagging [~]# yum update
    > Gathering header information file(s) from server(s)
    > Server: Fedora Core 2 - i386 - Base
    > Server: Fedora Core 2 - i386 - Released Updates
    > Finding updated packages
    > Downloading needed headers
    > Resolving dependencies
    > ..Package redhat-config-mouse needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-network-tui needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-bind needs /usr/bin/python2.2, this is not available.
    > Package redhat-config-nfs needs /usr/bin/python2.2, this is not available.
    > Package redhat-config-samba needs /usr/bin/python2.2, this is not available.
    > Package redhat-config-securitylevel needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-date needs /usr/bin/python2.2, this is not available.
    > Package redhat-config-keyboard needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-kickstart needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-language needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-users needs /usr/bin/python2.2, this is not available.
    > Package redhat-config-soundcard needs /usr/bin/python2.2, this is not
    > available.
    > Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not
    > available.
    > Package imap needs libcom_err.so.3, this is not available.
    > Package pine needs libcom_err.so.3, this is not available.
    > root@tagging [~]


    Your system is badly mixed with non FC2 packages. So remove all
    redhat-config-* packages. They are all named sytem-config-* since FC2.
    Remove too the imap and pine packages which are not Fedora Core packages!
    They are relicts from RH9 as they require libcom_err.so.3.

    Alexander


    --
    Alexander Dalloz | Enger, Germany | new address - new key: 0xB366A773
    legal statement: http://www.uni-x.org/legal.html
    Fedora GNU/Linux Core 2 (Tettnang) on Athlon kernel 2.6.10-1.14_FC2smp
    Serendipity 01:59:25 up 2 days, 1:21, load average: 0.34, 0.47, 0.55


  3. Re: yum help

    "Alexander Dalloz" wrote in message
    newsan.2005.02.19.01.01.26.690893@uni-x.org...
    > On Fri, 18 Feb 2005 22:47:06 +0000 Danny M. wrote:
    >
    >> Ok, I'm running Fedora Core 2 now, but when I try to use yum to update, I
    >> get:
    >>
    >> Ah ha! For some reason it was looking for redhat packages.
    >>
    >> I'm ran yum update and it:
    >>
    >> root@tagging [~]# yum update
    >> Gathering header information file(s) from server(s)
    >> Server: Fedora Core 2 - i386 - Base
    >> Server: Fedora Core 2 - i386 - Released Updates
    >> Finding updated packages
    >> Downloading needed headers
    >> Resolving dependencies
    >> ..Package redhat-config-mouse needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-network-tui needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-bind needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-nfs needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-samba needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-securitylevel needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-date needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-keyboard needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-kickstart needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-language needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-users needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-soundcard needs /usr/bin/python2.2, this is not
    >> available.
    >> Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not
    >> available.
    >> Package imap needs libcom_err.so.3, this is not available.
    >> Package pine needs libcom_err.so.3, this is not available.
    >> root@tagging [~]

    >
    > Your system is badly mixed with non FC2 packages. So remove all
    > redhat-config-* packages. They are all named sytem-config-* since FC2.
    > Remove too the imap and pine packages which are not Fedora Core packages!
    > They are relicts from RH9 as they require libcom_err.so.3.
    >
    > Alexander
    >
    >
    > --
    > Alexander Dalloz | Enger, Germany | new address - new key: 0xB366A773
    > legal statement: http://www.uni-x.org/legal.html
    > Fedora GNU/Linux Core 2 (Tettnang) on Athlon kernel 2.6.10-1.14_FC2smp
    > Serendipity 01:59:25 up 2 days, 1:21, load average: 0.34, 0.47, 0.55
    >


    I deleted all the redhat-config-* files and pine, (i couldn't find imap).
    But its still saying the same thing! Any ideas? Thanks!

    -Danny M.



  4. Re: yum help

    On Sat, 19 Feb 2005 18:35:21 +0000 Danny M. wrote:

    > I deleted all the redhat-config-* files and pine, (i couldn't find imap).
    > But its still saying the same thing! Any ideas? Thanks!
    >
    > -Danny M.


    cat /etc/fedora-release
    cat /etc/yum.conf
    rpm -qa | grep imap

    Alexander


    --
    Alexander Dalloz | Enger, Germany | new address - new key: 0xB366A773
    legal statement: http://www.uni-x.org/legal.html
    Fedora GNU/Linux Core 2 (Tettnang) on Athlon kernel 2.6.10-1.14_FC2smp
    Serendipity 22:58:23 up 2 days, 22:20, load average: 0.57, 0.68, 0.63


  5. Re: yum help

    Danny M. wrote:

    > I deleted all the redhat-config-* files


    That "I deleted" sounds scary to me!
    Did you DELETE them or remove them with rpm?

    andrew


  6. Re: yum help

    Chirpy fixed it all for me! *bows down to Chirpy*

    But now:


    Code:
    root@tagging [~]# yum update
    Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    .......Unable to satisfy dependencies
    Package mod_python needs httpd >= 2.0.40, this is not available.
    Package mod_python needs httpd-mmn = 20020903, this is not available.
    Package gkrellm needs kernel >= 2.6.2, this is not available.
    Package namazu-cgi needs webserver, this is not available.
    Package mod_auth_mysql needs httpd >= 2.0.40, this is not available.
    Package mod_auth_mysql needs httpd-mmn = 20020903, this is not available.
    Package mod_auth_pgsql needs httpd >= 2.0.40, this is not available.
    Package mod_auth_pgsql needs httpd-mmn = 20020903, this is not available.
    Package jcode.pl needs perl(:MODULE_COMPAT_5.8.3), this is not available.
    Package vim-enhanced needs perl >= 5.8.3, this is not available.
    Package htdig-web needs webserver, this is not available.
    Package foomatic needs perl >= 3:5.8.1, this is not available.
    Package foomatic needs perl(:MODULE_COMPAT_5.8.3), this is not available.
    Package nut-cgi needs webserver, this is not available.
    Package xchat needs /usr/lib/perl5/5.8.3/i386-linux-thread-multi, this is
    not available.
    Package jdkgcj needs gcc-java = 3.2.2, this is not available.
    Package qt-Xt needs qt = 1:3.1.1-6, this is not available.
    Package jdkgcj needs libgcj = 3.2.2, this is not available.
    Package db4-java needs db4 = 4.0.14-20, this is not available.
    Package galeon needs mozilla = 35:1.2.1, this is not available.
    root@tagging [~]#

    What do I do?



  7. Re: yum help

    Anyone? Please help! :-(


    "Danny M." wrote in message
    news:JFLRd.1199$Ba3.983@newsread2.news.atl.earthli nk.net...
    > "Alexander Dalloz" wrote in message
    > newsan.2005.02.19.01.01.26.690893@uni-x.org...
    >> On Fri, 18 Feb 2005 22:47:06 +0000 Danny M. wrote:
    >>
    >>> Ok, I'm running Fedora Core 2 now, but when I try to use yum to update,
    >>> I
    >>> get:
    >>>
    >>> Ah ha! For some reason it was looking for redhat packages.
    >>>
    >>> I'm ran yum update and it:
    >>>
    >>> root@tagging [~]# yum update
    >>> Gathering header information file(s) from server(s)
    >>> Server: Fedora Core 2 - i386 - Base
    >>> Server: Fedora Core 2 - i386 - Released Updates
    >>> Finding updated packages
    >>> Downloading needed headers
    >>> Resolving dependencies
    >>> ..Package redhat-config-mouse needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-network-tui needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-bind needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-nfs needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-samba needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-securitylevel needs /usr/bin/python2.2, this is
    >>> not
    >>> available.
    >>> Package redhat-config-date needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-keyboard needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-kickstart needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-language needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-users needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-soundcard needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not
    >>> available.
    >>> Package imap needs libcom_err.so.3, this is not available.
    >>> Package pine needs libcom_err.so.3, this is not available.
    >>> root@tagging [~]

    >>
    >> Your system is badly mixed with non FC2 packages. So remove all
    >> redhat-config-* packages. They are all named sytem-config-* since FC2.
    >> Remove too the imap and pine packages which are not Fedora Core packages!
    >> They are relicts from RH9 as they require libcom_err.so.3.
    >>
    >> Alexander
    >>
    >>
    >> --
    >> Alexander Dalloz | Enger, Germany | new address - new key: 0xB366A773
    >> legal statement: http://www.uni-x.org/legal.html
    >> Fedora GNU/Linux Core 2 (Tettnang) on Athlon kernel 2.6.10-1.14_FC2smp
    >> Serendipity 01:59:25 up 2 days, 1:21, load average: 0.34, 0.47, 0.55
    >>

    >
    > I deleted all the redhat-config-* files and pine, (i couldn't find imap).
    > But its still saying the same thing! Any ideas? Thanks!
    >
    > -Danny M.
    >
    >




  8. Re: yum help

    On Wed, 23 Feb 2005 00:15:21 +0000 Danny M. wrote:

    > Anyone? Please help! :-(


    Don't top-post!

    I answered you - but you didn't reply to my request for information from
    your side.

    Alexander


    --
    Alexander Dalloz | Enger, Germany | new address - new key: 0xB366A773
    legal statement: http://www.uni-x.org/legal.html
    Fedora GNU/Linux Core 2 (Tettnang) on Athlon kernel 2.6.10-1.14_FC2smp
    Serendipity 01:20:40 up 1 day, 12:29, load average: 1.04, 0.74, 0.65


+ Reply to Thread