fedora core 3 very slow - Redhat

This is a discussion on fedora core 3 very slow - Redhat ; I've installed Fedora Core 3 on my Dell c840. There is something wrong. The hard drive access is VERY slow, it takes over 10 minutes to load GNOME. This same laptop ran FC2 flawlessly. I'm getting less than 2MB/s on ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: fedora core 3 very slow

  1. fedora core 3 very slow

    I've installed Fedora Core 3 on my Dell c840. There is something wrong.
    The hard drive access is VERY slow, it takes over 10 minutes to load
    GNOME. This same laptop ran FC2 flawlessly. I'm getting less than 2MB/s
    on hdparm -t /dev/hda. Anything that required drive access is painfully
    slow. The weird thing is this slowness does not occur until the OS is
    finished loading. The OS boots without problem until I go to login, the
    very slow (both at init 3 and init 5). Any suggestions?

  2. Re: fedora core 3 very slow

    Greg Rodenhiser wrote:

    > I've installed Fedora Core 3 on my Dell c840. There is something wrong.
    > The hard drive access is VERY slow, it takes over 10 minutes to load
    > GNOME. This same laptop ran FC2 flawlessly. I'm getting less than 2MB/s
    > on hdparm -t /dev/hda. Anything that required drive access is painfully
    > slow. The weird thing is this slowness does not occur until the OS is
    > finished loading. The OS boots without problem until I go to login, the
    > very slow (both at init 3 and init 5). Any suggestions?


    Look for any obvious warning messages in either
    dmesg or /var/log/messages



  3. Re: fedora core 3 very slow

    Gumby wrote:
    > Greg Rodenhiser wrote:
    >
    >
    >>I've installed Fedora Core 3 on my Dell c840. There is something wrong.
    >>The hard drive access is VERY slow, it takes over 10 minutes to load
    >>GNOME. This same laptop ran FC2 flawlessly. I'm getting less than 2MB/s
    >>on hdparm -t /dev/hda. Anything that required drive access is painfully
    >>slow. The weird thing is this slowness does not occur until the OS is
    >>finished loading. The OS boots without problem until I go to login, the
    >>very slow (both at init 3 and init 5). Any suggestions?

    >
    >
    > Look for any obvious warning messages in either
    > dmesg or /var/log/messages
    >
    >

    I figured it out. Haldaemon ruins performance on laptops that share an
    IDE channel/cable between the hard drive and cdrom. HAL continuousy
    polls the cdrom for media, thus choking access to the hard drive. As
    soon as I disabled HAL, all was well...

+ Reply to Thread