Hi

I have been trying to install the driver for a new 3com gigabit NIC
(3c2000). When I tried to build the driver I got an error saying that
the make utility could not find the
"/usr/src/linux/includes/linux/version.h" file. After searching around
on the web I concluded that my src installation was not complete so I
decided to update the installation (which is currently red-hat 6.2,
kernal 2.something running on an intel pentium class chip).

First I needed to install "apt-get" so I downloaded
apt-0.5.4cnc7-fr0.62.1.i386.rpm and tried to install it. When I tried
to install this rpm I got a response telling me that rpm-4.0.0 was
required. Unfortunately I did not check the current rpm version and
proceeded to download and install the nearest version I could find to
4.0.0 (rpm-4.0-6x.i386.rpm). However now I cant execute directory
listings and I cant open a bash session on the machine (I am trying to
remotely connect to the machine using putty (telnet) - the machine is
in a different location) - I can ping it and I can still mount samba
shares. It seems that installing the rpm package has deleted a LOT of
ESSENTIAL libraries!!!

Here are the sequence of commands I used when installing
rpm-4.0-6x.i386.rpm. Everything was working fine until this point -
after this nothin was working!!!

Can anyone help me please? Is there any way to log onto the machine
without starting a bash shell (using putty) so that I can try and fix
this (by re-installing all the missing libraries)? I cant see what I
did wrong - I got no warnings about deleting libraries!

Cheers
Mark

root@raidfront mark/ >rpm -Uvh apt-0.5.4cnc7-fr0.62.1.i386.rpm
error: failed dependencies:
rpm >= 4.0.0 is needed by apt-0.5.4cnc7-fr0.62.1
libdb-3.1.so is needed by apt-0.5.4cnc7-fr0.62.1
librpmio.so.0 is needed by apt-0.5.4cnc7-fr0.62.1
root@raidfront mark/ >apt-get
bash: apt-get: command not found
root@raidfront mark/ >ll
total 2968
-rw-r----- 1 mark smbusers 0 Dec 22 17:35 TMP31B.tmp
-rw-r----- 1 mark smbusers 885316 Dec 23 17:30
apt-0.5.4cnc7-fr0.62.1.i
386.rpm
-rw-r----- 1 mark smbusers 2215 Dec 22 17:35 psuedo.txt
-rw-r----- 1 mark smbusers 2130440 Dec 23 17:43
rpm-4.0-6x.i386.rpm
-rw-r----- 1 mark smbusers 4 Dec 2 16:04 test.txt
root@raidfront mark/ >rpm -Uvh rpm-4.0-6x.i386.rpm
Preparing... ###########################################
[100%]
1:rpm ###########################################
[100%]
root@raidfront mark/ >rpm -Uvh apt-0.5.4cnc7-fr0.62.1.i386.rpm
error: failed dependencies:
rpm >= 4.0.0 is needed by apt-0.5.4cnc7-fr0.62.1
zlib is needed by apt-0.5.4cnc7-fr0.62.1
bzip2 is needed by apt-0.5.4cnc7-fr0.62.1
libstdc++ is needed by apt-0.5.4cnc7-fr0.62.1
/sbin/ldconfig is needed by apt-0.5.4cnc7-fr0.62.1
/sbin/ldconfig is needed by apt-0.5.4cnc7-fr0.62.1
ld-linux.so.2 is needed by apt-0.5.4cnc7-fr0.62.1
libbz2.so.0 is needed by apt-0.5.4cnc7-fr0.62.1
libc.so.6 is needed by apt-0.5.4cnc7-fr0.62.1
libdb-3.1.so is needed by apt-0.5.4cnc7-fr0.62.1
libdb.so.2 is needed by apt-0.5.4cnc7-fr0.62.1
libm.so.6 is needed by apt-0.5.4cnc7-fr0.62.1
libpopt.so.0 is needed by apt-0.5.4cnc7-fr0.62.1
librpm.so.0 is needed by apt-0.5.4cnc7-fr0.62.1
librpmio.so.0 is needed by apt-0.5.4cnc7-fr0.62.1
libstdc++-libc6.1-1.so.2 is needed by apt-0.5.4cnc7-fr0.62.1
libz.so.1 is needed by apt-0.5.4cnc7-fr0.62.1
/bin/sh is needed by apt-0.5.4cnc7-fr0.62.1
libc.so.6(GLIBC_2.0) is needed by apt-0.5.4cnc7-fr0.62.1
libc.so.6(GLIBC_2.1) is needed by apt-0.5.4cnc7-fr0.62.1
root@raidfront mark/ >ll
ls: /lib/ld-linux.so.2: version `GLIBC_PRIVATE' not found (required by
/lib/