DVD player stopped working??? - Redhat

This is a discussion on DVD player stopped working??? - Redhat ; I'm running on FC4. The last time I could _swear_ that I recalled my laptop DVD player working was somewhere around FC1 or 2 (I normally use my standalone home player for watching movies but tested it in anticipation of ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: DVD player stopped working???

  1. DVD player stopped working???

    I'm running on FC4. The last time I could _swear_ that I recalled my
    laptop DVD player working was somewhere around FC1 or 2 (I normally
    use my standalone home player for watching movies but tested it in
    anticipation of an upcoming trip).

    Checking Google didn't turn up anything that was wildly useful other
    than to update the packages.

    I'm running the newest version of necessary ogle packages (as reported
    by updating yum).

    This is horribly frustrating as I'd like my DVD player to work (again)
    as it used to!

    Gwen

    Here is the sequence of error messages:

    [strangepork 3] goldmoon > ogle &
    [1] 2728
    [17:58 2.57]
    [strangepork 4] goldmoon > WARNING[dvd_gui]: add_keybinding(): No such
    action: 'VideoToggle'
    WARNING[dvd_gui]: add_keybinding(): No such action: 'SaveScreenshot'
    WARNING[dvd_gui]: add_keybinding(): No such action:
    'SaveScreenshotWithSPU'
    WARNING[dvd_gui]: add_keybinding(): No such action:
    'AudioStreamChange'
    WARNING[dvd_gui]: add_keybinding(): No such action:
    'SubtitleStreamChange'
    libdvdread: Using libdvdcss version 1.2.8 for DVD access
    libdvdread: Using libdvdcss version 1.2.8 for DVD access

    libdvdread: Attempting to retrieve all CSS keys
    libdvdread: This can take a _long_ time, please be patient

    libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000153
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00007b18
    libdvdread: Elapsed time 1
    libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x000095c3
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0000969c
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_02_1.VOB
    (0x0000969c)!!
    libdvdread: Elapsed time 4
    libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0008c654
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0008c72d
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_03_1.VOB
    (0x0008c72d)!!
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x0010f1f9
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x0010f2d2
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_04_1.VOB
    (0x0010f2d2)!!
    libdvdread: Elapsed time 1
    libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x001911f6
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x001912cd
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_05_1.VOB
    (0x001912cd)!!
    libdvdread: Elapsed time 3
    libdvdread: Get key for /VIDEO_TS/VTS_06_0.VOB at 0x00212554
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_06_1.VOB at 0x0021262b
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_06_1.VOB
    (0x0021262b)!!
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_07_0.VOB at 0x00294710
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_07_1.VOB at 0x002947e9
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_07_1.VOB
    (0x002947e9)!!
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_08_0.VOB at 0x00316561
    libdvdread: Elapsed time 1
    libdvdread: Get key for /VIDEO_TS/VTS_08_1.VOB at 0x0031663c
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_08_1.VOB
    (0x0031663c)!!
    libdvdread: Elapsed time 0
    libdvdread: Found 8 VTS's
    libdvdread: Elapsed time 10
    Xscreensaver not running.
    !!#!!#!!#!!##!!#!!!!!!!!!!WARNING[ogle_mpeg_ps]: dvdreadblocks only
    got 56, wanted 193
    FATAL[ogle_mpeg_ps]: dvdreadblocks failed
    ERROR[ogle_ctrl]: ogle_sysv_shmrm: Invalid argument
    [1]+ Done ogle


  2. Re: DVD player stopped working???

    Gwen Morse wrote:

    > I'm running on FC4. The last time I could _swear_ that I recalled my
    > laptop DVD player working was somewhere around FC1 or 2 (I normally
    > use my standalone home player for watching movies but tested it in
    > anticipation of an upcoming trip).
    >
    > Checking Google didn't turn up anything that was wildly useful other
    > than to update the packages.
    >
    > I'm running the newest version of necessary ogle packages (as reported
    > by updating yum).
    >
    > This is horribly frustrating as I'd like my DVD player to work (again)
    > as it used to!


    I hate to tell you this, but as far as I know there are no FC4 rpm's for
    ogle and the FC1,2,3 ogle rpm packages may not work with FC4.

    With that said may I suggest that you head over to;
    http://dag.wieers.com/packages/
    and download the packages;
    ogle-0.9.2-4.rf.src.rpm and ogle_gui-0.9.2-4.rf.src.rpm

    Satisfy the requirements and build your own with something like (Hint:
    the requirements will be presented by typing the rpmbuild commands);

    rpmbuild -ba ogle-0.9.2-rf.spec

    You need to install both the ogle and ogle-devel packages before
    building the ogle_gui with something like;

    rpmbuild -ba ogle_gui-0.9.2-rf.spec


    Results;

    $ rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n'
    'ogle*' | sort
    ogle-0.9.2-4.rf.fc4.i386.rpm
    ogle-devel-0.9.2-4.rf.fc4.i386.rpm
    ogle_gui-0.9.2-4.rf.fc4.i386.rpm

    Yes!! I modified the spec files before building.


    --
    "They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety." -- B. Franklin, 1759

  3. Re: DVD player stopped working???

    Gwen Morse wrote:

    > I'm running on FC4. The last time I could _swear_ that I recalled my
    > laptop DVD player working was somewhere around FC1 or 2 (I normally
    > use my standalone home player for watching movies but tested it in
    > anticipation of an upcoming trip).


    May I suggest visiting; http://rpm.pbone.net/ and looking for;

    $ rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n'
    'ogle*' | sort

    ogle-0.9.2-4.2.fc4.i386.rpm
    ogle-devel-0.9.2-4.2.fc4.i386.rpm
    ogle_gui-0.9.2-4.2.fc4.i386.rpm


    --
    "They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety." -- B. Franklin, 1759

+ Reply to Thread