On Tue, 29 Jun 2004 22:51:56 +0200, dsa wrote:

> **** Post for FREE via your newsreader at post.usenet.com ****
>
> Hello
> I installed Red Hat Advanced Server 2.1, and updated up2date packages
> (because of new rhn certificate) like described on
> https://rhn.redhat.com/help/latest-up2date.pxt, but when i try: update
> -u i receive:
>
> Traceback (innermost last):
> File "/usr/sbin/up2date", line 835, in ?
> main()
> File "/usr/sbin/up2date", line 623, in main
> pkgNames, fullUpdate, dryRun = dry_run))
> File "/usr/sbin/up2date", line 778, in batchRun
> batch.run()
> File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
> self.__findPackagesToUpdate()
> File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 89, in
> __findPackagesToUpdate
> plist.run()
> File "/usr/share/rhn/up2date_client/packageList.py", line 85, in run
> self.addObsoletePackages(obsList)
> File "/usr/share/rhn/up2date_client/packageList.py", line 109, in
> addObsoletePackages
> for p in obsoletePackages:
> TypeError: loop over non-sequence
>
> Why ?


https://rhn.redhat.com/errata/RHEA-2003-378.html

Pay attention to what you need;
NOTE: The rhnlib and pyOpenSSL packages listed in this erratum must also
be installed, as up2date now requires them.



--
"In short, without this exclusive franchise, called the Windows API,
we would have been dead a long time ago." M$ Senior VP Bob Muglia '96