Problems with authentication in Apache 2 on RH8 - Redhat

This is a discussion on Problems with authentication in Apache 2 on RH8 - Redhat ; Hi, I am trying to get authentication working for cgi-bin, on the default Apache that came with RedHat 8.0 (Apache 2.0.40). I have the /etc/httpd/conf/httpd.conf with the following: #AllowOverride None #Options None #Order allow,deny #Allow from all AuthType Basic AuthName ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problems with authentication in Apache 2 on RH8

  1. Problems with authentication in Apache 2 on RH8

    Hi,

    I am trying to get authentication working for cgi-bin, on the default
    Apache that came with RedHat 8.0 (Apache 2.0.40).
    I have the /etc/httpd/conf/httpd.conf with the following:

    #AllowOverride None
    #Options None
    #Order allow,deny
    #Allow from all
    AuthType Basic
    AuthName "Test"
    AuthUserFile /var/www/passwd/passwords
    Require valid-user


    I also created a /var/www/passwd directory and ran:
    htpasswd -c /var/www/passwd/passwords test
    to create a user 'test'.

    Finally, I went into Services and restarted httpd.

    Then I tried to run a script in http://localhost/cgi-bin/, which gives the
    username/password window.
    The problem is that it doesn't seem to be accepting my username/password!
    It keeps giving me the username/password window again.
    Am I missing something???

    Thanks in advance,
    Scott Navarre



  2. Re: Problems with authentication in Apache 2 on RH8

    And Scott Navarre said...

    > Hi,
    >
    > I am trying to get authentication working for cgi-bin, on the default
    > Apache that came with RedHat 8.0 (Apache 2.0.40).
    > I have the /etc/httpd/conf/httpd.conf with the following:
    >
    > #AllowOverride None
    > #Options None
    > #Order allow,deny
    > #Allow from all
    > AuthType Basic
    > AuthName "Test"
    > AuthUserFile /var/www/passwd/passwords Require valid-user

    Should be broken into 2 lines ^^^

    >
    > I also created a /var/www/passwd directory and ran:
    > htpasswd -c /var/www/passwd/passwords test
    > to create a user 'test'.
    >

    Are you sure the user apache runs at can access this file ?


  3. Re: Problems with authentication in Apache 2 on RH8

    "Nils O. Selåsdal" wrote in message
    newsan.2004.05.17.00.05.55.342102@Utel.no...
    > And Scott Navarre said...
    >
    > > Hi,
    > >
    > > I am trying to get authentication working for cgi-bin, on the default
    > > Apache that came with RedHat 8.0 (Apache 2.0.40).
    > > I have the /etc/httpd/conf/httpd.conf with the following:
    > >
    > > #AllowOverride None
    > > #Options None
    > > #Order allow,deny
    > > #Allow from all
    > > AuthType Basic
    > > AuthName "Test"
    > > AuthUserFile /var/www/passwd/passwords Require valid-user

    > Should be broken into 2 lines ^^^
    >
    > >
    > > I also created a /var/www/passwd directory and ran:
    > > htpasswd -c /var/www/passwd/passwords test
    > > to create a user 'test'.
    > >

    > Are you sure the user apache runs at can access this file ?
    >


    All I can say is "Duh!!!" :-)

    Thank you!
    I knew the passwd directory had the proper permissions, and I guess I just
    assumed that apache's htpasswd command would create the password file with
    the proper permissions for apache...

    Excuse my ignorance...



+ Reply to Thread