Error compiling RealTek RTL8139C drivers - Redhat

This is a discussion on Error compiling RealTek RTL8139C drivers - Redhat ; Hi people, I'm trying to compile drivers for a RealTek RTL8139C NIC under a fresh Fedora Core 1 installation (with kernel 2.4.22-1.2115.nptl) and isn't getting anything but a lot of error messages. The driver is available from ftp://210.51.181.211/cn/nic/rtl8139a...139cp(160).zip (official RealTek ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Error compiling RealTek RTL8139C drivers

  1. Error compiling RealTek RTL8139C drivers

    Hi people,

    I'm trying to compile drivers for a RealTek RTL8139C NIC under a fresh
    Fedora Core 1 installation (with kernel 2.4.22-1.2115.nptl) and isn't
    getting anything but a lot of error messages. The driver is available from
    ftp://210.51.181.211/cn/nic/rtl8139a...139cp(160).zip
    (official RealTek FTP).

    As you can see, there is a Makefile which contains the string
    NEW_INCLUDE_PATH, which should be edited to fit your own kernel SRC
    directory location. I've tried with NEW_INCLUDE_PATH =
    /usr/src/linux-2.4.22-1.2115.nptl/include/ and when that didn't work I also
    tried simply NEW_INCLUDE_PATH = /usr/src/linux-2.4/include/, without any
    results.

    I would really appreciate some help from someone familiar with this problem
    or problems of the same kind, and would be really glad if I'd get this
    problem solved and the driver compiled.

    Regards,

    The Sorcerer



  2. Re: Error compiling RealTek RTL8139C drivers

    On Mon, 26 Apr 2004 18:41:21 +0300, The_Sorce wrote:

    >
    > I would really appreciate some help from someone familiar with this problem
    > or problems of the same kind, and would be really glad if I'd get this
    > problem solved and the driver compiled.
    >


    Well, posting part of the error output is always a good start to get
    helped. But a few things:

    1) go to the latest kernel. You are using an old one with security holes.
    2) go the the kernel source dir and edit the Makefile. In the
    extra-version theres is custom appended to it and you need to remove it
    3) copy the proper config file from /configs to
    .config
    4) run "make menuconfig", change nothing and leave
    5) run make dep clean

    and try again.

    --
    Bas.



+ Reply to Thread