Bind won't start - serial # error - Redhat

This is a discussion on Bind won't start - serial # error - Redhat ; Hi all, Bind works out of the box, but when I attempt to add a domain.com zone I get this error: Starting named: Error in named configuration: zone localdomain/IN: loaded serial 2006110721 zone localhost/IN: loaded serial 2006110700 zone 0.0.127.in-addr.arpa/IN: loaded ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Bind won't start - serial # error

  1. Bind won't start - serial # error

    Hi all,

    Bind works out of the box, but when I attempt to add a domain.com zone
    I get this error:

    Starting named:
    Error in named configuration:
    zone localdomain/IN: loaded serial 2006110721
    zone localhost/IN: loaded serial 2006110700
    zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    zone
    0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.ip6.arpa/IN:
    loaded serial 1997022700
    zone 255.in-addr.arpa/IN: loaded serial 1997022700
    zone 0.in-addr.arpa/IN: loaded serial 199702270
    [FAILED]
    How do I find the correct serial # I'm supposed to use?

    I've tried to dig localhost and cut/paste the serial # into the zone
    files above, and tried any combination I could think, including
    incrementing the last 2 serial digits, what am I doing wrong?

    results of dig localhost:
    ; <<>> DiG 9.3.3rc2 <<>> localhost
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 48676
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;localhost. IN A

    ;; AUTHORITY SECTION:
    .. 6925 IN SOA A.ROOT-SERVERS.NET.
    NSTLD.VERISIGN-GRS.COM. 2006110700 1800 900 604800 86400

    ;; Query time: 2 msec
    ;; SERVER: 38.96.5.10#53(38.96.5.10)
    ;; WHEN: Tue Nov 7 13:17:06 2006
    ;; MSG SIZE rcvd: 102


  2. Re: Bind won't start - serial # error

    unclecameron wrote:

    > zone 255.in-addr.arpa/IN: loaded serial 1997022700
    > zone 0.in-addr.arpa/IN: loaded serial 199702270
    > [FAILED]


    My guess is that the zone 0.in-addr.arpa should have serial 1997022700.
    Isn't it missing a 0 at the end?

    --
    Regards,
    Tore

  3. Re: Bind won't start - serial # error

    I found out the serial number is the date and the last 2 digits are the
    rev, based on the number of times you reload the zone, but if I match
    the serial on those files to the results of dig localhost, they still
    fail. I've tried incrementing the number through 10 digits, but it
    still fails.

    Thanks,
    Cameron


+ Reply to Thread