Able to connect through SSH, but not pinging..... - Redhat

This is a discussion on Able to connect through SSH, but not pinging..... - Redhat ; Hi, Here in this office I have one server running on RHEL 4. And the 2nd one is at another office. When i am trying to PING the 2nd server, its not pinging. But when trying to coonet through SSH, ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Able to connect through SSH, but not pinging.....

  1. Able to connect through SSH, but not pinging.....

    Hi,
    Here in this office I have one server running on RHEL 4. And the 2nd
    one is at another office.
    When i am trying to PING the 2nd server, its not pinging. But when
    trying to coonet through SSH, its connected. I have cheaked all the
    related configuration file, all are ok..
    So what is the probable solution for this problem.. Any idea
    please...........

    ************************
    deb


  2. Re: Able to connect through SSH, but not pinging.....

    On Thu, 15 Mar 2007 07:09:01 -0700, deb wrote:

    > Hi,
    > Here in this office I have one server running on RHEL 4. And the 2nd
    > one is at another office.
    > When i am trying to PING the 2nd server, its not pinging. But when
    > trying to coonet through SSH, its connected. I have cheaked all the
    > related configuration file, all are ok..
    > So what is the probable solution for this problem.. Any idea
    > please...........
    >
    > ************************
    > deb


    Many routers/firewalls drop ICMP echo/echo reply to prevent pings as a
    security measure. The machine itself may be running firewall code which
    is doing this, or a firewall at the second site may be doing it. If you
    have root access at the second machine, you can run 'iptables' to check.


  3. Re: Able to connect through SSH, but not pinging.....

    On 15 Mar 2007, in the Usenet newsgroup linux.redhat, in article
    <1173967741.244260.102410@e65g2000hsc.googlegroups. com>, deb wrote:

    >Here in this office I have one server running on RHEL 4. And the 2nd
    >one is at another office.
    >When i am trying to PING the 2nd server, its not pinging. But when
    >trying to coonet through SSH, its connected. I have cheaked all the
    >related configuration file, all are ok..


    And what might "all the related configuration file" be? Can you ping
    the server from the other net (is this a router or firewall dropping
    ICMP echo packets because idiots are using ping to DOS the network)?

    If the server won't respond to pings from a host on the other network,
    look at the firewall configuration, and look at the contents of
    "/proc/sys/net/ipv4/icmp_echo_ignore_all" on the server.

    >So what is the probable solution for this problem..


    Remember that 'ping' is using a different protocol than SSH. See RFC0792
    for details. Network diagnostic tools like ping have been abused by
    many, and a lot of people simply firewall it off, or disable it in the
    operating system.

    Old guy

+ Reply to Thread