Trouble installing Oracle 10g on RHEL 4 - Redhat

This is a discussion on Trouble installing Oracle 10g on RHEL 4 - Redhat ; I been trying to install Oracle 10g on Red Hat Linux. The message I get is: ================================================== ==================== Starting Oracle Universal Installer... Checking installer requirements... Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2 Passed All ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Trouble installing Oracle 10g on RHEL 4

  1. Trouble installing Oracle 10g on RHEL 4

    I been trying to install Oracle 10g on Red Hat Linux. The message I
    get is:
    ================================================== ====================
    Starting Oracle Universal Installer...

    Checking installer requirements...

    Checking operating system version: must be redhat-3, SuSE-9, redhat-4,
    UnitedLinux-1.0, asianux-1 or asianux-2
    Passed


    All installer requirements met.

    Preparing to launch Oracle Universal Installer from /tmp/
    OraInstall2007-03-11_02-20-45PM. Please wait ...[oracle@atlanta
    database]$ Xlib: connection to "127.0.0.1:0.0" refused by server
    Xlib: No protocol specified

    Exception in thread "main" java.lang.InternalError: Can't connect to
    X11 window server using '127.0.0.1:0.0' as the value of the DISPLAY
    variable.
    at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
    at sun.awt.X11GraphicsEnvironment.(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at
    java.awt.GraphicsEnvironment.getLocalGraphicsEnvir onment(Unknown
    Source)
    at java.awt.Window.init(Unknown Source)
    at java.awt.Window.(Unknown Source)
    at java.awt.Frame.(Unknown Source)
    at oracle.ewt.popup.PopupFrame.(Unknown Source)
    at oracle.ewt.lwAWT.BufferedFrame.(Unknown Source)
    at
    oracle.sysman.oio.oioc.OiocOneClickInstaller.(OiocOneClickInstaller.java:
    378)
    at
    oracle.sysman.oio.oioc.OiocOneClickInstaller.main( OiocOneClickInstaller.java:
    2091)
    ================================================== ====================
    It does not matter what I use for the window server. I 'xhost +' from
    the full domain name, short name, IP address, loop back, etc. I get
    the same message ...Can't connect ... No protocol specified ... The
    Linux machine using a gnome window to access everything and I suspect
    that may be the core of the problem, but I do not know for sure.

    Any help or pointers will be appreciated.


  2. Re: Trouble installing Oracle 10g on RHEL 4

    Jack wrote:
    > I been trying to install Oracle 10g on Red Hat Linux. The message I
    > get is:




    > It does not matter what I use for the window server. I 'xhost +' from
    > the full domain name, short name, IP address, loop back, etc. I get
    > the same message ...Can't connect ... No protocol specified ... The
    > Linux machine using a gnome window to access everything and I suspect
    > that may be the core of the problem, but I do not know for sure.
    >
    > Any help or pointers will be appreciated.
    >


    Hey,

    Here are a couple of links for things to double check:

    http://tinyurl.com/2mkcu2
    http://www.orafaq.com/forum/t/74948/0/

    From looking over these, it would seem that your 'xhost +' was not done
    as the proper user... if your issue is the same.

    S.



    --

    Bill will have to take Linux from my cold, dead flippers.

    -Tux.

+ Reply to Thread