Linksys wpc54g.v3 on rh9 - Redhat

This is a discussion on Linksys wpc54g.v3 on rh9 - Redhat ; Hi all, Trying to get that card running under rh9. Tried the ndiswrapper and get these messages from 'modprobe ndiswrapper': > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol pci_set_consistent_dma_mask > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_init > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_reset_port > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_submit_nt_urb ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Linksys wpc54g.v3 on rh9

  1. Linksys wpc54g.v3 on rh9

    Hi all,

    Trying to get that card running under rh9. Tried the ndiswrapper and
    get these messages from 'modprobe ndiswrapper':

    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol pci_set_consistent_dma_mask
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_init
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_reset_port
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_submit_nt_urb
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: unresolved symbol usb_exports
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: insmod /lib/modules/2.4.20-8/misc/ndiswrapper.o fa
    > iled
    > /lib/modules/2.4.20-8/misc/ndiswrapper.o: insmod ndiswrapper failed


    Can someone tell me what is going on. The module appeared to compile
    OK. There was a warning about the 'pci_set_ . . .', but I've gotten
    similar warnings on kernel compiles that seemed to work OK.

    'ndiswrapper -l' reports that the driver and hardware are present (but
    also reports a bunch of 'unknown line' error messages). Seems like it
    might work if the module would load.

    tia,
    dave

  2. Re: Linksys wpc54g.v3 on rh9

    dave wrote:
    > Hi all,
    >
    > Trying to get that card running under rh9. Tried the ndiswrapper and
    > get these messages from 'modprobe ndiswrapper':


    RH9 is ancient, no longer supported, etc.
    For best results with wireless, you may want to install something
    current, like Fedora Core 4.

    The important thing to know is the specific chipset your card
    uses....check your dmesg output to find out.

    If your Linksys card uses the Ralink rt2400 and rt2500 chipsets, see
    http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page

  3. Re: Linksys wpc54g.v3 on rh9

    The notebook this runs on is old, has barely enough disk space for rh9 - no room for FC4.

    The documentation says the chipset is BRCM4306c0. I'm not clear what this has to do with
    errors the modules gives. Those were mostly USB errors, this is a pcmcia device.

    dave



    Rodger wrote:
    > dave wrote:
    >
    >> Hi all,
    >>
    >> Trying to get that card running under rh9. Tried the ndiswrapper and
    >> get these messages from 'modprobe ndiswrapper':

    >
    >
    > RH9 is ancient, no longer supported, etc.
    > For best results with wireless, you may want to install something
    > current, like Fedora Core 4.
    >
    > The important thing to know is the specific chipset your card
    > uses....check your dmesg output to find out.
    >
    > If your Linksys card uses the Ralink rt2400 and rt2500 chipsets, see
    > http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page



+ Reply to Thread