system-config-soundcard problem - Redhat

This is a discussion on system-config-soundcard problem - Redhat ; Hello, I get this error when running this utility as root: (in Fedora Core 4): Traceback (most recent call last): File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46, in ? app = soundcard.childWindow() File "/usr/share/system-config-soundcard/soundcard.py", line 64, in __init__ self.cardList = self.soundcardBackend.probeCards() File "/usr/share/system-config-soundcard/soundcardBackend.py", ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: system-config-soundcard problem

  1. system-config-soundcard problem

    Hello,

    I get this error when running this utility as root: (in Fedora Core 4):

    Traceback (most recent call last):
    File "/usr/share/system-config-soundcard/system-config-soundcard.py",
    line 46, in ?
    app = soundcard.childWindow()
    File "/usr/share/system-config-soundcard/soundcard.py", line 64, in
    __init__
    self.cardList = self.soundcardBackend.probeCards()
    File "/usr/share/system-config-soundcard/soundcardBackend.py", line
    111, in probeCards
    driverList = read_driver_list()
    File "/usr/share/system-config-soundcard/soundcardBackend.py", line
    48, in read_driver_list
    fd = open('/proc/asound/modules', 'r')
    IOError: [Errno 2] No such file or directory: '/proc/asound/modules'

    This problem occurs under my custom built kernel config.
    Under the stock kernel config, it works (/proc/asound/modules *is*
    present, and the soundcard is detected ok.
    I have looked through the config choices, and can find nothing to
    account for this difference.

    Any ideas?

    Thanks!
    Rodger

  2. Re: system-config-soundcard problem

    Rodger wrote:

    > Hello,
    >
    > I get this error when running this utility as root: (in Fedora Core
    > 4):
    >
    > Traceback (most recent call last):
    > File
    > "/usr/share/system-config-soundcard/system-config-soundcard.py",
    > line 46, in ?
    > app = soundcard.childWindow()
    > File "/usr/share/system-config-soundcard/soundcard.py", line 64, in
    > __init__
    > self.cardList = self.soundcardBackend.probeCards()
    > File "/usr/share/system-config-soundcard/soundcardBackend.py", line
    > 111, in probeCards
    > driverList = read_driver_list()
    > File "/usr/share/system-config-soundcard/soundcardBackend.py", line
    > 48, in read_driver_list
    > fd = open('/proc/asound/modules', 'r')
    > IOError: [Errno 2] No such file or directory: '/proc/asound/modules'
    >
    > This problem occurs under my custom built kernel config.
    > Under the stock kernel config, it works (/proc/asound/modules *is*
    > present, and the soundcard is detected ok.
    > I have looked through the config choices, and can find nothing to
    > account for this difference.
    >
    > Any ideas?


    Works just fine for me;

    $ uname -a
    Linux Laptop1700 2.6.12.4 #3 Wed Aug 10 22:12:39 EST 2005 i686 i686 i386
    GNU/Linux

    $ rpm -q system-config-services
    system-config-services-0.8.25-1

    $ ls -l /proc/asound
    total 2
    dr-xr-xr-x 9 root root 0 Aug 11 15:48 card0
    dr-xr-xr-x 5 root root 0 Aug 11 15:48 card1
    -r--r--r-- 1 root root 0 Aug 11 15:48 cards
    -r--r--r-- 1 root root 0 Aug 11 15:48 devices
    lrwxrwxrwx 1 root root 5 Aug 11 15:48 I82801DBICH4 -> card0
    lrwxrwxrwx 1 root root 5 Aug 11 15:48 Modem -> card1
    -r--r--r-- 1 root root 0 Aug 11 15:48 modules
    dr-xr-xr-x 2 root root 0 Aug 11 15:48 oss
    -r--r--r-- 1 root root 0 Aug 11 15:48 pcm
    dr-xr-xr-x 2 root root 0 Aug 11 15:48 seq
    -r--r--r-- 1 root root 0 Aug 11 15:48 timers
    -r--r--r-- 1 root root 0 Aug 11 15:48 version

    Go back and check your config file for the custom kernel, perhaps you
    missed something, the relevent portion from my config file;

    #
    # Sound
    #
    CONFIG_SOUND=m

    #
    # Advanced Linux Sound Architecture
    #
    CONFIG_SND=m
    CONFIG_SND_TIMER=m
    CONFIG_SND_PCM=m
    CONFIG_SND_SEQUENCER=m
    # CONFIG_SND_SEQ_DUMMY is not set
    CONFIG_SND_OSSEMUL=y
    CONFIG_SND_MIXER_OSS=m
    CONFIG_SND_PCM_OSS=m
    CONFIG_SND_SEQUENCER_OSS=y
    CONFIG_SND_RTCTIMER=m
    # CONFIG_SND_VERBOSE_PRINTK is not set
    # CONFIG_SND_DEBUG is not set

    #
    # Generic devices
    #
    # CONFIG_SND_DUMMY is not set
    # CONFIG_SND_VIRMIDI is not set
    # CONFIG_SND_MTPAV is not set
    # CONFIG_SND_SERIAL_U16550 is not set
    # CONFIG_SND_MPU401 is not set

    #
    # PCI devices
    #
    CONFIG_SND_AC97_CODEC=m
    # CONFIG_SND_ALI5451 is not set
    # CONFIG_SND_ATIIXP is not set
    # CONFIG_SND_ATIIXP_MODEM is not set
    # CONFIG_SND_AU8810 is not set
    # CONFIG_SND_AU8820 is not set
    # CONFIG_SND_AU8830 is not set
    # CONFIG_SND_AZT3328 is not set
    # CONFIG_SND_BT87X is not set
    # CONFIG_SND_CS46XX is not set
    # CONFIG_SND_CS4281 is not set
    # CONFIG_SND_EMU10K1 is not set
    # CONFIG_SND_EMU10K1X is not set
    # CONFIG_SND_CA0106 is not set
    # CONFIG_SND_KORG1212 is not set
    # CONFIG_SND_MIXART is not set
    # CONFIG_SND_NM256 is not set
    # CONFIG_SND_RME32 is not set
    # CONFIG_SND_RME96 is not set
    # CONFIG_SND_RME9652 is not set
    # CONFIG_SND_HDSP is not set
    # CONFIG_SND_TRIDENT is not set
    # CONFIG_SND_YMFPCI is not set
    # CONFIG_SND_ALS4000 is not set
    # CONFIG_SND_CMIPCI is not set
    # CONFIG_SND_ENS1370 is not set
    # CONFIG_SND_ENS1371 is not set
    # CONFIG_SND_ES1938 is not set
    # CONFIG_SND_ES1968 is not set
    # CONFIG_SND_MAESTRO3 is not set
    # CONFIG_SND_FM801 is not set
    # CONFIG_SND_ICE1712 is not set
    # CONFIG_SND_ICE1724 is not set
    CONFIG_SND_INTEL8X0=m
    CONFIG_SND_INTEL8X0M=m


    --
    "They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety." -- B. Franklin, 1759

  3. Re: system-config-soundcard problem

    Thank you very much, Lenard.

    There were indeed three or four differences in the ALSA section of my
    ..config, so
    I made the ALSA section of my custom kernel config file look just yours,
    and after rebuilding and rebooting, I had the /proc/asound/modules
    present. Problem solved!

    Kindest Regards,
    Rodger

  4. Re: system-config-soundcard problem

    Rodger wrote:

    > Thank you very much, Lenard.
    >
    > There were indeed three or four differences in the ALSA section of my
    > .config, so
    > I made the ALSA section of my custom kernel config file look just
    > yours, and after rebuilding and rebooting, I had the
    > /proc/asound/modules present. Problem solved!


    Your welcome, glad to know that everything is working now.


    --
    "They that can give up essential liberty to obtain a little temporary
    safety deserve neither liberty nor safety." -- B. Franklin, 1759

+ Reply to Thread