FC3 can't use CDburner - Redhat

This is a discussion on FC3 can't use CDburner - Redhat ; I have FC3 running 2.6.11-1.27_FC3smp, my CDburner is a Memorex IDE device at /dev/hdd and there are no other scsi devices on my system. I "CAN" mount an existing iso9660 cd disk using the command mount -t iso9660 /dev/hdd /mnt/cdrom ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: FC3 can't use CDburner

  1. FC3 can't use CDburner

    I have FC3 running 2.6.11-1.27_FC3smp, my CDburner is a Memorex IDE device at /dev/hdd and
    there are no other scsi devices on my system.
    I "CAN" mount an existing iso9660 cd disk using the command
    mount -t iso9660 /dev/hdd /mnt/cdrom
    But I "CANNOT" seem to get the burner to work (works fine under WinXP).
    I do not see a device called "sg" under /proc/devices like I would expect to see ...




    If I run :
    cdrecord -scanbus

    it returns:
    cdrecord: Warning: using inofficial libscg transport code version (schily -
    RedHat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright1997 J.
    Schilling').
    scsibus1:
    1,0,0 100) *
    1,1,0 101) 'Memorex ' 'DVD+/-RW Dual-X1' '1.05' Removable CD-ROM
    1,2,0 102) *
    1,3,0 103) *
    1,4,0 104) *
    1,5,0 105) *
    1,6,0 106) *
    1,7,0 107) *


    but then if I run :
    cdrecord -data dev=1,1,0 myfile.iso

    it returns :
    scsidev: '1,1,0'
    scsibus: 1 target: 1 lun: 0
    cdrecord: Success. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'.


    --------------
    can someone point me down the right path ?
    ....thanks in advance,
    Mitch





  2. Re: FC3 can't use CDburner

    On Thu, 26 May 2005 14:50:58 +0000, Mitch wrote:


    >
    > but then if I run :
    > cdrecord -data dev=1,1,0 myfile.iso

    cdrecord -data dev=ATA blah blah

  3. Re: FC3 can't use CDburner

    Alf Tanner wrote:
    > On Thu, 26 May 2005 14:50:58 +0000, Mitch wrote:
    >
    >
    >
    >>but then if I run :
    >> cdrecord -data dev=1,1,0 myfile.iso

    >
    > cdrecord -data dev=ATA blah blah

    scsidev: 'ATA'
    devname: 'ATA'
    scsibus: -2 target: -2 lun: -2
    Linux sg driver version: 3.5.27
    Using libscg version 'schily-0.8'.
    cdrecord: Warning: using inofficial libscg transport code version (schily -
    RedHat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright1997 J.
    Schilling').
    cdrecord: Cannot do inquiry for CD/DVD-Recorder.
    cdrecord: Input/output error. test unit ready: scsi sendcmd: fatal error
    CDB: 00 C0 00 00 00 00
    cmd finished after 0.000s timeout 40s

  4. Re: FC3 can't use CDburner

    On Thu, 26 May 2005 15:48:42 +0000, Mitch wrote:

    > Alf Tanner wrote:
    >> On Thu, 26 May 2005 14:50:58 +0000, Mitch wrote:
    >>
    >>
    >>
    >>>but then if I run :
    >>> cdrecord -data dev=1,1,0 myfile.iso

    >>
    >> cdrecord -data dev=ATA blah blah

    > scsidev: 'ATA'
    > devname: 'ATA'

    OK, then
    cdrecord dev=/dev/cdrom (or /dev/wherever it is)


  5. BINGO ! Re: FC3 can't use CDburner

    Alf Tanner wrote:
    > On Thu, 26 May 2005 15:48:42 +0000, Mitch wrote:
    >
    >
    >>Alf Tanner wrote:
    >>
    >>>On Thu, 26 May 2005 14:50:58 +0000, Mitch wrote:
    >>>
    >>>
    >>>
    >>>
    >>>>but then if I run :
    >>>> cdrecord -data dev=1,1,0 myfile.iso
    >>>
    >>>cdrecord -data dev=ATA blah blah

    >>
    >>scsidev: 'ATA'
    >>devname: 'ATA'

    >
    > OK, then
    > cdrecord dev=/dev/cdrom (or /dev/wherever it is)
    >


    cdrecord dev=/dev/hdd myfile.iso



    Now works great !!! Many thanks !
    ....Mitch


  6. Re: BINGO ! Re: FC3 can't use CDburner

    On Thu, 26 May 2005 15:59:30 +0000, Mitch wrote:


    >> OK, then
    >> cdrecord dev=/dev/cdrom (or /dev/wherever it is)
    >>
    >>

    > cdrecord dev=/dev/hdd myfile.iso
    >
    >
    >
    > Now works great !!! Many thanks !
    > ...Mitch

    You're welcome.

    But have you considered using k3b instead?


+ Reply to Thread