Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Lines: 22
Message-ID:
Date: Wed, 01 Nov 2006 17:53:38 GMT
NNTP-Posting-Host: 81.232.22.128
X-Complaints-To: abuse@telia.com
X-Trace: newsb.telia.net 1162403618 81.232.22.128 (Wed, 01 Nov 2006 18:53:38 CET)
NNTP-Posting-Date: Wed, 01 Nov 2006 18:53:38 CET
Organization: Telia Internet
Xref: number1.nntp.dca.giganews.com comp.lang.php:130948 comp.os.linux.misc:655257 comp.os.linux.setup:480493 comp.os.linux.questions:51499

Following the guidelines in
http://www.php.net/manual/en/install.unix.apache2.php
I thought I might add PHP5 support to Apache 2. Apache runs fine. Php
builds without the --with-apxs2 option. However when I added
'--with-apxs2=/usr/sbin/apxs \' to the Pkgfile the
php build fails ending with:

[stuff deleted]
Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

+ install -D -m 755 sapi/cgi/php
/usr/ports/contrib/php/work/pkg/usr/bin/php
install: cannot stat `sapi/cgi/php': No such file or directory
=======> ERROR: Building
'/usr/ports/contrib/php/php#5.1.6-1.pkg.tar.gz'
failed.
bash-3.1#

It seems other people have had similar problems
Thanks,
--theo