wpa_supplicant - Questions

This is a discussion on wpa_supplicant - Questions ; Anyone know anything about wpa_supplicant? My OS is Fedora Core 4 with the latest kernel 2.6.13-1.1526_FC4.stk16 I installed wpa_supplicant using the wpa_supplicant-0.3.9-8.rhfc4.at rpm package. I am running a Dell Truemobile 1350 PCMCIA card using ndiswrapper and the bcmwl5 driver. All ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: wpa_supplicant

  1. wpa_supplicant

    Anyone know anything about wpa_supplicant?

    My OS is Fedora Core 4 with the latest kernel 2.6.13-1.1526_FC4.stk16
    I installed wpa_supplicant using the wpa_supplicant-0.3.9-8.rhfc4.at rpm
    package.
    I am running a Dell Truemobile 1350 PCMCIA card using ndiswrapper and
    the bcmwl5 driver. All is fine in cleartext and using WEP.

    My AP is set to use WPA-PSK using TKIP. My passphrase is "This is a
    test". I set it to broadcast my SSID.

    My wpa conf file looks like:

    ctrl_interface=/var/run/wpa_supplicant
    ap_scan=2

    network={
    ssid="engelsman1"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    psk="This is a test"
    }

    I invoke wpa_supplicant with this command:

    $ wpa_supplicant -iwlan0 -c/etc/my_supplicant.conf -Dndiswrapper -d -w

    It almost works... I get the following output:

    Associated with 00:13:10:1f:e9:f7
    Authentication with 00:13:10:1f:e9:f7 timed out.
    Trying to associate with SSID "engelsman1"
    Disconnect event - remove keys

    Over and over and over...

    The MAC address is right, so it's seeing my AP. But the WPA
    authentication isn't happening. Anybody see what's wrong?

    TIA

    Rod

  2. Re: wpa_supplicant

    Randomthots wrote:

    > Anyone know anything about wpa_supplicant?
    >
    > My OS is Fedora Core 4 with the latest kernel
    > 2.6.13-1.1526_FC4.stk16 I installed wpa_supplicant using the
    > wpa_supplicant-0.3.9-8.rhfc4.at rpm package.
    > I am running a Dell Truemobile 1350 PCMCIA card using
    > ndiswrapper and the bcmwl5 driver. All is fine in cleartext and
    > using WEP.
    >
    > My AP is set to use WPA-PSK using TKIP. My passphrase is "This
    > is a test". I set it to broadcast my SSID.
    >
    > My wpa conf file looks like:
    >
    > ctrl_interface=/var/run/wpa_supplicant
    > ap_scan=2
    >
    > network={
    > ssid="engelsman1"
    > scan_ssid=1
    > proto=WPA
    > key_mgmt=WPA-PSK
    > pairwise=TKIP
    > psk="This is a test"
    > }
    >
    > I invoke wpa_supplicant with this command:
    >
    > $ wpa_supplicant -iwlan0 -c/etc/my_supplicant.conf -Dndiswrapper
    > -d -w
    >
    > It almost works... I get the following output:
    >
    > Associated with 00:13:10:1f:e9:f7
    > Authentication with 00:13:10:1f:e9:f7 timed out.
    > Trying to associate with SSID "engelsman1"
    > Disconnect event - remove keys
    >
    > Over and over and over...
    >
    > The MAC address is right, so it's seeing my AP. But the WPA
    > authentication isn't happening. Anybody see what's wrong?
    >
    > TIA
    >
    > Rod


    Use wpa_passphrase to encrypt your psk and enter the the encrypted
    key in your config file.

    HTH
    Ransom

    --
    For real email get public key 0xF6BB5695 from www.keyserver.net
    NO to Software Patents - http://www.ffii.org

+ Reply to Thread