help asm not working - Questions

This is a discussion on help asm not working - Questions ; Is anyone else having trouble getting inb/outb commands to work in C? Running Slackware 9.1 here. If you have a solution I could sure use it. RAZ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: help asm not working

  1. help asm not working

    Is anyone else having trouble getting inb/outb commands to work in C?
    Running Slackware 9.1 here.
    If you have a solution I could sure use it.
    RAZ

  2. Re: help asm not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Razzel wrote:
    > Is anyone else having trouble getting inb/outb commands to work in C?
    > Running Slackware 9.1 here.
    > If you have a solution I could sure use it.


    You /do/ realize that Linux (Slackware and other flavours) is a /secure/
    operating system that doesn't permit user programs to perform direct I/O
    without special permission, don't you?

    You need to run your program as root (either from the root user, or as a
    setuid root program), and you need to have the program issue an ioperm(2) or
    iopl(2) call before you try to use the outb(2) family of I/O functions.

    Are you /sure/ that your user program cannot use an existing device, and needs
    direct I/O? If so, then make your program setuid root and have it invoke the
    iopl(2)/ioperm(2) calls first.

    - --
    Lew Pitcher

    Master Codewright & JOAT-in-training | GPG public key available on request
    Registered Linux User #112576 (http://counter.li.org/)
    Slackware - Because I know what I'm doing.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)

    iD8DBQFCYa6XagVFX4UWr64RAuUVAJ0TgmE96vlrgqBkWSfnwX r8l1vOwACfT4Rk
    CCztdPwnveDHuyLfwb/GKuE=
    =l4YC
    -----END PGP SIGNATURE-----

+ Reply to Thread