Hello,

For the first time I successed to compile a linux kernel (from 2.4.26 to
2.6.11.6). Everything is working fine except from the sound module.
If I'm right I need the snd-op13sa2 module. So that's the modules I
compiled.

This what I got from lsmod.

root@linux:~# lsmod
Module Size Used by
snd_opl3_lib 9024 -
snd_hwdep 6816 -
snd_cs4231_lib 23520 -
snd_mpu401_uart 6208 -
snd_rawmidi 20000 -
snd_pcm_oss 48608 -
snd_pcm 84392 -
snd_page_alloc 7460 -
snd_mixer_oss 17376 -


There's only one module missing. (if I'm right)

root@linux:~# modprobe -c | grep opl3
alias pnp:cYMH0020dYMH0021* snd_opl3sa2
alias pnp:cYMH0030dYMH0021* snd_opl3sa2
alias pnp:cYMH0800dYMH0021* snd_opl3sa2
alias pnp:cYMH0801dYMH0021* snd_opl3sa2
alias pnp:cNMX2200dYMH2210* snd_opl3sa2
alias symbol:snd_opl3_create snd_opl3_lib
alias symbol:snd_opl3_timer_new snd_opl3_lib
alias symbol:snd_opl3_new snd_opl3_lib
alias symbol:snd_opl3_regmap snd_opl3_lib
alias symbol:snd_opl3_hwdep_new snd_opl3_lib
alias symbol:snd_opl3_init snd_opl3_lib
alias symbol:snd_opl3_reset snd_opl3_lib
alias symbol:snd_opl3_interrupt snd_opl3_lib

I don't understand all of this output but I thought I should use the
snd_op13sa2 module:
Code:
root@linux:~# modprobe snd_opl3sa2
FATAL: Error inserting snd_opl3sa2 (/lib/modules/2.6.11.6/kernel/sound/isa/snd-opl3sa2.ko): No such device
root@linux:~# cd /lib/modules/2.6.11.6/kernel/sound/isa/
root@linux:/lib/modules/2.6.11.6/kernel/sound/isa# insmod snd-opl3sa2.ko
insmod: error inserting 'snd-opl3sa2.ko': -1 No such device

emz... strange? What's wrong here? And how could I make my sound working
again?

Greetz,

Noud Aldenhoven


distro: Slackware-10.0
kernel: 2.6.11.6