Problems with dvdauthor - please help. - Questions

This is a discussion on Problems with dvdauthor - please help. - Questions ; Hi, Has anyone been able to author DVD's in Linux? I've been trying to do it for quite some time and am on the verge of giving up! I have an MPEG2 video I'd like to burn onto a DVD ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Problems with dvdauthor - please help.

  1. Problems with dvdauthor - please help.

    Hi,

    Has anyone been able to author DVD's in Linux? I've been trying to
    do it for quite some time and am on the verge of giving up!

    I have an MPEG2 video I'd like to burn onto a DVD and have this video
    divided up into "chapters" and perhaps even a menu, but the menu isn't
    as important.

    I have bee able to successfully make a DVD with KLVEmkdvd. However, it
    is one huge track. i.e. I can't jump to different sections of the video
    without having to scan through it from the beginning.

    I tried qdvdauther, which uses dvdauthor, but it fails. The last thing
    qdvdauthor does is execute the following:

    /usr/bin/dvdauthor -x "/home/george/tmp/GCFirstDVD/dvdauthor.xml"

    After that, I see the following:

    DVDAuthor::dvdauthor, version 0.6.10.
    Build options: gnugetopt magick iconv freetype fribidi
    Send bugs to

    INFO: Locale=en_US
    INFO: Converting filenames to ISO-8859-1
    INFO: dvdauthor creating VTS
    STAT: Picking VTS 01

    STAT: Processing /home/george/CC605_apple_ii_forever.mpg...
    WARN: System header found, but PCI/DSI information is not where expected
    (make sure your system header is 18 bytes!)
    WARN: Skipping sector, waiting for first VOBU...
    WARN: Skipping sector, waiting for first VOBU...
    WARN: Skipping sector, waiting for first VOBU...
    WARN: Skipping sector, waiting for first VOBU...
    ..
    ..
    ..


    The warning "WARN: Skipping sector, waiting for first VOBU..." is then
    repeated for a long time until. eventually, a segmentation fault occurs.
    It looks as though there is something wrong with some header information
    in the mpeg video. What is the 18 bytes of header information supposed
    to be (as mentioned in the warning)? Why doesn't KLVEmkdvd, or any other
    media players I use complain about this header information in the video?

    Here is information about the software I'm using:
    Linux version: Mandrake Linux 10.1 (Official)
    dvdauthor: version 0.6.10
    qdvdauthor: version 0.0.8-1


    Any help would be greatly appreciated!


    Thanks!
    George

  2. Re: Problems with dvdauthor - please help.

    Groovy hepcat George was jivin' on Tue, 21 Dec 2004 17:36:53 -0500 in
    comp.os.linux.setup.
    Problems with dvdauthor - please help.'s a cool scene! Dig it!

    > Has anyone been able to author DVD's in Linux? I've been trying to
    >do it for quite some time and am on the verge of giving up!


    I've been doing it successfully without too many problems.

    >I have an MPEG2 video I'd like to burn onto a DVD and have this video
    >divided up into "chapters" and perhaps even a menu, but the menu isn't
    >as important.
    >
    >I have bee able to successfully make a DVD with KLVEmkdvd. However, it
    >is one huge track. i.e. I can't jump to different sections of the video
    >without having to scan through it from the beginning.
    >
    >I tried qdvdauther, which uses dvdauthor, but it fails. The last thing
    >qdvdauthor does is execute the following:
    >
    >/usr/bin/dvdauthor -x "/home/george/tmp/GCFirstDVD/dvdauthor.xml"
    >
    >After that, I see the following:
    >
    >DVDAuthor::dvdauthor, version 0.6.10.
    >Build options: gnugetopt magick iconv freetype fribidi
    >Send bugs to
    >
    >INFO: Locale=en_US
    >INFO: Converting filenames to ISO-8859-1
    >INFO: dvdauthor creating VTS
    >STAT: Picking VTS 01
    >
    >STAT: Processing /home/george/CC605_apple_ii_forever.mpg...
    >WARN: System header found, but PCI/DSI information is not where expected
    > (make sure your system header is 18 bytes!)
    >WARN: Skipping sector, waiting for first VOBU...
    >WARN: Skipping sector, waiting for first VOBU...
    >WARN: Skipping sector, waiting for first VOBU...
    >WARN: Skipping sector, waiting for first VOBU...


    Looks like your MPEG file is not DVD compliant or is corrupt or
    something. How are you encoding it? Are you using transcode for this?
    What is the exact command line you're using?

    >The warning "WARN: Skipping sector, waiting for first VOBU..." is then
    >repeated for a long time until. eventually, a segmentation fault occurs.
    >It looks as though there is something wrong with some header information
    >in the mpeg video. What is the 18 bytes of header information supposed
    >to be (as mentioned in the warning)? Why doesn't KLVEmkdvd, or any other
    >media players I use complain about this header information in the video?


    Perhaps KLVEmkdvd reencodes the video or something. Or perhaps it
    simply is more relaxed about DVD compliance or is more forgiving about
    corrupt video files. I haven't used it, so I don't know.

    >Here is information about the software I'm using:
    >Linux version: Mandrake Linux 10.1 (Official)
    >dvdauthor: version 0.6.10
    >qdvdauthor: version 0.0.8-1


    You need to tell us what you're using to encode the video. That's
    where the problem lies, not in dvdauthor.

    --

    Dig the even newer still, yet more improved, sig!

    http://alphalink.com.au/~phaywood/
    "Ain't I'm a dog?" - Ronny Self, Ain't I'm a Dog, written by G. Sherry & W. Walker.
    I know it's not "technically correct" English; but since when was rock & roll "technically correct"?

  3. Re: Problems with dvdauthor - please help.

    Hi all,

    It looks like the video I was trying to write to a DVD did not have
    some information in it required by dvdauthor. I looked at the man page
    for "mpeg2enc" and the "-f" option states the following:

    -f|--format 8
    - DVD MPEG-2 for 'dvdauthor'
    This version adds special dummy navigation packets into the output
    stream that the dvdauthor tool fills in to make a proper .VOB for
    authoring. Bit-rate defaults to 7500kbps, buffer sizes to the maximum
    permitted by the DVD specification.

    This is what was missing in my mpeg file.

    I used the "tovid" tool to properly convert my mpeg and it worked! I was
    able to successfully get qdvdauthor to make a dvd for me. (mind you,
    there were some other big bugs in the qdvdauthor tool that I figured out
    how to avoid. )

    However, there was a big drop in quality from the original MPEG video
    using "tovid". It reads the mpeg and modifies it. I'm sure I could
    optimize all of the settings for mpeg2enc but there are so many and I
    know very little about mpeg files.

    What I'd like to know is what the "special dummy navigation packets" in
    the mpeg file are? If I knew this, I could add them myself without
    having to re-process the mpeg file again (and decrease the video quality).



    Thanks!
    George

    P.S. Thank you noi, Wiseguy, and Peter for your help! I really
    appreciate it!



    Peter Shaggy Haywood wrote:
    > Groovy hepcat George was jivin' on Tue, 21 Dec 2004 17:36:53 -0500 in
    > comp.os.linux.setup.
    > Problems with dvdauthor - please help.'s a cool scene! Dig it!
    >
    >
    >> Has anyone been able to author DVD's in Linux? I've been trying to
    >>do it for quite some time and am on the verge of giving up!

    >
    >
    > I've been doing it successfully without too many problems.
    >
    >
    >>I have an MPEG2 video I'd like to burn onto a DVD and have this video
    >>divided up into "chapters" and perhaps even a menu, but the menu isn't
    >>as important.
    >>
    >>I have bee able to successfully make a DVD with KLVEmkdvd. However, it
    >>is one huge track. i.e. I can't jump to different sections of the video
    >>without having to scan through it from the beginning.
    >>
    >>I tried qdvdauther, which uses dvdauthor, but it fails. The last thing
    >>qdvdauthor does is execute the following:
    >>
    >>/usr/bin/dvdauthor -x "/home/george/tmp/GCFirstDVD/dvdauthor.xml"
    >>
    >>After that, I see the following:
    >>
    >>DVDAuthor::dvdauthor, version 0.6.10.
    >>Build options: gnugetopt magick iconv freetype fribidi
    >>Send bugs to
    >>
    >>INFO: Locale=en_US
    >>INFO: Converting filenames to ISO-8859-1
    >>INFO: dvdauthor creating VTS
    >>STAT: Picking VTS 01
    >>
    >>STAT: Processing /home/george/CC605_apple_ii_forever.mpg...
    >>WARN: System header found, but PCI/DSI information is not where expected
    >> (make sure your system header is 18 bytes!)
    >>WARN: Skipping sector, waiting for first VOBU...
    >>WARN: Skipping sector, waiting for first VOBU...
    >>WARN: Skipping sector, waiting for first VOBU...
    >>WARN: Skipping sector, waiting for first VOBU...

    >
    >
    > Looks like your MPEG file is not DVD compliant or is corrupt or
    > something. How are you encoding it? Are you using transcode for this?
    > What is the exact command line you're using?
    >
    >
    >>The warning "WARN: Skipping sector, waiting for first VOBU..." is then
    >>repeated for a long time until. eventually, a segmentation fault occurs.
    >>It looks as though there is something wrong with some header information
    >>in the mpeg video. What is the 18 bytes of header information supposed
    >>to be (as mentioned in the warning)? Why doesn't KLVEmkdvd, or any other
    >>media players I use complain about this header information in the video?

    >
    >
    > Perhaps KLVEmkdvd reencodes the video or something. Or perhaps it
    > simply is more relaxed about DVD compliance or is more forgiving about
    > corrupt video files. I haven't used it, so I don't know.
    >
    >
    >>Here is information about the software I'm using:
    >>Linux version: Mandrake Linux 10.1 (Official)
    >>dvdauthor: version 0.6.10
    >>qdvdauthor: version 0.0.8-1

    >
    >
    > You need to tell us what you're using to encode the video. That's
    > where the problem lies, not in dvdauthor.
    >


  4. Re: Problems with dvdauthor - please help.

    Groovy hepcat George was jivin' on Tue, 28 Dec 2004 00:58:39 -0500 in
    comp.os.linux.setup.
    Re: Problems with dvdauthor - please help.'s a cool scene! Dig it!

    >Hi all,


    Howdy! And sorry for taking so long to get back to you!

    > It looks like the video I was trying to write to a DVD did not have
    >some information in it required by dvdauthor. I looked at the man page
    >for "mpeg2enc" and the "-f" option states the following:
    >
    >-f|--format 8
    >- DVD MPEG-2 for 'dvdauthor'
    >This version adds special dummy navigation packets into the output
    >stream that the dvdauthor tool fills in to make a proper .VOB for
    >authoring. Bit-rate defaults to 7500kbps, buffer sizes to the maximum
    >permitted by the DVD specification.
    >
    >This is what was missing in my mpeg file.
    >
    >I used the "tovid" tool to properly convert my mpeg and it worked! I was
    >able to successfully get qdvdauthor to make a dvd for me. (mind you,
    >there were some other big bugs in the qdvdauthor tool that I figured out
    >how to avoid. )
    >
    >However, there was a big drop in quality from the original MPEG video
    >using "tovid". It reads the mpeg and modifies it. I'm sure I could
    >optimize all of the settings for mpeg2enc but there are so many and I
    >know very little about mpeg files.


    I've not used tovid, so i can't help you with it. But maybe there's
    a way of specifying the bit rate. I use transcode, and although it
    uses mpeg2enc to do the actual conversion, it has a different default
    bit rate to that specified above. I have to specify the bit rate
    explicitly to get any decent quality. Maybe you need to do the same
    with tovid.

    >What I'd like to know is what the "special dummy navigation packets" in
    >the mpeg file are? If I knew this, I could add them myself without
    >having to re-process the mpeg file again (and decrease the video quality).


    I can't help you with that, i'm afraid.

    >P.S. Thank you noi, Wiseguy, and Peter for your help! I really
    >appreciate it!


    No problem.

    --

    Dig the even newer still, yet more improved, sig!

    http://alphalink.com.au/~phaywood/
    "Ain't I'm a dog?" - Ronny Self, Ain't I'm a Dog, written by G. Sherry & W. Walker.
    I know it's not "technically correct" English; but since when was rock & roll "technically correct"?

  5. Re: Problems with dvdauthor - please help.

    Peter Shaggy Haywood wrote:
    > Groovy hepcat George was jivin' on Tue, 28 Dec 2004 00:58:39 -0500 in
    > comp.os.linux.setup.
    > Re: Problems with dvdauthor - please help.'s a cool scene! Dig it!
    >
    >
    >>Hi all,

    >
    >
    > Howdy! And sorry for taking so long to get back to you!
    >
    >
    >> It looks like the video I was trying to write to a DVD did not have
    >>some information in it required by dvdauthor. I looked at the man page
    >>for "mpeg2enc" and the "-f" option states the following:
    >>
    >>-f|--format 8
    >>- DVD MPEG-2 for 'dvdauthor'
    >>This version adds special dummy navigation packets into the output
    >>stream that the dvdauthor tool fills in to make a proper .VOB for
    >>authoring. Bit-rate defaults to 7500kbps, buffer sizes to the maximum
    >>permitted by the DVD specification.
    >>
    >>This is what was missing in my mpeg file.
    >>
    >>I used the "tovid" tool to properly convert my mpeg and it worked! I was
    >>able to successfully get qdvdauthor to make a dvd for me. (mind you,
    >>there were some other big bugs in the qdvdauthor tool that I figured out
    >>how to avoid. )
    >>
    >>However, there was a big drop in quality from the original MPEG video
    >>using "tovid". It reads the mpeg and modifies it. I'm sure I could
    >>optimize all of the settings for mpeg2enc but there are so many and I
    >>know very little about mpeg files.

    >
    >
    > I've not used tovid, so i can't help you with it. But maybe there's
    > a way of specifying the bit rate. I use transcode, and although it
    > uses mpeg2enc to do the actual conversion, it has a different default
    > bit rate to that specified above. I have to specify the bit rate
    > explicitly to get any decent quality. Maybe you need to do the same
    > with tovid.


    I was asked to create a DVD with some various clips people has assembled
    on a particular topic. Unfortunately some are recorded, some are pulled
    from the net, and they are in various .avi, .wmv, .rm, .mpg etc formats,
    and some were taken with clip recordings on still cameras and are
    downsize 320x200 or something larger but not 640x480.

    The desired result is a DVD with an intro (to be recorded with whatever
    a Sony DV camera generates) and then a menu of clips to view. The small
    format clips really should be upsized to some standard size for NTSC
    viewing, since they are clips of solving problems in the field. I have
    tools to resize still images without serious artifact, I assume there
    are similar video programs and/or methods.

    Can someone point me to the the tools needed and a description of the
    steps to create such a menu and DVD? Preferably somewhere between a set
    of steps to follow blindly and hope (although I would try that) and a
    discussion of the meaning of individual bits in headers, which is only
    useful if you want to write your own application from scratch.

    If this is simply more than can be reasonably done with Linux, tell me
    now before I say I can do it ;-)

    --
    -bill davidsen (davidsen@tmr.com)
    "The secret to procrastination is to put things off until the
    last possible moment - but no longer" -me

  6. Re: Problems with dvdauthor - please help.

    Groovy hepcat Bill Davidsen was jivin' on Fri, 07 Jan 2005 19:01:26
    GMT in comp.os.linux.setup.
    Re: Problems with dvdauthor - please help.'s a cool scene! Dig it!

    >I was asked to create a DVD with some various clips people has assembled
    >on a particular topic. Unfortunately some are recorded, some are pulled
    >from the net, and they are in various .avi, .wmv, .rm, .mpg etc formats,
    >and some were taken with clip recordings on still cameras and are
    >downsize 320x200 or something larger but not 640x480.


    You can use transcode (with other tools) to resize and convert video
    to the required format. For stills, you can use gimp to do the same. I
    find the following transcode command line very useful for creating DVD
    compliant MPEG (in PAL format - for NTSC make necessary adjustments):

    transcode -V -x mplayer, raw --export_prof dvd_pal --export_par 2 -F
    "8,-H -92" -w 6000 -y mpeg2enc,mp2enc -E 48000 -i your_input_video.avi
    -o your_output_prefix

    You can adjust the quality & size by changing the video bit rate (-w
    option).

    >The desired result is a DVD with an intro (to be recorded with whatever
    >a Sony DV camera generates) and then a menu of clips to view. The small
    >format clips really should be upsized to some standard size for NTSC
    >viewing, since they are clips of solving problems in the field. I have
    >tools to resize still images without serious artifact, I assume there
    >are similar video programs and/or methods.


    Like I said, transcode can do that. So can mencoder. No doubt there
    are others.

    >Can someone point me to the the tools needed and a description of the
    >steps to create such a menu and DVD? Preferably somewhere between a set
    >of steps to follow blindly and hope (although I would try that) and a
    >discussion of the meaning of individual bits in headers, which is only
    >useful if you want to write your own application from scratch.
    >
    >If this is simply more than can be reasonably done with Linux, tell me
    >now before I say I can do it ;-)


    It's easily done, though can be a little involved and sometimes
    painstaking. Go to the following URL for a very good guide and
    discussion of the topic:

    http://forums.gentoo.org/viewtopic.php?t=117709

    --

    Dig the even newer still, yet more improved, sig!

    http://alphalink.com.au/~phaywood/
    "Ain't I'm a dog?" - Ronny Self, Ain't I'm a Dog, written by G. Sherry & W. Walker.
    I know it's not "technically correct" English; but since when was rock & roll "technically correct"?

  7. Re: Problems with dvdauthor - please help.

    Groovy hepcat Peter "Shaggy" Haywood was jivin' on Tue, 11 Jan 2005
    00:32:58 GMT in comp.os.linux.setup.
    Re: Problems with dvdauthor - please help.'s a cool scene! Dig it!

    >Groovy hepcat Bill Davidsen was jivin' on Fri, 07 Jan 2005 19:01:26
    >GMT in comp.os.linux.setup.
    >Re: Problems with dvdauthor - please help.'s a cool scene! Dig it!
    >
    >I
    >find the following transcode command line very useful for creating DVD
    >compliant MPEG (in PAL format - for NTSC make necessary adjustments):
    >
    >transcode -V -x mplayer, raw --export_prof dvd_pal --export_par 2 -F
    >"8,-H -92" -w 6000 -y mpeg2enc,mp2enc -E 48000 -i your_input_video.avi
    >-o your_output_prefix


    Oh, I forgot to mention that this will create two output streams,
    one video and one audio, with filenames your_output_prefix.m2v and
    your_output_prefix.mpa respectively. You then use mplex to multiplex
    them into a single MPEG file. See transcode and mplex man pages for
    more information.

    --

    Dig the even newer still, yet more improved, sig!

    http://alphalink.com.au/~phaywood/
    "Ain't I'm a dog?" - Ronny Self, Ain't I'm a Dog, written by G. Sherry & W. Walker.
    I know it's not "technically correct" English; but since when was rock & roll "technically correct"?

+ Reply to Thread