REPOST: How to use 3D support with SuSE Linux ? - Questions

This is a discussion on REPOST: How to use 3D support with SuSE Linux ? - Questions ; (reposted in plain text format; sorry for viewing problems in earlier post) Situation: I want to use the 3D support of my motherboard with SuSE Linux to start several applications that use this functionality (e.g. the crawling ant screensaver). I ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: REPOST: How to use 3D support with SuSE Linux ?

  1. REPOST: How to use 3D support with SuSE Linux ?

    (reposted in plain text format; sorry for viewing problems in earlier post)

    Situation: I want to use the 3D support of my motherboard with SuSE Linux
    to start several applications that use this functionality (e.g. the crawling
    ant screensaver). I am positive that the motherboard (Intel) supports 3D,
    as I've run Fedora Core 1 in the past without any 3D hitches.

    Running 3Ddiag in the terminal, I get the following....

    Tests for XFree86 configuration:
    Config File /etc/X11/XF86Config ... done.
    Driver ... done.
    Color Depth ... done.
    Extensions ... failed!
    ================================================== ==============
    3D Hardware acceleration is not used. To use 3D
    Hardware acceleration please specify these entries

    Load "dri"

    in the Section "Module" of your /etc/X11/XF86Config.
    ================================================== ==============

    I next go to the "Module" section of /etc/X11/XF86Config: and add the last
    (Load "dri") line, so that it looks like this:

    Section "Module"
    Load "type1"
    Load "speedo"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "dri"
    EndSection

    Finally, to test my configuration regarding the 3D feature, I use the
    command
    glxinfo | grep rendering

    to test if 3D is activated. The output is dissappointing, and reads:

    direct rendering: No

    What am I doing wrong? Please help.
    -G



  2. Re: REPOST: How to use 3D support with SuSE Linux ?

    "gurdude" wrote:

    > (reposted in plain text format; sorry for viewing problems in earlier post)


    thanks!!!!!!

    > Section "Module"
    > Load "type1"
    > Load "speedo"
    > Load "extmod"
    > Load "freetype"
    > Load "glx"switch2xf86_glx
    > Load "dri"
    > EndSection


    do you have this section/entry in the /etc/X11/XF86Config:

    Section "DRI"
    Mode 0666
    EndSection

    also, what is the "DefaultDepth" setting
    (should be at most '24')

    also, have you executed: 'switch2xf86_glx' ?
    --
    << http://michaeljtobler.homelinux.com/ >>
    Getting into trouble is easy. - D. Winkel and F. Prosser


  3. How does one execute 'switch2xf86_glx'

    > do you have this section/entry in the /etc/X11/XF86Config:
    >
    > Section "DRI"
    > Mode 0666
    > EndSection
    >
    > also, what is the "DefaultDepth" setting
    > (should be at most '24')
    >
    > also, have you executed: 'switch2xf86_glx' ?


    I did have the Section "DRI" entry, but the mode was 0660. I changed it to
    0666 and cannot observe any differences (problem persists). The
    "DefaultDepth" setting is 16, so that does not seem to be the problem
    either.

    How does one execute the switch2xf86_glx ? I'm a newbie, so step-by-step
    instructions would be nice.

    Thanks.
    -G



+ Reply to Thread