Hi,

On my redhat 7.3 (kernel 2.4.20-30.7 ) I am running iostat..

When I run the command iostat it gives me following result..

---------------------------------
Device: tps Blk_read/s Blk_wrtn/s Blk_read Blk_wrtn
dev3-0 35.36 3595.49 318.36 170535712 15099714
dev3-1 55.35 2920.45 225.62 138518228 10701336
------------------

When I run iostat -x the result are:

----------
Device: rrqm/s wrqm/s r/s w/s rsec/s wsec/s rkB/s wkB/s
avgrq-sz avgqu-sz await svctm %util
/dev/hda 1652.45 35.17 30.73 4.56 3591.17 318.09 1795.59
159.04 110.77 0.76 95.06 21.67 7.65
/dev/hda1 0.00 0.00 0.00 0.00 0.00 0.00 0.00 0.00
4.89 0.00 105.56 105.56 0.00
/dev/hda2 0.00 0.94 0.56 0.45 4.50 11.29 2.25 5.64
15.60 0.63 616.37 199.92 2.02
/dev/hda3 32.48 34.23 4.43 4.11 295.24 306.80 147.62 153.40
70.48 1.74 203.55 30.38 2.60
/dev/hdb 1254.53 8.75 35.84 19.42 2916.99 225.69 1458.50
112.84 56.87 1.11 193.32 14.59 8.06
/dev/hdb1 0.38 4.87 0.42 14.54 6.39 155.34 3.20 77.67
10.81 2.86 189.43 46.24 6.92
/dev/hdb2 39.11 3.88 16.12 4.88 441.92 70.35 220.96 35.17
24.39 7.03 328.38 75.15 15.78
-------------


Note the result of iostat -x command /dev/hda shows the rsec/s as
3591.17 ... However the sum of rsec/s from /dev/hda1, /dev/hda2,
/dev/hda3 is just about 300.. I am confused about where these extra
reads coming from??
The same behaviour is for /dev/hdb

I am checking these because I am facing a strange problem with my mail
server. It works normally for say around 24 hrs and then simply
freezes within fraction of seconds. Then the only option i am left
with is to reboot the server. The server is located in a remote
location and I can only ping to it when this happens, everything else
is freezed!!

I will appreciate any kind of help.

Thanks