How to mount Amiga filesystem image in i386 Linux? - Questions

This is a discussion on How to mount Amiga filesystem image in i386 Linux? - Questions ; I have an image dumped from an Amiga 2000 SCSI hard disk and I'm having trouble mounting this image on an i386 Linux (2.4.20-8) PC (not on an Amiga). Every time I try to mount it, I get the following ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: How to mount Amiga filesystem image in i386 Linux?

  1. How to mount Amiga filesystem image in i386 Linux?

    I have an image dumped from an Amiga 2000 SCSI hard disk and I'm
    having trouble mounting this image on an i386 Linux (2.4.20-8) PC (not
    on an Amiga).

    Every time I try to mount it, I get the following message:

    [root@localhost amiga-backup]# mount ./amiga.img /mnt -t affs -o loop
    mount: wrong fs type, bad option, bad superblock on /dev/loop0,
    or too many mounted file systems

    I have compiled in Amiga partition support and have successfully
    inserted the Amiga filesystem support module in my kernel. I have
    also tried mounting the actual SCSI disk instead of an image.

    Questions:
    Does AFFS support only work for big-endian (ie m68k, PPC) machines,
    and not i386?
    Am I dumping the disk correctly (dd if=/dev/sda of=amiga.img)?
    Would I have better luck trying to get this to work on my MkLinux
    system?
    My Amiga has a Nexus SCSI controller. Could this have caused
    problems?
    Why isn't this working?

    Thanks for any help

  2. Re: How to mount Amiga filesystem image in i386 Linux?


    "Bob" skrev i meddelandet
    news:ceaa9c4f.0403050435.57473ac1@posting.google.c om...
    > I have an image dumped from an Amiga 2000 SCSI hard disk and I'm
    > having trouble mounting this image on an i386 Linux (2.4.20-8) PC (not
    > on an Amiga).
    >
    > Every time I try to mount it, I get the following message:
    >
    > [root@localhost amiga-backup]# mount ./amiga.img /mnt -t affs -o loop
    > mount: wrong fs type, bad option, bad superblock on /dev/loop0,
    > or too many mounted file systems
    >
    > I have compiled in Amiga partition support and have successfully
    > inserted the Amiga filesystem support module in my kernel. I have
    > also tried mounting the actual SCSI disk instead of an image.
    >
    > Questions:
    > Does AFFS support only work for big-endian (ie m68k, PPC) machines,
    > and not i386?
    > Am I dumping the disk correctly (dd if=/dev/sda of=amiga.img)?
    > Would I have better luck trying to get this to work on my MkLinux
    > system?
    > My Amiga has a Nexus SCSI controller. Could this have caused
    > problems?
    > Why isn't this working?
    >
    > Thanks for any help


    have you tried this:

    mount -t auto

    in the Amiga hd?



+ Reply to Thread