Help Printing from WinXP to Fedora via SAMBA - Questions

This is a discussion on Help Printing from WinXP to Fedora via SAMBA - Questions ; I am running Fedora core 1 on my desktop and WinXP on a notebook. I am able to share files between the 2 machines just fine. I am having trouble printing from the WinXP machine thru SAMBA. With my current ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Help Printing from WinXP to Fedora via SAMBA

  1. Help Printing from WinXP to Fedora via SAMBA

    I am running Fedora core 1 on my desktop and WinXP on a notebook. I am
    able to share files between the 2 machines just fine. I am having trouble
    printing from the WinXP machine thru SAMBA. With my current smb.conf file
    I am able to (seemingly) install the network printers on WinXP (they are
    physically connected to the desktop) but when I go to print nothing
    happens. No error message or access denied message, just nothing. It's
    like the print job just vanishes after leaving WinXP. Can anyone help?

    I don't know if I have my linux box set up as a server correctly. Below
    is my smb.conf file, /etc/hosts file, and printcap file if it helps.

    Thanks,
    Tom

    smb.conf:
    ;*******************section global*****************
    [global]
    workgroup = mshome
    netbios name = Linux-Desktop
    server string = linux running samba 3.0.1
    hosts allow = 192.168.2. 127.
    log file = /var/log/samba/%.log
    load printers = yes
    socket options = TCP_NODELAY
    max log size = 1024
    lock directory = /var/lock/samba
    smb passwd file = /etc/samba/smbpasswd
    local master = yes
    preferred master = yes
    password server = None
    printcap name = /etc/printcap
    ;printcap name = cups
    security = SHARE
    encrypt passwords = no
    dns proxy = no
    ;*******************section homes*****************
    [homes]
    comment = Home Directories
    browseable = no
    writeable = yes
    ;*******************section printers*****************
    [printers]
    comment = All Printers
    public = yes
    path = /var/spool/samba
    browseable = yes
    writable = no
    printable = yes
    use client driver = yes
    ;*******************section tmp*****************
    [tmp]
    path = /tmp
    writeable = yes
    comment = Temporary file space
    guest ok = yes


    /etc/hosts :
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost


    printcap:
    # This file was automatically generated by cupsd(8) from the
    # /etc/cups/printers.conf file. All changes to this file
    # will be lost.

    S800LINUX|S800LINUX\
    :rm=localhost.localdomain:rp=S800LINUX:

    BJC210LINUX|BJC210LINUX\
    :rm=localhost.localdomain:rp=BJC210LINUX:



  2. Re: Help Printing from WinXP to Fedora via SAMBA

    USMC Sniper wrote in message news:...
    > I am running Fedora core 1 on my desktop and WinXP on a notebook. I am
    > able to share files between the 2 machines just fine. I am having trouble
    > printing from the WinXP machine thru SAMBA. With my current smb.conf file
    > I am able to (seemingly) install the network printers on WinXP (they are
    > physically connected to the desktop) but when I go to print nothing
    > happens. No error message or access denied message, just nothing. It's
    > like the print job just vanishes after leaving WinXP. Can anyone help?
    >


    Agree with that. I have the same configuration, using Fedora as
    printserver. Shares are OK and can be seen and used by Windows XP. The
    printer can be seen by XP, but not used (acces denied). Strange enough
    there is a folder Printer/ Faxmachines, which has an icon to the
    printer and I am able to print a testmessage in that way.

    Any help would be appreciated.

    Jan Stedehouder

  3. Re: Help Printing from WinXP to Fedora via SAMBA

    Hello!

    I have the same problem.

    I have found a possible solution in an other newsgroup. I have not tested it yet.

    This is the advice:

    Cups-

    Go to /etc/cups
    remove comment of octet-stream in mime.convs and mime.types.
    remove comment of msword in one of the two indicated files (don't remember!)


    Hope it will work.

    With kind regards

    Joerch


    USMC Sniper wrote in message news:...
    > I am running Fedora core 1 on my desktop and WinXP on a notebook. I am
    > able to share files between the 2 machines just fine. I am having trouble
    > printing from the WinXP machine thru SAMBA. With my current smb.conf file
    > I am able to (seemingly) install the network printers on WinXP (they are
    > physically connected to the desktop) but when I go to print nothing
    > happens. No error message or access denied message, just nothing. It's
    > like the print job just vanishes after leaving WinXP. Can anyone help?
    >
    > I don't know if I have my linux box set up as a server correctly. Below
    > is my smb.conf file, /etc/hosts file, and printcap file if it helps.
    >
    > Thanks,
    > Tom
    >
    > smb.conf:
    > ;*******************section global*****************
    > [global]
    > workgroup = mshome
    > netbios name = Linux-Desktop
    > server string = linux running samba 3.0.1
    > hosts allow = 192.168.2. 127.
    > log file = /var/log/samba/%.log
    > load printers = yes
    > socket options = TCP_NODELAY
    > max log size = 1024
    > lock directory = /var/lock/samba
    > smb passwd file = /etc/samba/smbpasswd
    > local master = yes
    > preferred master = yes
    > password server = None
    > printcap name = /etc/printcap
    > ;printcap name = cups
    > security = SHARE
    > encrypt passwords = no
    > dns proxy = no
    > ;*******************section homes*****************
    > [homes]
    > comment = Home Directories
    > browseable = no
    > writeable = yes
    > ;*******************section printers*****************
    > [printers]
    > comment = All Printers
    > public = yes
    > path = /var/spool/samba
    > browseable = yes
    > writable = no
    > printable = yes
    > use client driver = yes
    > ;*******************section tmp*****************
    > [tmp]
    > path = /tmp
    > writeable = yes
    > comment = Temporary file space
    > guest ok = yes
    >
    >
    > /etc/hosts :
    > # Do not remove the following line, or various programs
    > # that require network functionality will fail.
    > 127.0.0.1 localhost.localdomain localhost
    >
    >
    > printcap:
    > # This file was automatically generated by cupsd(8) from the
    > # /etc/cups/printers.conf file. All changes to this file
    > # will be lost.
    >
    > S800LINUX|S800LINUX\
    > :rm=localhost.localdomain:rp=S800LINUX:
    >
    > BJC210LINUX|BJC210LINUX\
    > :rm=localhost.localdomain:rp=BJC210LINUX:


  4. Re: Help Printing from WinXP to Fedora via SAMBA

    > I have found a possible solution in an other newsgroup. I have not tested it yet.
    Could you please tell me what newsgroup?
    > Go to /etc/cups
    > remove comment of octet-stream in mime.convs and mime.types.
    > remove comment of msword in one of the two indicated files (don't remember!)

    A little vague, but explaining which newsgroup you are talking about would
    help :-).

    Regards,
    Edward S. Rice

+ Reply to Thread