switched motherboard -> can't use CD-RW - Questions

This is a discussion on switched motherboard -> can't use CD-RW - Questions ; Ok, I switched motherboard and a new hard disk a week ago, installed a fresh copy of RedHat Linux 8 and now the CD-RW no longer works. This CD-RW worked a week ago under RedHat Linux 8 with the previous ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: switched motherboard -> can't use CD-RW

  1. switched motherboard -> can't use CD-RW

    Ok, I switched motherboard and a new hard disk a week ago, installed a
    fresh copy of RedHat Linux 8 and now the CD-RW no longer works. This
    CD-RW worked a week ago under RedHat Linux 8 with the previous
    motherboard and hard disk. Now, when I put in a disc (any disc blank
    or with data), it just keeps blinking. RedHat 8 seems to recognize the
    drive, but can't mount and none of the CD writer software works. I am
    baffled to what is the cause of the problem. Please advice on what to
    do . . . Thanks.

    cdrecord -scanbus
    Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg
    Schilling
    cdrecord: No such file or directory. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
    are root.


    hdparm /dev/hdd

    /dev/hdd:
    HDIO_GET_MULTCOUNT failed: Invalid argument
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 0 (off)
    keepsettings = 0 (off)
    readonly = 1 (on)
    readahead = 8 (on)
    HDIO_GETGEO failed: Invalid argument


    dmesg
    Linux version 2.4.18-14 (bhcompile@astest.test.redhat.com) (gcc
    version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 12:13:11
    EDT 2002
    .. . .
    Kernel command line: ro root=LABEL=/ hdc=ide-scsi
    ide_setup: hdc=ide-scsi
    .. . .
    Uniform Multi-Platform E-IDE driver Revision: 6.31
    ide: Assuming 33MHz system bus speed for PIO modes; override with
    idebus=xx
    VP_IDE: IDE controller on PCI bus 00 dev a1
    VP_IDE: chipset revision 16
    VP_IDE: not 100% native mode: will probe irqs later
    VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci00:14.1
    ide0: BM-DMA at 0xd400-0xd407, BIOS settings: hdaMA, hdbio
    ide1: BM-DMA at 0xd408-0xd40f, BIOS settings: hdcio, hddMA
    hda: WDC WD1200JB-00DUA3, ATA DISK drive
    hdd: 48X12X50 CD-RW 1.02 20021009, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63,
    UDMA(66)
    .. . .
    Partition check:
    hda: hda1 hda2 hda3
    .. . .
    hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache
    Uniform CD-ROM driver Revision: 3.12
    SCSI subsystem driver Revision: 1.00
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    .. . .
    cdrom: This disc doesn't have any tracks I recognize!

    Chieh
    --
    Camera Hacker - http://Chieh.CameraHacker.com/

  2. Re: switched motherboard -> can't use CD-RW

    On Mon, 29 Dec 2003 18:31:42 -0800, Chieh Cheng typed:

    > Ok, I switched motherboard and a new hard disk a week ago, installed a
    > fresh copy of RedHat Linux 8 and now the CD-RW no longer works. This
    > CD-RW


    > . . .
    > Kernel command line: ro root=LABEL=/ hdc=ide-scsi ide_setup:
    > hdc=ide-scsi


    > hda: WDC WD1200JB-00DUA3, ATA DISK drive hdd: 48X12X50 CD-RW 1.02


    > hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache Uniform CD-ROM driver


    Try fixing the line in /boot/grub/grub.conf to match what you see, the
    CD-RW drive is hdd which is a change. hdd=ide-scsi and not hdc=ide-scsi

    Or since you have a newer version of cdrecord, cdrecord --dev=/dev/hdd
    will work after removing ide-scsi emulation boot option from
    /etc/grub/grub.conf






    --
    SCO + RICO Act = Justice

    Hi! I'm a .sig virus! Copy me to your .sig!


  3. Re: switched motherboard -> can't use CD-RW

    Chieh Cheng wrote:

    [Problems with CD-RW]
    > VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci00:14.1
    > ide0: BM-DMA at 0xd400-0xd407, BIOS settings: hdaMA, hdbio
    > ide1: BM-DMA at 0xd408-0xd40f, BIOS settings: hdcio, hddMA
    > hda: WDC WD1200JB-00DUA3, ATA DISK drive
    > hdd: 48X12X50 CD-RW 1.02 20021009, ATAPI CD/DVD-ROM drive


    It seems that your CD-RW is running as slave (hdd) without master. That is
    not supported by the IDE standarts. Rejumber your drive as master (hdc).
    And then fix all references to hdd in your configuration files.



  4. Re: switched motherboard -> can't use CD-RW

    Lenard wrote in message news:...
    > On Mon, 29 Dec 2003 18:31:42 -0800, Chieh Cheng typed:
    >
    > > Ok, I switched motherboard and a new hard disk a week ago, installed a
    > > fresh copy of RedHat Linux 8 and now the CD-RW no longer works. This
    > > CD-RW

    >
    > > . . .
    > > Kernel command line: ro root=LABEL=/ hdc=ide-scsi ide_setup:
    > > hdc=ide-scsi

    >
    > > hda: WDC WD1200JB-00DUA3, ATA DISK drive hdd: 48X12X50 CD-RW 1.02

    >
    > > hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache Uniform CD-ROM driver

    >
    > Try fixing the line in /boot/grub/grub.conf to match what you see, the
    > CD-RW drive is hdd which is a change. hdd=ide-scsi and not hdc=ide-scsi
    >
    > Or since you have a newer version of cdrecord, cdrecord --dev=/dev/hdd
    > will work after removing ide-scsi emulation boot option from
    > /etc/grub/grub.conf



    Thanks! That fixed the problem.

    Chieh
    --
    Camera Hacker - http://www.CameraHacker.com/

  5. Re: switched motherboard -> can't use CD-RW

    Markus Kossmann wrote in message news:...
    > Chieh Cheng wrote:
    >
    > [Problems with CD-RW]
    > > VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci00:14.1
    > > ide0: BM-DMA at 0xd400-0xd407, BIOS settings: hdaMA, hdbio
    > > ide1: BM-DMA at 0xd408-0xd40f, BIOS settings: hdcio, hddMA
    > > hda: WDC WD1200JB-00DUA3, ATA DISK drive
    > > hdd: 48X12X50 CD-RW 1.02 20021009, ATAPI CD/DVD-ROM drive

    >
    > It seems that your CD-RW is running as slave (hdd) without master. That is
    > not supported by the IDE standarts. Rejumber your drive as master (hdc).
    > And then fix all references to hdd in your configuration files.


    I see. I didn't realize that it's against the standard to have a slave
    drive without a master drive. The drive seems to work now, but I'll
    change it to a master the next time I take apart the system.

    Chieh
    --
    Camera Hacker - http://www.CameraHacker.com/

  6. Re: switched motherboard -> can't use CD-RW

    On 2 Jan 2004 23:50:54 -0800, gypsymoth@mindless.com (Chieh Cheng)
    Gave us:

    >I see. I didn't realize that it's against the standard to have a slave
    >drive without a master drive. The drive seems to work now, but I'll
    >change it to a master the next time I take apart the system.
    >


    It isn't when no actual drive controller is needed for said slave,
    as in the case of the CD-ROM reader drives. Though actually, it has
    to be set to master. This is a mere flag issue in the IDE spec.

    At least, they have ALWAYS worked in WindBlows, and or DOS
    attachments. I think BeOS has no problem either.

    Sure, a proper configuration with a bona fide master is better, but
    not required.

    Even when a CD_ROM drive is set to master, there are no Integrated
    Drive Electronics (IDE) on the drive as there is no hard drive to
    master the channel.

    Ever notice how a CD-ROM drive cannot be the master on a channel,
    when there is a hard drive on with it? It cannot, becuase there is no
    real controller integrated onto a CD-ROM drive.

+ Reply to Thread