I've asked and gotten no useful replies.
I posted this message in here and in the cups groups and no one seems to
have any helpful info. Yes, I've gone through the configurations dozens
upon dozens upon dozens of time, examining every single possible
configuration option conceivable.
I've poured through every file in /etc/cups. I've poured through every file
in /etc
I've gone through printerdrake a zillion times. I've gone through MCC and
examined (and tried) every single option available.

I've check the hosts file, I've checked the resolv.conf file, I've checked
every freaking file in the box that ends with .conf

WTF?!! I would rather just get rid of cups completely at this point.
Is there a way to just totally eliminate cups and have the printer run as a
raw printer???

Here's the message I've posted in the past,


HELP! CUPS hangs PC for several mins, only while online!
From:
me
Date:
Wednesday 22 October 2003 11:20:54 pm
Groups:
cups.bugs,cups.development,cups.general
Followup-To:
cups.bugs
no references

My dad is using Mandrake 9.1 and the version of cups that was distributed
with 9.1

He uses a dial-up modem and KPPP to dial into his ISP..

When he is NOT connected to his ISP and tries to print anything it prints
instantly, there is no delay at all, you hit print and BAM!, it prints
right then.

When he is connected to his ISP via KPPP and tries to print anything at all,
CUPS says "initializing" and locks up everything for several minutes.

This is extremely annoying and my dad is just about to dump Linux and go
back to winbloz because of this annoying problem.

My neighbor also has the same problem but he uses a cable modem that's
plugged straight into his PC, no router.

I have a router and a cable modem, my PC gets dhcp info from the router
(smoothwall) at 192.168.1.1 and I do NOT have the problems they have, I
can't reproduce those problems here on my system but their machines do it
every time, 100% of the time.

I believe that the machines are trying to locate the CUPS server on the
internet through the ISP connection rather than just using the localhost.
When not connected everything resolves to localhost and you get instant
printing. When connected to ISP, cups looks everywhere else first then
after not finding a cups server at the ISP, finally times/erorrs out and
prints to localhost..

Anyone know what to do about this??

I've checked /etc/hosts to make shure localhost resolves to 127.0.0.1 and in
resolve.conf, well that changes everytime they connect, KPPP makes and
deletes DNS entries in resolve.conf as it sees fit.

I also checked in /etc/cups for the .conf files and edited them (client and
server and any other file that has the option) to define the server as
being at 127.0.0.1 and still no luck..

Thanks!!