This is apparently a problem with either window managers (KDE/GNOME et.
al) or with how the distros configure. I have been researching this
under Slackware 9 and Gnome/KDE for weeks and get nowhere. The usual
solution is permissions and ownership. In the case of Gnome some have had
luck (why is this needed when we run rockets with computers?) by
unchecking the "at server initialization" or some configuration like that
(my recall is poor on the exact terms). It seems strange to me that so
many have this type of problem with /dev/sound/mixer, /dev/mixer, and
/dev/dsp. There should be a single solution. If you get one please let
me know. I am upgrading to Slackware 9.1 next week because of this and in
hope that the problem will magically go away.
Razzle

0 wrote:

> Hi NG!
>
> After compiling the vanilla 2.4.18 kernel on my suse 7.3 I came across
> a little problem:
>
> I have installedmy Crystal Soundfusion CS42xx not as a module, but
> directly into the kernel. The soundcard is a terratec dmx Xfire 1024.
> On the original 2.4.10.SuSE, sound worked with a module, through alsa.
> now sound still works, without alsa, but I barely hear something only
> when I put my speakers the loudest possible. And it is impossible to
> change the mixer properties.
>
> I tried all mixers found in my path, wmmixer tells me something
> interesting:
>
> "wmmixer : Unable to open mixer device '/dev/mixer'.
>
> wmmixer : Sorry, no supported channels found."
>
> Anyone knowing what's going on?
>
> Thanks a lot
>
> Bernd Haller.