Glib question - Questions

This is a discussion on Glib question - Questions ; I downloaded glib 2.2.3. I ran the following commands in the location where I decompressed the src: ../configure make make check make install as root. It looks like it succeed to me as I didnt see any error msgs. Question ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Glib question

  1. Glib question

    I downloaded glib 2.2.3. I ran the following commands in the
    location where I decompressed the src:
    ../configure
    make
    make check
    make install

    as root. It looks like it succeed to me as I didnt see any error
    msgs. Question #1: how do I know for certain?

    Next, I downloaded xmms 1.2.8 and ran ./configure in the src location
    for xmms and I get this error:

    checking for GLIB - version >= 1.2.2... no
    *** The glib-config script installed by GLIB could not be found
    *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GLIB_CONFIG environment variable to the
    *** full path to glib-config.
    configure: error: *** GLIB >= 1.2.2 not installed - please install
    first ***

    I tried setting GLIB_CONFIG to /usr/local/lib where the lib files
    are. I also tried setting it to the source location but I still can't
    get xmms to configure. Question #2 is what should GLIB_CONFIG point
    to?

    I've used locate, find and which to find a glib-config file. I have
    not found anything on my system. I've read README and install in the
    glib source dir. I've been to the gtk web. Searches on google
    yielded a lot. Nothing proved helpful too me. I am really lost here.
    I would be happy to RTFM if I could just find a FM to read :=)

    I really would love to have an answer as to how to go about fixing
    this....I'm begging plz :=)

    Thanks
    Matt

  2. Re: Glib question

    matt.raffel@mindspring.com (raffelm) writes:

    I downloaded glib 2.2.3. I ran the following commands in the

    [snip]

    configure: error: *** GLIB >= 1.2.2 not installed - please install
    first ***

    Glib-1.2.2 is not just an older version of glib, you must install it
    as well as 2.2.3 to do what you're trying to do.

    Billy

  3. Re: Glib question

    Billy O'Connor wrote in message news:<84r81bafrc.fsf@dps7.oconnoronline.net>...
    > matt.raffel@mindspring.com (raffelm) writes:
    >
    > I downloaded glib 2.2.3. I ran the following commands in the
    >
    > [snip]
    >
    > configure: error: *** GLIB >= 1.2.2 not installed - please install
    > first ***
    >
    > Glib-1.2.2 is not just an older version of glib, you must install it
    > as well as 2.2.3 to do what you're trying to do.
    >
    > Billy


    Thank You!!! A billion times over In all big capital letters. :=)
    Why isnt such information available in one of the many READMEs?

    Thanks again
    Matt

+ Reply to Thread