CGI suddenly dies on RedHat 9 server - Questions

This is a discussion on CGI suddenly dies on RedHat 9 server - Questions ; Hello, I have a few basic questions and having a hard time finding some answers. I've tried various FAQs. I have a server running redhat9 and apache 2.0.40. I was having trouble getting some cgi to execute and starting experimenting ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: CGI suddenly dies on RedHat 9 server

  1. CGI suddenly dies on RedHat 9 server

    Hello,

    I have a few basic questions and having a hard time finding some
    answers. I've tried various FAQs.

    I have a server running redhat9 and apache 2.0.40. I was having
    trouble getting some cgi to execute and starting experimenting with
    permissions as root. now no cgi on the box will run for any remote
    user. I CAN run CGI from the console, however. I've tried setting
    perms to 766 for all the the cgis in cgi-bin and setting the owner to
    root.root as well as apache.apache (i'm using the default user and
    group in httpd.conf). I've indicated with a in httpd.conf
    that the folder should have the ExecCGI option enabled.

    Questions: how do I allow web users to run the cgi if 766 will not
    work?
    Can you screw up web access to cgi by resetting perms and owner in the
    way i did?

    What should I check to see what i've messed up? All the apache error
    logs tell me is a client at such and such address was denied access to
    various cgi files. duh.

    grumpy referrals to a page or document that would get me up to speed
    would be heartily accepted!

    Thanks,

    Michael Salmons
    salmonsm@missouri.edu

  2. Re: CGI suddenly dies on RedHat 9 server


    Hi, Michael:

    Have you tried looking in your httpd.conf file, or using
    redhat-config-httpd? Looking through the file, sometimes things just
    pop out obviously. Try searching for "cgi" in that file.

    Best of luck,
    John


    Michael Salmons wrote:

    > Hello,
    >
    > I have a few basic questions and having a hard time finding some
    > answers. I've tried various FAQs.
    >
    > I have a server running redhat9 and apache 2.0.40. I was having
    > trouble getting some cgi to execute and starting experimenting with
    > permissions as root. now no cgi on the box will run for any remote
    > user. I CAN run CGI from the console, however. I've tried setting
    > perms to 766 for all the the cgis in cgi-bin and setting the owner to
    > root.root as well as apache.apache (i'm using the default user and
    > group in httpd.conf). I've indicated with a in httpd.conf
    > that the folder should have the ExecCGI option enabled.
    >
    > Questions: how do I allow web users to run the cgi if 766 will not
    > work?
    > Can you screw up web access to cgi by resetting perms and owner in the
    > way i did?
    >
    > What should I check to see what i've messed up? All the apache error
    > logs tell me is a client at such and such address was denied access to
    > various cgi files. duh.
    >
    > grumpy referrals to a page or document that would get me up to speed
    > would be heartily accepted!
    >
    > Thanks,
    >
    > Michael Salmons
    > salmonsm@missouri.edu



  3. Re: CGI suddenly dies on RedHat 9 server

    Hi there,
    As I am trying to do some thing similar, I have been belting my head
    against a brick wall to, I wrote to RedHat and told them to improve
    their documents, and their $30 yearly joining fee to their help site
    is un-satasfactory (as linux world is "suppose to be freely-helpful",
    I havn't heard back, and they might post here to try to "save face!".
    Any way try below links, also if anyone else knows better, PLEASE
    SPEAK-UP! (in other words, if I go wrong feel free to jump in!),

    salmonsm@missouri.edu (Michael Salmons) wrote in message news:...
    > Hello,
    >
    > I have a few basic questions and having a hard time finding some
    > answers. I've tried various FAQs.
    >
    > I have a server running redhat9 and apache 2.0.40. I was having
    > trouble getting some cgi to execute and starting experimenting with
    > permissions as root. now no cgi on the box will run for any remote
    > user. I CAN run CGI from the console, however. I've tried setting
    > perms to 766 for all the the cgis in cgi-bin and setting the owner to
    > root.root as well as apache.apache (i'm using the default user and
    > group in httpd.conf). I've indicated with a in httpd.conf
    > that the folder should have the ExecCGI option enabled.


    First, login as root, how, when the login page apears that you enter
    your user name, simply type "root", and then , and then the
    password that you entered in setup for the root directory. This will
    get you in as root and you should have acess to most/all files.
    WARNING ROBERTSON WARNING WARNING!!!! do not change the type of files
    i.e. from mime to something else in an attempt to read, as you might
    accidently change a system file, thus damanaging startup, resulting in
    major head-aches!.
    Once in, go to /etc/http/httpd.conf and open with a text editor,
    then ( I think (thanks again to the briliant documents!) you have to
    change the settings (and then save), for reference use this
    http://httpd.apache.org/docs-2.0/howto/cgi.html
    I think that you have to make a file in your user account i.e.
    /home/"your name"/www.MyHome.com once this is done, I think that this
    is where you keep your web pages, & make a folder in that folder
    cgi-bin, i.e. /home/"your name"/www.MyHome.com/cgi-bin then change the
    settings in httpd.conf to point to that folder, reconize that folder,
    see it as a cgi folder, and allow general execution of programs (this
    I am still trying to work out).
    write a simple trial to see if works!.



    >
    > Questions: how do I allow web users to run the cgi if 766 will not
    > work?
    > Can you screw up web access to cgi by resetting perms and owner in the
    > way i did?
    >
    > What should I check to see what i've messed up? All the apache error
    > logs tell me is a client at such and such address was denied access to
    > various cgi files. duh.



    acesss rights explained above, WARNING ROBERTSON WARNING WARNING!!!!
    if you go changing you the rights of users/groups, be careful that you
    don't allow security holes, at the top of the httpd.conf file it says
    something llike "the text below is for hints only, no liability held,
    in other words your on your own." nice isn't it, even nicer if they
    actualy told you where to go to get the whole "walk through", APACHE
    note, your on REDHAT's level!.


    >
    > grumpy referrals to a page or document that would get me up to speed
    > would be heartily accepted!
    >
    > Thanks,
    >
    > Michael Salmons
    > salmonsm@missouri.edu




    I realy hope this helps as the stress of continualy crashing my
    computer is nearly enough to make me go to (dare I say it!) Windows!.
    cheers
    Andrew

+ Reply to Thread