Hello all! I'm having some difficulty getting the modem functionality
of my Xircom CardBus RBEM56G-100 to work on my Dell Latitude CPx
laptop with Mandrake Linux 9.1.

I've gone through several newsgroups and it looks like this PCI card
is hit or miss...it seems to work for some, but others like me are
having difficulty. When Linux first boots, and tries to initialize
eth0 it fails; that's the only failure I get when booting up. Once I
login, and issue the command "ls /dev/modem", the entry shows but it
is flashing in red. Then when I start up pppd with /dev/modem as the
first parameter, it tells me that /dev/modem is an invalid option. So
there's obviously a problem.

I've tried all of the following so far: I edited my config file in
/etc/pcmcia and added an entry for the modem. Like this:

card "Xircom CBEM56G-100 CardBus 10/100 Ethernet + 56K modem"
version "Xircom", "*", "CBEM56G"
bind "xircom_cb" to 0

Then I issued the command: /etc/init.d/pcmcia restart, reinserted the
card and it still didn't work.

I tried putting an alias in my /etc/modules.conf file, like this:
alias eth0 xircom_cb, rebooted and still nothing.

I tried "ifconfig eth0 up" and "ifconfig eth0 promisc" and still
nothing. pppd still tells me that /dev/modem is an invalid option.
/dev/modem still flashes in red when using the ls command, and eth0
still signifies "FAILURE" during the Linux boot process.

Any ideas from you gurus out there? Is xircom_cb the wrong driver?

Aggravated Adult