TCP Socket communication at xx:xx:00 while Vista<-->Vista - Programmer

This is a discussion on TCP Socket communication at xx:xx:00 while Vista<-->Vista - Programmer ; Hello All, I am facing strange Socket communication delay of multipal Seconds. My task is to communicate (Client - Server) via conponent of internet explorer. Where by command communication from client-server is done via socket on TCP protocol. My product ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: TCP Socket communication at xx:xx:00 while Vista<-->Vista

  1. TCP Socket communication at xx:xx:00 while Vista<-->Vista

    Hello All,

    I am facing strange Socket communication delay of multipal Seconds.

    My task is to communicate (Client - Server) via conponent of internet
    explorer.
    Where by command communication from client-server is done via socket
    on TCP protocol.

    My product need to work on multi OS (2000, XP, Server, Vista)
    I am facing communication delayed only in VISTA-VISTA combination of
    client server, when I want to send some command to Server & in return
    expecting some answers from server.
    All other combination of client-server are making communication to-
    from in 1 or 2 seconds.
    But windows Vista takes multiple seconds to reach data to server &
    samiler way to reach data back to client... whole process takes more
    then 1 minute.

    One observation I have made is
    when server clock becomes xx:xx:00(HH:MM:SS) message is read by server
    & when client clock becomes xx:xx:00(HH:MM:SS) message is read by
    client

    above 00-SS behavoiur seems stange to me. Do not know what is going
    on... as the code written is working fine for all the other
    combination, that includes Client-Server as
    VISTA-XP
    XP-VISTA
    XP-XP
    2000-VISTA
    ....
    ....
    ....

    Only in the case of VISTA-VISTA it shows me behaviour of 00-SS.

    If any one has any clue on this please show me some light.

    Thanks in advance
    Bipin Mistry.

  2. Re: TCP Socket communication at xx:xx:00 while Vista<-->Vista

    I have analized situation further in depth & found out that

    1. Triggered an event from client to get (X) data from server.
    2. When server side desktop is repainted then message is conveyed from
    client to server
    3. & on next repaint data is received by client to server.

    Initially till now Clock was getting displayed at server side & it
    chages only in minits.
    & as minit changes server sode gets repaint event & data communication
    initiated.

    Summary is at the current situation server is not getting any commands
    till self repaint is initiated.
    & I can noway force from client to make server desktop update as
    server is not hearing client messages.

    This seems to be WINDOWS VISTA feacture(BUG, from my view) not to
    communicate anything without paint kind of events.

    If any one has any idea on how this can be resolved or any view points
    then do share with me.

    Bipin Mistry.


    On Jul 25, 3:41*pm, Bipin Mistry wrote:
    > Hello All,
    >
    > I am facing strange Socket communication delay of multipal Seconds.
    >
    > My task is to communicate (Client - Server) via conponent of internet
    > explorer.
    > Where by command communication from client-server is done via socket
    > on TCP protocol.
    >
    > My product need to work on multi OS (2000, XP, Server, Vista)
    > I am facing communication delayed only in VISTA-VISTA combination of
    > client server, when I want to send some command to Server & in return
    > expecting some answers from server.
    > All other combination of client-server are making communication to-
    > from in 1 or 2 seconds.
    > But windows Vista takes multiple seconds to reach data to server &
    > samiler way to reach data back to client... whole process takes more
    > then 1 minute.
    >
    > One observation I have made is
    > when server clock becomes xx:xx:00(HH:MM:SS) message is read by server
    > & when client clock becomes xx:xx:00(HH:MM:SS) message is read by
    > client
    >
    > above 00-SS behavoiur seems stange to me. Do not know what is going
    > on... as the code written is working fine for all the other
    > combination, that includes Client-Server as
    > VISTA-XP
    > XP-VISTA
    > XP-XP
    > 2000-VISTA
    > ...
    > ...
    > ...
    >
    > Only in the case of VISTA-VISTA it shows me behaviour of 00-SS.
    >
    > If any one has any clue on this please show me some light.
    >
    > Thanks in advance
    > Bipin Mistry.



+ Reply to Thread