> I'm trying to upgrade to proftpd 1.3.1 from a previous version.* My
> config file contains the following directives:
>
>****** CharsetLocal******************* UTF-8
>****** CharsetRemote****************** CP1252


> Has mod_codeconv been deprecated or should I be looking elsewhere for
> that code?* Any guidance would be greatly appreciated.


The mod_codeconv module was never an official part of the proftpd source
distribution; it may have been added by some package maintainer.

To achieve the above functionality, you can use the proftpd-1.3.2rc1
release, and do:

./configure --enable-nls ...

This will enable the support for handling different encodings via the
mod_lang module. Thus, after compiling proftpd-1.3.2rc1 with the above
--enable-nls option, you would use the following in your proftpd.conf:


UseEncoding utf8 cp1251


to achieve the above conversion. See also the doc/modules/mod_lang.html
file, in the proftpd-1.3.2rc1 source distribution, for documentation and
details.

Hope this helps,
TJ

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I wanted only to try to live in accord with the promptings which came from
my true self. Why was that so very difficult?

-Herman Hesse

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://sourceforge.net/services/buy/index.php
_______________________________________________
ProFTPD Users List
Unsubscribe problems?
http://www.proftpd.org/list-unsub.html