--===============1088627302==
Content-Type: multipart/alternative;
boundary="=====================_424506046==.ALT"

--=====================_424506046==.ALT
Content-Type: text/plain; charset="iso-8859-1"; format=flowed
Content-Transfer-Encoding: quoted-printable

I just have to share this. When the users tell=20
you something has gone wrong with your FTP site...

_____________________________________________
From: Nnnnnnnn, Jeri
Sent: Friday, September 08, 2006 9:25 AM
To: Shinnick, Tom
Subject: Ftp permissions

Hey Tom,
I am unable to remove a folder from the ftp site:
ftp.budgie.com
UserID: frobitz
Pswd: gefloogle

I try to keep the site sync'd with our sales.
Can you give me permissions to remove and add folders to the ftp site?

Thank you,
Jeri

_____________________________________________
Subject: RE: Ftp permissions
Date: Fri, 8 Sep 2006 10:13:07 -0500
From: "Shinnick, Tom"

Which one? You should have all the permissions=20
you nee=85 Ah, found it. ? ! ? !!??

Oh, that's .... hideous.

You must be using the Internet Explorer web browser. And it has
a problem (it turns out) with files that have leading blanks in the
filenames. Here's a different file listing:
/var/opt/budgie/ftphome/budgie5/Welsh 1
-rw-rw---- 1317398 Jun 15 05:13 Welsh 1 Morning Report =
06-15-06.zip
-rw-rw---- 1370552 Jun 16 05:03 Welsh 1 Morning Report 06-16-06.zip
-rw-rw---- 1317398 Jun 15 05:13 Welsh 1 Morning Report 06-15-06.zip
-rw-rw---- 1370552 Jun 16 05:03 Welsh 1 Morning Report 06-16-06.zip

The first two are the filenames as I found them. The second two are
copies I made but dropping the leading blank in the filename. Looking
at all these in IE I couldn't see *any* difference in appearance.

And when trying to delete the files original and renamed files, there
wasn't any difference in the DELEte command that IE attempted:
budgie5 [08/Sep/2006:09:46:18] "DELE Welsh1=20
Morning Report 06-15-06.zip" 250 -
budgie5 [08/Sep/2006:09:46:23] "DELE Welsh1=20
Morning Report 06-15-06.zip" 550 -
The first delete works, the second fails, because the second doesn't
have the leading blank character of the original filename.

Anyway, I've left the filenames *without* leading blanks. I've also checked
that no _other_ files in your directories have filenames with leading=
blanks.
In fact, I looked in all the FTP accounts!

Please don't hesitate to email or call with problems,
Tom

(Well, if you _know_ they're hideous, give me some warning first=85 ;-)

--=20
Tom Shinnick
512-xxx-xxxx (c) (best)
tom.shinnick@nnnnnnnn.com=20
--=====================_424506046==.ALT
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable



I just have to share this.  When the users tell you something has
gone wrong with your FTP site...


_____________________________________________

From:   Nnnnnnnn, Jeri 

Sent:   Friday, September 08, 2006 9:25
AM

To:     Shinnick, Tom

Subject:        
Ftp permissions


Hey Tom,

I am unable to remove a folder from the ftp site:

ftp.budgie.com

UserID:  frobitz

Pswd:   gefloogle


I try to keep the site sync'd with our sales.

Can you give me permissions to remove and add folders to the ftp
site?


Thank you,

Jeri


_____________________________________________

Subject: RE: Ftp permissions

Date: Fri, 8 Sep 2006 10:13:07 -0500

From: "Shinnick, Tom"
<Tom.Shinnick@nnnnnnnn.com>


Which one?  You should have all the permissions you nee=85 Ah, found
it.  ? ! ? !!??


Oh, that's .... hideous


You must be using the Internet Explorer web browser.  And it has


a problem (it turns out) with files that have leading blanks in the

filenames.  Here's a different file listing:

  /var/opt/budgie/ftphome/budgie5/Welsh 1

    -rw-rw----    1317398 Jun 15
05:13  Welsh 1 Morning Report  06-15-06.zip

    -rw-rw----    1370552 Jun 16
05:03  Welsh 1 Morning Report 06-16-06.zip

    -rw-rw----    1317398 Jun 15 05:13
Welsh 1 Morning Report  06-15-06.zip

    -rw-rw----    1370552 Jun 16 05:03
Welsh 1 Morning Report 06-16-06.zip


The first two are the filenames as I found them.  The second
two are

copies I made but dropping the leading blank in the filename. 
Looking

at all these in IE I couldn't see *any* difference in appearance. 



And when trying to delete the files original and renamed files, there


wasn't any difference in the DELEte command that IE attempted:

    budgie5 [08/Sep/2006:09:46:18] "DELE Welsh1
Morning Report  06-15-06.zip" 250 -

    budgie5 [08/Sep/2006:09:46:23] "DELE Welsh1
Morning Report  06-15-06.zip" 550 -

The first delete works, the second fails, because the second doesn't


have the leading blank character of the original filename.


Anyway, I've left the filenames *without* leading blanks.  I've also
checked

that no _other_ files in your directories have filenames with leading
blanks. 

In fact, I looked in all the FTP accounts!


Please don't hesitate to email or call with problems,

Tom


(Well, if you _know_ they're hideous, give me some warning first=85
;-)


--

Tom Shinnick

512-xxx-xxxx (c)  (best)

tom.shinnick@nnnnnnnn.com


--=====================_424506046==.ALT--


--===============1088627302==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=...057&dat=121642
--===============1088627302==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
ProFTPD Users List
Unsubscribe problems?
http://www.proftpd.org/list-unsub.html
--===============1088627302==--