Windows not responding to echo requests from my PPP Stack - PPP

This is a discussion on Windows not responding to echo requests from my PPP Stack - PPP ; I am in the process of testing a PPP Stack that I developed. Everything is pretty much working (I am currently testing with the PPP stack that comes with Windows XP). In this scenario, I have put in a periodic ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Windows not responding to echo requests from my PPP Stack

  1. Windows not responding to echo requests from my PPP Stack

    I am in the process of testing a PPP Stack that I developed. Everything
    is pretty much working (I am currently testing with the PPP stack that
    comes with Windows XP).

    In this scenario, I have put in a periodic timer that fires to make
    sure that the PPP connection is still healthy.

    My test scenario is to run a constant ping, and then watch that LCP
    echo requests go out periodically among the ping requests/replies. What
    I am seeing is that the Pings are working great (as well as TCP/UDP
    Traffic). I see my periodic LCP Echo requests going out, but windows
    appears to be ignoring them (No reply).

    Here is the echo packet I am sending captured off the link (Snarfed
    using Ethereal)

    09 00 00 1c ef be ad e2 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f
    70


    Is this correct, From what I can tell it is. Do I have to do anything
    special with the Windows PPP Client to get it to echo-reply.

    Thanks

    -Chris


  2. Re: Windows not responding to echo requests from my PPP Stack

    Figured it out !

    My size was incorrect in my Echo packet and Windows silently discarded
    it



    -Chris


+ Reply to Thread