Hello,
Please help - I am trying to connect to a linux based system on the
network at work from my linux box. To do this i need to setup a PPPoE
session to get an IP. This works fine. Then i connect a PPTP layer to
give me an IP address on the appropriate network. This works 4 out of
five times but as i use the system to test the PPTP server i would like
to resolve why it doesn't work every 1/5. Below is a log of the
connections -from my pc. I am running Fedora 2 (2.6.7 kernel with
MPPE MPPC 1.1 patch from www.polbox.com/h/hs001/ ) and ppp 2.4.2 with
patch from afore-mentioned site. The server is running a 2.4.x kernel
with ppp 2.4.2.

Could anyone explain what is failing and how i can fix it please.

In case your wondering from the logs below - yes this is all happening
over a vlan too.

Thanks!

-James

## Bringing up Primary interface: eth5.287
Added VLAN with VID == 287 to IF -:eth5:-
Set flag on device -:eth5.287:- Should be visible in /proc/net/vlan/eth5.287


## Bringing up PPPoE interface: ppp0
using channel 13
Using interface ppp0
Connect: ppp0 <--> /dev/pts/25
rcvd [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfNak id=0x1 ]
rcvd [LCP ConfAck id=0x1 ]
rcvd [LCP ConfReq id=0x2 ]
sent [LCP ConfAck id=0x2 ]
sent [LCP EchoReq id=0x0 magic=0x27750cde]
rcvd [LCP EchoReq id=0x0 magic=0x2f398690]
sent [LCP EchoRep id=0x0 magic=0x27750cde]
rcvd [CHAP Challenge id=0x0 , name = "server"]
sent [CHAP Response id=0x0 <9e0aac908b28ad130f5abc47141bbeae0000000000000000ef ae5da2fe1f1dd8a3f998440d95646efda1f66a9ba190bf00>, name = "isys-
norma-chem@chem-vpn.nomadic.bris.ac.uk"]
rcvd [LCP EchoRep id=0x0 magic=0x2f398690]
rcvd [CHAP Success id=0x0 "S=BFF454C2992034DABF03EB1183EC35B336F9E6FE"]
sent [IPCP ConfReq id=0x1 ]
rcvd [IPCP ConfReq id=0x1 ]
sent [IPCP ConfAck id=0x1 ]
rcvd [IPCP ConfNak id=0x1 ]
sent [IPCP ConfReq id=0x2 ]
rcvd [IPCP ConfAck id=0x2 ]
not replacing existing default route to eth0 [137.222.223.250]
local IP address 172.16.12.28
remote IP address 137.222.114.225
primary DNS address 137.222.114.225
secondary DNS address 137.222.114.225
Script /etc/ppp/ip-up started (pid 3213)
Script /etc/ppp/ip-up finished (pid 3213), status = 0x0

## Setting route(s) to PPTP server: chem-vpn.nomadic.bris.ac.uk

## Bringing up PPTP Tunnel: chem-vpn.nomadic.bris.ac.uk [16/Aug/2004 17:12:16]
using channel 14
Using interface ppp1
Connect: ppp1 <--> /dev/pts/27
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfReq id=0x1 ]
sent [LCP ConfAck id=0x1 ]
rcvd [LCP ConfAck id=0x1 ]
rcvd [LCP EchoReq id=0x0 magic=0x96a329f3]
sent [LCP EchoRep id=0x0 magic=0xe572701a]
rcvd [CHAP Challenge id=0x6a <1d3bd2952fac4b720a2cfcdd59b2535b>, name = "server"]
sent [CHAP Response id=0x6a , name = "isys
-norma-chem@chem-vpn.nomadic.bris.ac.uk"]
rcvd [CHAP Success id=0x6a "S=414454D2DC574D45CBF7904BE2E45527E7136789"]
sent [CCP ConfReq id=0x1 ]
rcvd [CCP ConfReq id=0x1 ]
sent [CCP ConfAck id=0x1 ]
rcvd [IPCP ConfReq id=0x1 ]
sent [IPCP TermAck id=0x1]
sent [CCP ConfReq id=0x1 ]
rcvd [LCP TermReq id=0x2 "MPPE disabled"]
LCP terminated by peer (MPPE disabled)
sent [LCP TermAck id=0x2]
rcvd [CCP ConfReq id=0x2 ]
Discarded non-LCP packet when LCP not open
rcvd [CCP ConfAck id=0x1 ]
Discarded non-LCP packet when LCP not open
Script pptp chem-vpn.nomadic.bris.ac.uk --nolaunchpppd --loglevel 2 --localbind 172.16.12.28 finished (pid 3225), status = 0x0
Modem hangup
Connection terminated.


PPPoE has exit status 0 (because it worked)#
PPTP has exit status 16