Problems with Multilink PPP - PPP

This is a discussion on Problems with Multilink PPP - PPP ; Hi, I've been trying to get MultilinkPPP working with our ISP for sometime now under linux, but I've had no joy so far (I'm gettting errors when trying to bring up the first link of the bundle), we always end ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problems with Multilink PPP

  1. Problems with Multilink PPP

    Hi,

    I've been trying to get MultilinkPPP working with our ISP for sometime
    now under linux, but I've had no joy so far (I'm gettting errors when trying
    to bring up the first link of the bundle), we always end up with an error of
    in make_ppp_unit, already had /dev/ppp open? Couldn't attach to PPP unit 0:
    Invalid argument.

    Connecting to the ISP and multilinking the lines in Windows XP work fine, so
    it appears that the ISP is supporting mlppp correctly.

    Using pppd 2.2.4 included with Fedora Core 2 (Kernel 2.6.6-1) we are
    getting the following logs;

    --> Modem initialized.
    --> Sending: ATDxxxxxxxxxxx
    --> Waiting for carrier.
    ATDxxxxxxxxxxxxxx
    CONNECT 9600/V90/LAPM/V42BIS/28800:TX/48000:RX
    --> Carrier detected. Waiting for prompt.
    CVX Access Switch.
    Access is restricted to authorized users only.
    login:
    --> Looks like a login prompt.
    --> Sending: xxxxx
    xxxxx
    password:
    --> Looks like a password prompt.
    --> Sending: (password)
    Exiting shell, and starting PPP session.
    ~[7f]}#@!}!}!} %}!}$}%\}"}&} }*} } }%}&p)g3}'}"}(}"}1}$}%b}3})}#} }0<}*[14]
    #H~
    --> PPP negotiation detected.
    Serial connection established.
    using channel 34
    Starting negotiation on /dev/ttyS1
    sent [LCP ConfReq id=0x1
    ]
    rcvd [LCP ConfAck id=0x1
    ]
    rcvd [LCP ConfReq id=0x2
    ]
    sent [LCP ConfRej id=0x2 ]
    rcvd [LCP ConfReq id=0x3
    ]
    sent [LCP ConfAck id=0x3
    ]
    Using interface ppp0
    New bundle ppp0 created
    sent [CCP ConfReq id=0x1 ]
    sent [IPCP ConfReq id=0x1 0.0.0.0> ]
    rcvd [LCP ConfReq id=0x39
    ]
    sent [LCP ConfReq id=0x2
    ]
    sent [LCP ConfRej id=0x39 ]
    rcvd [LCP ConfAck id=0x2
    ]
    rcvd [LCP ConfReq id=0x3a
    ]
    sent [LCP ConfAck id=0x3a
    ]
    sent [PAP AuthReq id=0x1 user="empics1" password="mogintai"]
    rcvd [PAP AuthAck id=0x1 ""]
    PAP authentication succeeded
    in make_ppp_unit, already had /dev/ppp open?
    Couldn't attach to PPP unit 0: Invalid argument

    the options i've provided to pppd are;

    noauth
    show-password
    debug
    /dev/ttyS1
    #/dev/rfcomm0
    lock
    crtscts
    user "xxxxxx"
    ipcp-accept-local
    ipcp-accept-remote
    kdebug 1
    noipdefault
    defaultroute
    debug
    default-asyncmap
    usepeerdns
    nodetach
    connect "/usr/bin/wvdial --chat --config /etc/ppp/peers/id0_wvdial.conf
    gold"
    mp

    I've not found any real info regarding this problem on Google etc, so would
    much appreciate any help etc.

    Thanks

    Steve Drew



  2. Re: Problems with Multilink PPP

    Hi,

    My appologies, pppd is version 2.4.2

    Thanks

    steve

    "steve drew" wrote in message
    news:Ca6Qc.224$bi5.221@newsfe1-gui.ntli.net...
    > Hi,
    >
    > I've been trying to get MultilinkPPP working with our ISP for sometime
    > now under linux, but I've had no joy so far (I'm gettting errors when

    trying
    > to bring up the first link of the bundle), we always end up with an error

    of
    > in make_ppp_unit, already had /dev/ppp open? Couldn't attach to PPP unit

    0:
    > Invalid argument.
    >
    > Connecting to the ISP and multilinking the lines in Windows XP work fine,

    so
    > it appears that the ISP is supporting mlppp correctly.
    >
    > Using pppd 2.2.4 included with Fedora Core 2 (Kernel 2.6.6-1) we

    are
    > getting the following logs;
    >
    > --> Modem initialized.
    > --> Sending: ATDxxxxxxxxxxx
    > --> Waiting for carrier.
    > ATDxxxxxxxxxxxxxx
    > CONNECT 9600/V90/LAPM/V42BIS/28800:TX/48000:RX
    > --> Carrier detected. Waiting for prompt.
    > CVX Access Switch.
    > Access is restricted to authorized users only.
    > login:
    > --> Looks like a login prompt.
    > --> Sending: xxxxx
    > xxxxx
    > password:
    > --> Looks like a password prompt.
    > --> Sending: (password)
    > Exiting shell, and starting PPP session.
    > ~[7f]}#@!}!}!}

    %}!}$}%\}"}&} }*} } }%}&p)g3}'}"}(}"}1}$}%b}3})}#} }0<}*[14]
    > #H~
    > --> PPP negotiation detected.
    > Serial connection established.
    > using channel 34
    > Starting negotiation on /dev/ttyS1
    > sent [LCP ConfReq id=0x1
    > ]
    > rcvd [LCP ConfAck id=0x1
    > ]
    > rcvd [LCP ConfReq id=0x2
    > ]
    > sent [LCP ConfRej id=0x2 ]
    > rcvd [LCP ConfReq id=0x3
    > ]
    > sent [LCP ConfAck id=0x3
    > ]
    > Using interface ppp0
    > New bundle ppp0 created
    > sent [CCP ConfReq id=0x1 ]
    > sent [IPCP ConfReq id=0x1 > 0.0.0.0> ]
    > rcvd [LCP ConfReq id=0x39
    > ]
    > sent [LCP ConfReq id=0x2
    > ]
    > sent [LCP ConfRej id=0x39 ]
    > rcvd [LCP ConfAck id=0x2
    > ]
    > rcvd [LCP ConfReq id=0x3a
    > ]
    > sent [LCP ConfAck id=0x3a
    > ]
    > sent [PAP AuthReq id=0x1 user="empics1" password="mogintai"]
    > rcvd [PAP AuthAck id=0x1 ""]
    > PAP authentication succeeded
    > in make_ppp_unit, already had /dev/ppp open?
    > Couldn't attach to PPP unit 0: Invalid argument
    >
    > the options i've provided to pppd are;
    >
    > noauth
    > show-password
    > debug
    > /dev/ttyS1
    > #/dev/rfcomm0
    > lock
    > crtscts
    > user "xxxxxx"
    > ipcp-accept-local
    > ipcp-accept-remote
    > kdebug 1
    > noipdefault
    > defaultroute
    > debug
    > default-asyncmap
    > usepeerdns
    > nodetach
    > connect "/usr/bin/wvdial --chat --config /etc/ppp/peers/id0_wvdial.conf
    > gold"
    > mp
    >
    > I've not found any real info regarding this problem on Google etc, so

    would
    > much appreciate any help etc.
    >
    > Thanks
    >
    > Steve Drew
    >
    >




+ Reply to Thread