pppd Hangs on "No response to PAP authenticate-requests" - PPP

This is a discussion on pppd Hangs on "No response to PAP authenticate-requests" - PPP ; Hi, I'm connecting embedded board to GPRS network through GPRS modem in OpenBSD machine. I have application that sends AT commands to GPRS modem and wait for result. After that, it will execl the pppd to negotiate PPP link. Discover ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: pppd Hangs on "No response to PAP authenticate-requests"

  1. pppd Hangs on "No response to PAP authenticate-requests"

    Hi,

    I'm connecting embedded board to GPRS network through GPRS modem
    in OpenBSD machine. I have application that sends AT commands to
    GPRS modem and wait for result. After that, it will execl the pppd
    to negotiate PPP link. Discover that sometimes, pppd will hangs in
    "No response to PAP authenticate-requests". If I mannually terminate
    pppd and let the application to repeat sending AT commands and execl
    pppd again, it can get the IP address.
    Does anyone know how to let pppd terminates automatically if
    it reaches "No response to PAP authenticate-requests" stage?
    My pppd version is 2.3 patch level 5.

    My /etc/ppp/options file is
    lock
    crtscts
    nobsdcomp
    deflate 0,0
    noipdefault
    defaultroute
    novj
    debug
    name syslink
    asyncmap 0xa0000
    pap-max-authreq 3
    pap-timeout 5

    The pppd debug messages are the following
    Mar 25 11:48:04 tiger portsvr: sent [AT+CSQ\r]
    Mar 25 11:48:05 tiger portsvr: rcvd [AT+CSQ +CSQ: 14,0 OK ]
    Mar 25 11:48:05 tiger portsvr: sent [AT+CGDCONT=1,"IP","shhdb"\r]
    Mar 25 11:48:06 tiger portsvr: rcvd [AT+CGDCONT=1,"IP","shhdb" OK ]
    Mar 25 11:48:06 tiger portsvr: sent [AT+CGATT=1\r]
    Mar 25 11:48:07 tiger portsvr: rcvd [AT+CGATT=1 OK ]
    Mar 25 11:48:07 tiger portsvr: sent [ATDT*99***1#\r]
    Mar 25 11:48:08 tiger portsvr: rcvd [ATDT*99***1# CONNECT 38400
    ~^?}#@!}!}!} }6}!}$}%\}"}&} } } } }'}"}(}"}#}$@#&4~]
    Mar 25 11:48:09 tiger pppd[24158]: pppd 2.3.5 started by root, uid 0
    Mar 25 11:48:09 tiger pppd[24158]: Using interface ppp0
    Mar 25 11:48:09 tiger pppd[24158]: Connect: ppp0 <--> /dev/tty03
    Mar 25 11:48:09 tiger pppd[24158]: sent [LCP ConfReq id=0x1 0xa0000> ]
    Mar 25 11:48:09 tiger pppd[24158]: rcvd [LCP ConfRej id=0x1 0x632dfcc5>]
    Mar 25 11:48:09 tiger pppd[24158]: sent [LCP ConfReq id=0x2 0xa0000> ]
    Mar 25 11:48:09 tiger pppd[24158]: rcvd [LCP ConfAck id=0x2 0xa0000> ]
    Mar 25 11:48:11 tiger pppd[24158]: rcvd [LCP ConfReq id=0x1
    ]
    Mar 25 11:48:11 tiger pppd[24158]: sent [LCP ConfAck id=0x1
    ]
    Mar 25 11:48:11 tiger pppd[24158]: sent [PAP AuthReq id=0x1
    user="syslink" password="*"]
    Mar 25 11:48:14 tiger pppd[24158]: sent [PAP AuthReq id=0x2
    user="syslink" password="*"]
    Mar 25 11:48:17 tiger pppd[24158]: sent [PAP AuthReq id=0x3
    user="syslink" password="*"]
    Mar 25 11:48:20 tiger pppd[24158]: No response to PAP
    authenticate-requests


    Thank you for the advice.

    Goh Choon Lye

  2. Re: pppd Hangs on "No response to PAP authenticate-requests"

    Have you tried adding "updetach" to your options ?
    clgoh@willowglen.com.sg (Goh Choon Lye) wrote in message news:<21ad597e.0404072339.b4165d7@posting.google.com>...
    > Hi,
    >
    > I'm connecting embedded board to GPRS network through GPRS modem
    > in OpenBSD machine. I have application that sends AT commands to
    > GPRS modem and wait for result. After that, it will execl the pppd
    > to negotiate PPP link. Discover that sometimes, pppd will hangs in
    > "No response to PAP authenticate-requests". If I mannually terminate
    > pppd and let the application to repeat sending AT commands and execl
    > pppd again, it can get the IP address.
    > Does anyone know how to let pppd terminates automatically if
    > it reaches "No response to PAP authenticate-requests" stage?
    > My pppd version is 2.3 patch level 5.
    >
    > My /etc/ppp/options file is
    > lock
    > crtscts
    > nobsdcomp
    > deflate 0,0
    > noipdefault
    > defaultroute
    > novj
    > debug
    > name syslink
    > asyncmap 0xa0000
    > pap-max-authreq 3
    > pap-timeout 5
    >
    > The pppd debug messages are the following
    > Mar 25 11:48:04 tiger portsvr: sent [AT+CSQ\r]
    > Mar 25 11:48:05 tiger portsvr: rcvd [AT+CSQ +CSQ: 14,0 OK ]
    > Mar 25 11:48:05 tiger portsvr: sent [AT+CGDCONT=1,"IP","shhdb"\r]
    > Mar 25 11:48:06 tiger portsvr: rcvd [AT+CGDCONT=1,"IP","shhdb" OK ]
    > Mar 25 11:48:06 tiger portsvr: sent [AT+CGATT=1\r]
    > Mar 25 11:48:07 tiger portsvr: rcvd [AT+CGATT=1 OK ]
    > Mar 25 11:48:07 tiger portsvr: sent [ATDT*99***1#\r]
    > Mar 25 11:48:08 tiger portsvr: rcvd [ATDT*99***1# CONNECT 38400
    > ~^?}#@!}!}!} }6}!}$}%\}"}&} } } } }'}"}(}"}#}$@#&4~]
    > Mar 25 11:48:09 tiger pppd[24158]: pppd 2.3.5 started by root, uid 0
    > Mar 25 11:48:09 tiger pppd[24158]: Using interface ppp0
    > Mar 25 11:48:09 tiger pppd[24158]: Connect: ppp0 <--> /dev/tty03
    > Mar 25 11:48:09 tiger pppd[24158]: sent [LCP ConfReq id=0x1 > 0xa0000> ]
    > Mar 25 11:48:09 tiger pppd[24158]: rcvd [LCP ConfRej id=0x1 > 0x632dfcc5>]
    > Mar 25 11:48:09 tiger pppd[24158]: sent [LCP ConfReq id=0x2 > 0xa0000> ]
    > Mar 25 11:48:09 tiger pppd[24158]: rcvd [LCP ConfAck id=0x2 > 0xa0000> ]
    > Mar 25 11:48:11 tiger pppd[24158]: rcvd [LCP ConfReq id=0x1
    > ]
    > Mar 25 11:48:11 tiger pppd[24158]: sent [LCP ConfAck id=0x1
    > ]
    > Mar 25 11:48:11 tiger pppd[24158]: sent [PAP AuthReq id=0x1
    > user="syslink" password="*"]
    > Mar 25 11:48:14 tiger pppd[24158]: sent [PAP AuthReq id=0x2
    > user="syslink" password="*"]
    > Mar 25 11:48:17 tiger pppd[24158]: sent [PAP AuthReq id=0x3
    > user="syslink" password="*"]
    > Mar 25 11:48:20 tiger pppd[24158]: No response to PAP
    > authenticate-requests
    >
    >
    > Thank you for the advice.
    >
    > Goh Choon Lye


+ Reply to Thread