ISP connexion kppp ppp pppd - PPP

This is a discussion on ISP connexion kppp ppp pppd - PPP ; Hello 1.When i connect to internet with kppp i have this result : - dialing works - modem negociation works(V90,V44,LAPM,49333) - then there is no more exchange and there is no login dialog. - finally i have a ppd error ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: ISP connexion kppp ppp pppd

  1. ISP connexion kppp ppp pppd

    Hello

    1.When i connect to internet with kppp i have this result :

    - dialing works
    - modem negociation works(V90,V44,LAPM,49333)
    - then there is no more exchange and there is no login dialog.
    - finally i have a ppd error "...signal 15"
    - under Windows 98 SE , mdk 9.0 and 9.1 that worked fine
    -WVDIAL does not work also

    2. My config : Mandrake 9.2

    - Mandrake 9.2(kernel 2.4.22.10 or 2.4.22.26)
    - a OLITEC Speedcom V92 Ready (serial db9) modem
    - a BELKIN adapter serial-usb F5U103F
    - my modem is connected to the PC via the adapter
    - the link /dev/ttyUSB0(generated by the OS) is used by kppp
    - All parameters have default value
    - all necessary modules are installed usbcore,usbserial,belkin_sa etc
    - hardrake2 does not see the Belkin adapter but it is installed(that were
    the case under 9.0 and 9.1)
    - usbview see the Belkin adapter and the hotplug and hot unplug work fine

    3. The log files :
    3.1 lsmod result

    ++++++++++++++++++++++++++++++++++++++++++++++
    Module Size Used by Not tainted
    udf 88736 0 (autoclean)
    lp 8160 0 (autoclean) (unused)
    parport 34472 0 (autoclean) [lp]
    i810 61436 12
    agpgart 48292 7 (autoclean)
    i810_audio 25692 0 (unused)
    ac97_codec 15828 0 [i810_audio]
    soundcore 6340 0 [i810_audio]
    af_packet 14856 0 (autoclean)
    sr_mod 19384 0 (autoclean)
    floppy 55932 0
    mod_quickcam 102912 0
    videodev 7936 1 [mod_quickcam]
    usbmouse 2936 0 (unused)
    keybdev 2756 0 (unused)
    mousedev 5428 1
    hid 24164 0 (unused)
    usbkbd 4472 0 (unused)
    input 5696 0 [usbmouse keybdev mousedev hid usbkbd]
    belkin_sa 6680 0 (unused)
    usbserial 21724 0 [belkin_sa]
    nls_iso8859-15 4060 1 (autoclean)
    nls_cp850 4284 1 (autoclean)
    vfat 11820 1 (autoclean)
    fat 38040 0 (autoclean) [vfat]
    supermount 84032 2 (autoclean)
    ide-cd 33956 0
    cdrom 32608 0 [sr_mod ide-cd]
    ide-scsi 11376 0
    scsi_mod 106176 2 [sr_mod ide-scsi]
    printer 8576 1
    usb-uhci 25136 0 (unused)
    usbcore 74988 1 [mod_quickcam usbmouse hid usbkbd
    belkin_sa usbserial printer usb-uhci]
    rtc 9004 0 (autoclean)
    ext3 60048 2
    jbd 39264 2 [ext3]

    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++

    3.2 pppd logfile

    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++
    Nov 4 13:36:49 localhost pppd[2145]: pppd 2.4.1 started by root, uid 0
    Nov 4 13:37:18 localhost pppd[2145]: Terminating on signal 15.
    Nov 4 13:37:18 localhost pppd[2145]: Couldn't set tty to PPP discipline:
    Interrupted system call
    Nov 4 13:37:18 localhost pppd[2145]: tcsetattr: No such device
    Nov 4 13:37:18 localhost pppd[2145]: Exit.
    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++

    3.3 Console file

    the messages sent to the console during the connexion
    -see the STRANGE MESSAGES "Couldn't find interface ppp0: No such device" and
    "insmod ppp0 failed"

    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++
    [root@localhost root]# kppp
    Loading required GL library /usr/X11R6/lib/libGL.so.1.2
    Opener: received SetSecret
    Opener: received SetSecret
    Opener: received OpenLock

    Opener: received OpenDevice
    Opener: received ExecPPPDaemon
    In parent: pppd pid 2237
    Couldn't find interface ppp0: No such device
    Kernel supports ppp alright.
    Couldn't find interface ppp0: No such device
    ----------------------------------------------------------------------------
    -
    Couldn't find interface ppp0: No such device
    ----------------------------------------------------------------------------
    --
    --------------------cut by me (it is very long)
    Couldn't find interface ppp0: No such device
    Opener: received KillPPPDaemon
    In killpppd(): Sending SIGTERM to 2237
    It was pppd that died
    pppd exited with return value 1
    Sending 2193 a SIGUSR1
    Opener: received RemoveSecret
    Opener: received RemoveSecret
    Opener: received OpenResolv
    Opener: received OpenResolv
    Opener: received RemoveLock
    Opener: received OpenSysLog
    Jan 19 18:06:54 localhost kernel: CSLIP: code copyright 1989 Regents of the
    University of California
    Jan 19 18:06:54 localhost insmod: insmod: a module named slhc already exists
    ----------------------------------------------------------------------------
    ---
    Jan 19 18:06:54 localhost modprobe: modprobe: insmod ppp0 failed
    ----------------------------------------------------------------------------
    ---
    Jan 19 18:06:54 localhost kernel: PPP generic driver version 2.4.2
    Jan 19 18:06:54 localhost pppd[2237]: pppd 2.4.1 started by root, uid 0
    Jan 19 18:07:24 localhost pppd[2237]: Terminating on signal 15.
    Jan 19 18:07:24 localhost pppd[2237]: Couldn't set tty to PPP discipline:
    Interrupted system call
    Jan 19 18:07:24 localhost pppd[2237]: tcsetattr: No such device
    Jan 19 18:07:24 localhost pppd[2237]: Exit.
    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++

    If anyone has an idea i would appreciate.

    Thanks

    Philippe





  2. Re: ISP connexion kppp ppp pppd

    "Philippe ROUBACH" writes:

    ]Hello

    First you have to figure out if Linux sees your modem at all.
    A simple test is
    cat -v '' AT OK /dev/ttyS1
    where you replace ttyS1 by the location of your modem. If this comes
    back in a second or so, your system is seeing the modem. If not, if it
    takes say 15 sec to come back, then you cannot see your modem. The first
    thing you have to do is fix this. It is hopeless to try to use ppp if
    your modem cannot be found.



    ]2. My config : Mandrake 9.2

    ]- Mandrake 9.2(kernel 2.4.22.10 or 2.4.22.26)
    ]- a OLITEC Speedcom V92 Ready (serial db9) modem
    ]- a BELKIN adapter serial-usb F5U103F
    ]- my modem is connected to the PC via the adapter
    ]- the link /dev/ttyUSB0(generated by the OS) is used by kppp

    Your modem may also be a winmodem.

  3. Re: ISP connexion kppp ppp pppd

    Thank you but if you see the chap 1 of the definition of problem you'll see
    that dialing works and modem negociation works.So i assume the problem is
    somewhere else isn't it?

    Bill Unruh a écrit dans le message :
    c0hcjl$npt$1@string.physics.ubc.ca...
    > "Philippe ROUBACH" writes:
    >
    > ]Hello
    >
    > First you have to figure out if Linux sees your modem at all.
    > A simple test is
    > cat -v '' AT OK /dev/ttyS1
    > where you replace ttyS1 by the location of your modem. If this comes
    > back in a second or so, your system is seeing the modem. If not, if it
    > takes say 15 sec to come back, then you cannot see your modem. The first
    > thing you have to do is fix this. It is hopeless to try to use ppp if
    > your modem cannot be found.
    >
    >
    >
    > ]2. My config : Mandrake 9.2
    >
    > ]- Mandrake 9.2(kernel 2.4.22.10 or 2.4.22.26)
    > ]- a OLITEC Speedcom V92 Ready (serial db9) modem
    > ]- a BELKIN adapter serial-usb F5U103F
    > ]- my modem is connected to the PC via the adapter
    > ]- the link /dev/ttyUSB0(generated by the OS) is used by kppp
    >
    > Your modem may also be a winmodem.




+ Reply to Thread