Hello
I've a problem with a solaris 2.7 server running pppd 2.3.11. Several
times I receive the next error:

Unsupported protocol 'IP' (0x21) received

This error appears when a igmp packet arrives before ip-up script has
finished.
Then a Protocol Reject frame is sent.
If the igmp packet arrive after ip-up script has finished, then
connection progress correctly

Does anybody know what's the cause of this problem?

Jul 29 02:43:06 nsgssbe2 pppd[633]: local IP address 217.124.42.140
Jul 29 02:43:06 nsgssbe2 pppd[633]: remote IP address 213.0.186.34
Jul 29 02:43:06 nsgssbe2 pppd[633]: Script ip-up started (pid 660)
Jul 29 02:43:06 nsgssbe2 pppd[633]: rcvd [IP data] 45 00 00 1c 37 08
00 00 ...
Jul 29 02:43:06 nsgssbe2 pppd[633]: Unsupported protocol 'IP' (0x21)
received
Jul 29 02:43:06 nsgssbe2 pppd[633]: sent [LCP ProtRej id=0x2 00 21 45
00 00 1c 37 08 00 00 01 02 13 b4 d5 00 ba 22 e0 00 00 01 11 64
ee 9b 00 00 00 00]
Jul 29 02:43:06 nsgssbe2 pppd[633]: rcvd [IPCP TermReq id=0x2]
Jul 29 02:43:06 nsgssbe2 pppd[633]: IPCP terminated by peer
Jul 29 02:43:06 nsgssbe2 pppd[633]: sent [IPCP TermAck id=0x2]
Jul 29 02:43:06 nsgssbe2 pppd[633]: rcvd [LCP TermReq id=0x4]
Jul 29 02:43:06 nsgssbe2 pppd[633]: LCP terminated by peer
Jul 29 02:43:06 nsgssbe2 pppd[633]: sent [LCP TermAck id=0x4]
Jul 29 02:43:09 nsgssbe2 pppd[633]: Connection terminated.
Jul 29 02:43:09 nsgssbe2 pppd[633]: Connect time 0.1 minutes.
Jul 29 02:43:09 nsgssbe2 pppd[633]: Sent 351 bytes, received 390
bytes.

Regards, Diego