Hi!

I use pppd-2.4.1 on slackware 8.1, 2.4.18 to dial on demand to my ISP
via DSL (TDSL).
At home it works fine, i have a gateway, cfg. is below.

Now i wanted to copy the conf. to my notebook (same linux, but maybe
another kernel conf.- i cant find out, i deleted the kernel sources
because of lack of space and because i thought i would give it up soon,
i have a new nb, but not working yet.)

I want to do this to be able to connect to the internet at my
girlfriends home, she has a new DSL account but not yet conf. on SuSE linux.

My aim for now is to get my laptop connected.

I try to compare the two boxes:

Same on both:

modules:
pppoe 6640 1
pppox 1104 1 [pppoe]
ppp_deflate 39456 0 (unused)
ppp_async 6096 0 (unused)
ppp_generic 14112 3 [pppoe pppox ppp_deflate ppp_async]
slhc 4480 0 [ppp_generic]

ppp/options:




syslog:
### 1. same on both:
## many modules not found, ie. escape
# crtscts nocrtscts cdtrcts nocdtrcts xonxoff modem local sync vj
# which arent needed, right?
May 9 17:07:57 groovemobil pppd[192]: Couldn't increase MTU to 1500.
May 9 17:07:57 groovemobil pppd[192]: Couldn't increase MRU to 1500


differences:
2. This is on the problem box:
May 9 17:07:56 groovemobil modprobe: modprobe: Safe mode parameter
starts with '-'
May 9 18:41:18 groovemobil pppd[394]: LCP: timeout sending Config-Requests


3. the fine box:
Jul 18 12:45:13 grooveway pppd[4250]: tdb_store failed: Success
Jul 18 12:45:13 grooveway pppd[4250]: tdb_store key failed: Success
Jul 18 12:45:13 grooveway pppd[4250]: tdb_store failed: Success
Jul 18 12:45:13 grooveway pppd[4250]: Local IP address changed to
217.84.105.122
Jul 18 12:45:13 grooveway pppd[4250]: tdb_store failed: Success
Jul 18 12:45:13 grooveway pppd[4250]: Remote IP address changed to
217.5.98.38
Jul 18 12:45:13 grooveway pppd[4250]: tdb_store failed: Success
Jul 18 13:12:18 grooveway pppd[4340]: not replacing existing default
route to ppp0 [217.5.98.38]
### -> many warnings, but working


my options:
plugin pppoe.so
demand
connect /bin/true
debug
#ipcp-accept-remote
#ipcp-accept-local
idle 3600 # nach 3600 Sekunden ohne Datenverkehr wird aufgelegt
noipdefault
defaultroute

auth. is via pap, dont know why not chap.

When i start
pppd eth0
i get:
Plugin pppoe.so loaded.
PPPoE Plugin Initialized


ifconfig
ppp0 Link encap:Point-to-Point Protocol
inet addr:10.64.64.64 P-t-P:10.112.112.112 Mask:255.255.255.255

What "special" IP is 10.64.64.64 ?? I've come over it several times.

I checked the ppp-howto, the FAQ and google for a time, but no
inspirations yet.



so far by now.
I hope you can advise me what i could try next.

BTW, ethernet is fine of course.


TIA,
cheers,

Florian



--
Florian Konnertz --- http://www.florian-konnertz.de
http://openspirit.homelinux.net/noowiki/FrontPage
ZWiki about all topics, especially consciousness research
and wisdom traditions