Strange Netatalk 1.6.4 problem - Powerpc

This is a discussion on Strange Netatalk 1.6.4 problem - Powerpc ; After a system crash, netatalk started behaving strangley. I could connect to a share, but nothing would be visible within the share. After reading I post I found at the SF netatalk section, I removed the db files from the ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Strange Netatalk 1.6.4 problem

  1. Strange Netatalk 1.6.4 problem

    After a system crash, netatalk started behaving strangley. I could
    connect to a share, but nothing would be visible within the share. After
    reading I post I found at the SF netatalk section, I removed the db
    files from the share, and restarted netatalk. Now I can see the files
    and folders within the share, but no one else can. I am owner of the
    share and its files and folders, I'm not sure if that makes a difference
    or not. Although they are part of a group that has r/w privs on the
    share. The log shows this error when they try to connect:
    Apr 27 17:16:26 [afpd] [enumerate.c:83]: E:AFPDaemon: adddir: Incorrect
    parameters passed to cnid_add

    Another odd thing is that if one of the affected users tries to create a
    new folder or place a file on the share, they get the error:
    "The command could not be completed because of a system error -50"

    Which is a parameter error, consistent with the error posted above. But
    if I then look at the share, I will see the new folder or file that was
    placed there. I've tried upgrading to 2.01 and downgrading to 1.5.3, but
    no luck, smae problem. I know netatalk uses berkdb as a backend and I
    figure its corrupt, but I have no idea how to fix it.
    Anyone have any ideas?
    TIA

    --
    "My Break-Dancing days are over, but there's always the Funky Chicken"
    --The Full Monty

  2. Re: Strange Netatalk 1.6.4 problem (Solved)

    In article
    ,
    Lorenzo wrote:

    > After a system crash, netatalk started behaving strangley. I could
    > connect to a share, but nothing would be visible within the share. After
    > reading I post I found at the SF netatalk section, I removed the db
    > files from the share, and restarted netatalk. Now I can see the files
    > and folders within the share, but no one else can. I am owner of the
    > share and its files and folders, I'm not sure if that makes a difference
    > or not. Although they are part of a group that has r/w privs on the
    > share. The log shows this error when they try to connect:
    > Apr 27 17:16:26 [afpd] [enumerate.c:83]: E:AFPDaemon: adddir: Incorrect
    > parameters passed to cnid_add
    >
    > Another odd thing is that if one of the affected users tries to create a
    > new folder or place a file on the share, they get the error:
    > "The command could not be completed because of a system error -50"
    >
    > Which is a parameter error, consistent with the error posted above. But
    > if I then look at the share, I will see the new folder or file that was
    > placed there. I've tried upgrading to 2.01 and downgrading to 1.5.3, but
    > no luck, smae problem. I know netatalk uses berkdb as a backend and I
    > figure its corrupt, but I have no idea how to fix it.
    > Anyone have any ideas?
    > TIA


    I fixed it! I had to set the permissions on the share to 2777, delete
    the .AppleDB directory and restart netatalk. After restarting netatalk,
    I was able to connect and see the files on the share. Then I could
    restore the original permissions, but the user needs to r/w to the
    ..AppleDB directory. BerkDB seems to require that.
    Damn, I'm good!

+ Reply to Thread