Hi all,


I'm no sure about the right location of this question on the group. but I
haven't found any place better. And I know that on this list there are
really good experts.

I am trying to install GD library. In order to install this I have to
install also some modules:

PNG library, JPEG library, Freetype 2.x library


while the configuration process with:

../configure --with-png=/usr/local --with-freetype=/usr/local --with-jpeg=/sw

on folder /usr/loca/lib I have installed the following modules.


libexpat.0.4.0.dylib libfreetype.dylib libpng.3.1.2.5.dylib
libreadline.a
libexpat.0.dylib libfreetype.la libpng.a
libreadline.dylib
libexpat.a libhistory.4.2.dylib libpng12.0.1.2.5.dylib libz.a
libexpat.dylib libhistory.4.dylib libpng12.0.dylib mysql
libexpat.la libhistory.a libpng12.a php
libfreetype.6.3.3.dylib libhistory.dylib libpng12.dylib php.ini
libfreetype.6.dylib libpng. libreadline.4.2.dylib
pkgconfig
libfreetype.a libpng.3. libreadline.4.dylib


but on the building process I get:

checking for libpng-config... /usr/local/bin/libpng-config
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for png_create_read_struct in -lpng... no
configure: WARNING: libpng is required - see http://www.libpng.org/pub/png/
checking for freetype-config... /usr/local/bin/freetype-config


and the result is like:


** Configuration summary for gd 2.0.15:

Support for PNG library: no
Support for JPEG library: yes
Support for Freetype 2.x library: yes
Support for Xpm library: no


could you tell me why I the PNG library can not be seen???


Thanks a million
Pedro