Suspend-to-RAM and NVidia cards: Has anyone fixed the "blank screen" problem? - Portable

This is a discussion on Suspend-to-RAM and NVidia cards: Has anyone fixed the "blank screen" problem? - Portable ; I've got an Inspiron 8600 and I've never been able to use Suspend-to-RAM on it. The suspend part works... but, upon resume, the screen never comes back. It stays black. Keep in mind that I can still type commands at ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Suspend-to-RAM and NVidia cards: Has anyone fixed the "blank screen" problem?

  1. Suspend-to-RAM and NVidia cards: Has anyone fixed the "blank screen" problem?

    I've got an Inspiron 8600 and I've never been able to use
    Suspend-to-RAM on it.

    The suspend part works... but, upon resume, the screen never comes
    back. It stays black. Keep in mind that I can still type commands at
    the keyboard (like "shutdown") and I can ssh into it over the
    network.... so the machine is still alive. The only problem is that the
    video system is seemingly stuck in the "off" state upon resume.

    I've read various web pages regarding this, and some people claim to
    have fixed it... but, in their solution, they mention using NVidia's
    binary drivers for X, etc. What perplexes me about this is that I get
    this problem even when I'm *not* using X. I can boot to a text console,
    suspend, resume, and I'll have this same problem. So, I don't see how a
    different X driver is going to help me there.

    Also, most of the pages I read say that you have to recompile the
    kernel (at a minimum) and possibly even apply some patches to some of
    the downloaded sources. However, most of these pages are more than a
    year old, so I'm hoping that, over the last year, the solutions have
    become a little more "plug-n-play" than a kernel recompile.

    Also, I have noticed that the Debian package repository has a lot of
    new (within the last year or so) goodies that might offer help, like
    vbetool, and an NVidia kernel driver (although I don't know what it's
    supposed to help with).

    So, I ask this to the group. Has anyone out there had this
    blank-screen-on-resume problem with their NVidia-based laptop and
    solved it? If so, I'd be interested in hearing about what you did.


  2. Re: Suspend-to-RAM and NVidia cards: Has anyone fixed the "blank screen" problem?


    * joe@emenaker.com wrote:
    > I've got an Inspiron 8600 and I've never been able to use
    > Suspend-to-RAM on it.


    The same problem with a IBM Thinkpad T22 and a Savage graphic device.
    So it's driver independent.

    Any solution is welcomed,

    thanks in advance,

    Thomas.

    --
    ++ Thomas Bengs +++++++++++++++++++++++++ | /"\ ASCII Ribbon Campaign
    ++ tbengs@web.de ++++++++++++++++++++++++ | \ / ---------------------
    ++ http://www.bengs.de ++++++++++++++++++ | x against HTML in Email
    ++ "Anywhere you go, you ever go away" ++ | / \ and News

+ Reply to Thread