TP a22p (Ati Mobility M3), mp4player, mplayer etc - Portable

This is a discussion on TP a22p (Ati Mobility M3), mp4player, mplayer etc - Portable ; Hi, dont know what it is caused by, it happens on FreeBSD as well, Xorg, mp4player (mpeg4ip.sf.net) and mplayer. The windows opens in the expected size and mp4player etc just display an distorted image in the upper half of the ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: TP a22p (Ati Mobility M3), mp4player, mplayer etc

  1. TP a22p (Ati Mobility M3), mp4player, mplayer etc

    Hi,

    dont know what it is caused by, it happens on FreeBSD as well, Xorg,
    mp4player (mpeg4ip.sf.net) and mplayer.

    The windows opens in the expected size and mp4player etc
    just display an distorted image in the upper half of the screen, the
    rest is black. The y axis of the movie is only half as long as
    expected.

    Is Xorg broken, do I have settings wrong?
    There are some pages in the net on a22p Thinkpads, this problem is
    never mentioned.


    Thanks,


    H.

  2. Re: TP a22p (Ati Mobility M3), mp4player, mplayer etc

    On Wed, 13 Jul 2005 16:12:28 +0200, Heiko Recktenwald staggered into the
    Black Sun and said:

    Message rearranged a bit for clarity.

    > [When I try to play movies on a Thinkpad A22p,] the windows open in
    > the expected size and mp4player, etc., just display a distorted
    > image in the upper half of the screen. The y axis of the movie is
    > only half as long as expected. [I] don't know what it is caused by,
    > it happens on FreeBSD as well.
    >
    > Is Xorg broken, [or] do I have settings wrong?


    I've seen this before, but it was a long time ago and on XFree, not
    Xorg. It's a problem with the Xv extension and the r128 graphics
    chipset. When I was using XFree, I solved the problem by using the
    GATOS X module for r128 instead of the XFree standard module. I haven't
    seen this problem with Xorg. http://gatos.sourceforge.net/ . As a
    temporary workaround, you could use the movie players' X11 video output
    instead of the Xv video output. That's "-vo x11" for mplayer.

    > There are some pages in the net on a22p Thinkpads, [but] this problem
    > is never mentioned [on those pages].


    Like I said, the only time I've seen this happen was years ago with old
    XFree.

    --
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
    Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
    http://www.brainbench.com /
    -----------------------------/ This space sort of for rent.

  3. Re: TP a22p (Ati Mobility M3), mp4player, mplayer etc

    Black Sun,

    On Wed, 13 Jul 2005 09:48:04 -0500, Dances With Crows
    wrote:

    >On Wed, 13 Jul 2005 16:12:28 +0200, Heiko Recktenwald staggered into the
    >Black Sun and said:
    >
    >Message rearranged a bit for clarity.


    >> [When I try to play movies on a Thinkpad A22p,] the windows open in
    >> the expected size and mp4player, etc., just display a distorted
    >> image in the upper half of the screen. The y axis of the movie is
    >> only half as long as expected. [I] don't know what it is caused by,
    >> it happens on FreeBSD as well.
    >>
    >> Is Xorg broken, [or] do I have settings wrong?

    >
    >I've seen this before, but it was a long time ago and on XFree, not
    >Xorg. It's a problem with the Xv extension and the r128 graphics
    >chipset. When I was using XFree, I solved the problem by using the
    >GATOS X module for r128 instead of the XFree standard module. I haven't
    >seen this problem with Xorg. http://gatos.sourceforge.net/ . As a
    >temporary workaround, you could use the movie players' X11 video output
    >instead of the Xv video output. That's "-vo x11" for mplayer.


    No solution for the Cisco mp4player and I am on Windows in this
    moment, havent yet tested it, anyway, the secrets of xorg...

    Thanks!


    H.
    >
    >> There are some pages in the net on a22p Thinkpads, [but] this problem
    >> is never mentioned [on those pages].

    >
    >Like I said, the only time I've seen this happen was years ago with old
    >XFree.



  4. Re: TP a22p (Ati Mobility M3), mp4player, mplayer etc

    >>> [When I try to play movies on a Thinkpad A22p,] the windows open in
    >>> the expected size and mp4player, etc., just display a distorted
    >>> image in the upper half of the screen. The y axis of the movie is
    >>> only half as long as expected. [I] don't know what it is caused by,
    >>> it happens on FreeBSD as well.
    >>>
    >>> Is Xorg broken, [or] do I have settings wrong?

    >>
    >>I've seen this before, but it was a long time ago and on XFree, not
    >>Xorg. It's a problem with the Xv extension and the r128 graphics
    >>chipset. When I was using XFree, I solved the problem by using the
    >>GATOS X module for r128 instead of the XFree standard module. I haven't
    >>seen this problem with Xorg. http://gatos.sourceforge.net/ . As a
    >>temporary workaround, you could use the movie players' X11 video output
    >>instead of the Xv video output. That's "-vo x11" for mplayer.

    >
    > No solution for the Cisco mp4player and I am on Windows in this
    > moment, havent yet tested it, anyway, the secrets of xorg...


    Well, currently I am using the vesa driver.
    With mplayer, I get at least the ordinary movie,
    not worse than x11 (IMHO), with mp4player I get the
    fullscreen too.

    Maybe I should try the gatos driver with xorg as well.


    H.

+ Reply to Thread