fan control on evo n800v - Portable

This is a discussion on fan control on evo n800v - Portable ; Hello I have a compaq evo n800v on which I want to use linux. I have install Mandrake 10.1 and all seem working except the fan control... Acpi seem ok and seeing the dmesg, the dsdt of my laptop is ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: fan control on evo n800v

  1. fan control on evo n800v

    Hello

    I have a compaq evo n800v on which I want to use linux.

    I have install Mandrake 10.1 and all seem working except the fan
    control... Acpi seem ok and seeing the dmesg, the dsdt of my laptop is
    used (see dmesg at the end of the post).

    In fact, when I boot, the processor's fan is active (but not detected by
    acpi) :

    When I do an acpi -V, I've a message like this :
    Battery 1 : charged, 100%
    Thermal 1 : ok, 46.0 degrees C
    Thermal 2 : ok, 43.0 degrees C
    Thermal 3 : ok, 16.0 degrees C

    Something else is supprising :

    When I use more cpu, the temperature increase and when I reach 55
    degrees C, the fan should start. Of course, because it was running,
    nothing is changed... except it's detected !

    acpi -V gives :

    Battery 1 : charged, 100%
    Thermal 1 : active[3], 58.0 degrees C
    Thermal 2 : ok, 45.0 degrees C
    Thermal 3 : ok, 16.0 degrees C

    And when the temperature goes down 41 degrees C, the fan stop !!

    So I'm looking for a way to stop fan at boot time : it's active even if
    the temperature is 30 degrees... if I do simple think which dont use to
    many processor time (just emacs for example), the temperature never
    increase and the fan is always on...

    Thank you in advance for your help and sorry for my english (I'm french)

    Yayel

    ================================================== ====================================

    dmesg :


    Linux version 2.6.8.1-12mdk (quintela@n5.mandrakesoft.com) (gcc version
    3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)) #1 Fri Oct 1 12:53:41 CEST 2004
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000001ffd0000 (usable)
    BIOS-e820: 000000001ffd0000 - 000000001fff0c00 (reserved)
    BIOS-e820: 000000001fff0c00 - 000000001fffc000 (ACPI NVS)
    BIOS-e820: 000000001fffc000 - 0000000020000000 (reserved)
    0MB HIGHMEM available.
    511MB LOWMEM available.
    On node 0 totalpages: 131024
    DMA zone: 4096 pages, LIFO batch:1
    Normal zone: 126928 pages, LIFO batch:16
    HighMem zone: 0 pages, LIFO batch:1
    DMI 2.3 present.
    ACPI: RSDP (v000 COMPAQ ) @ 0x000f60c0
    ACPI: RSDT (v001 COMPAQ CPQ004A 0x26040420 CPQ 0x00000001) @ 0x1fff0c84
    ACPI: FADT (v002 COMPAQ CPQ004A 0x00000002 CPQ 0x00000001) @ 0x1fff0c00
    ACPI: SSDT (v001 COMPAQ CPQGysr 0x00001001 MSFT 0x0100000e) @ 0x1fff69b8
    ACPI: SSDT (v001 COMPAQ CPQMag 0x00001001 MSFT 0x0100000e) @ 0x1fff6ac6
    ACPI: DSDT (v001 COMPAQ EVON800 0x00010000 MSFT 0x0100000e) @ 0x00000000
    ACPI: PM-Timer IO Port: 0x1008
    Built 1 zonelists
    No local APIC present or hardware disabled
    Initializing CPU#0
    Kernel command line: BOOT_IMAGE=linux ro root=305 acpi=on
    resume=/dev/hda7 splash=silent
    bootsplash: silent mode.
    PID hash table entries: 2048 (order 11: 16384 bytes)
    Detected 2392.636 MHz processor.
    Using pmtmr for high-res timesource
    Console: colour dummy device 80x25
    Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
    Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
    Memory: 515252k/524096k available (1859k kernel code, 8080k reserved,
    578k data, 200k init, 0k highmem, 0k BadRAM)
    Checking if this processor honours the WP bit even in supervisor mode... Ok.
    Calibrating delay loop... 4734.97 BogoMIPS
    Security Scaffold v1.0.0 initialized
    SELinux: Disabled at boot.
    Capability LSM initialized
    Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
    CPU: After generic identify, caps: bfebf9ff 00000000 00000000 00000000
    CPU: After vendor identify, caps: bfebf9ff 00000000 00000000 00000000
    CPU: Trace cache: 12K uops, L1 D cache: 8K
    CPU: L2 cache: 512K
    CPU: After all inits, caps: bfebf9ff 00000000 00000000 00000080
    Intel machine check architecture supported.
    Intel machine check reporting enabled on CPU#0.
    CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
    CPU0: Thermal monitoring enabled
    CPU: Intel Mobile Intel(R) Pentium(R) 4 - M CPU 2.40GHz stepping 09
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    init init/main.c:689
    init init/main.c:702
    init init/main.c:707
    do_pre_smp_initcalls init/main.c:653
    do_pre_smp_initcalls init/main.c:659
    init init/main.c:711
    init init/main.c:714
    init init/main.c:716
    init init/main.c:718
    checking if image is initramfs...it isn't (no cpio magic); looks like an
    initrd
    ACPI: Looking for DSDT in initrd ... not found!
    Freeing initrd memory: 84k freed
    init init/main.c:724
    do_basic_setup init/main.c:634
    do_basic_setup init/main.c:636
    NET: Registered protocol family 16
    PCI: PCI BIOS revision 2.10 entry at 0xf031f, last bus=3
    PCI: Using configuration type 1
    mtrr: v2.0 (20020519)
    ACPI: Subsystem revision 20040326
    ACPI: IRQ9 SCI: Edge set to Level Trigger.
    ACPI: Interpreter enabled
    ACPI: Using PIC for interrupt routing
    ACPI: PCI Root Bridge [C046] (00:00)
    PCI: Probing PCI hardware (bus 00)
    PCI: Transparent bridge - 0000:00:1e.0
    ACPI: PCI Interrupt Routing Table [\_SB_.C046._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.C046.C047._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.C046.C058._PRT]
    ACPI: Embedded Controller [C0E4] (gpe 29)
    ACPI: Power Resource [C155] (off)
    ACPI: Power Resource [C169] (off)
    ACPI: Power Resource [C16D] (off)
    ACPI: Power Resource [C171] (off)
    ACPI: Power Resource [C17A] (on)
    ACPI: PCI Interrupt Link [C0C0] (IRQs 5 10 *11)
    ACPI: PCI Interrupt Link [C0C1] (IRQs *5 10 11)
    ACPI: PCI Interrupt Link [C0C2] (IRQs 5 10 11) *0, disabled.
    ACPI: PCI Interrupt Link [C0C3] (IRQs 5 10 *11)
    ACPI: PCI Interrupt Link [C0C4] (IRQs 5 *10 11)
    ACPI: PCI Interrupt Link [C0C5] (IRQs) *0, disabled.
    ACPI: PCI Interrupt Link [C0C6] (IRQs) *0, disabled.
    ACPI: PCI Interrupt Link [C0C7] (IRQs) *0, disabled.
    ACPI: Power Resource [C0E3] (on)
    ACPI: Power Resource [C1EB] (off)
    ACPI: Power Resource [C1EC] (off)
    ACPI: Power Resource [C1ED] (off)
    ACPI: Power Resource [C1EE] (off)
    Linux Plug and Play Support v0.97 (c) Adam Belay
    PnPBIOS: Disabled
    PCI: Using ACPI for IRQ routing
    ACPI: PCI Interrupt Link [C0C2] enabled at IRQ 11
    ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 11 (level, low) -> IRQ 11
    ACPI: PCI Interrupt Link [C0C1] enabled at IRQ 5
    ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
    ACPI: PCI Interrupt Link [C0C0] enabled at IRQ 11
    ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 11 (level, low) -> IRQ 11
    ACPI: PCI interrupt 0000:02:04.0[A] -> GSI 5 (level, low) -> IRQ 5
    ACPI: PCI Interrupt Link [C0C3] enabled at IRQ 11
    ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 11 (level, low) -> IRQ 11
    ACPI: PCI Interrupt Link [C0C4] enabled at IRQ 10
    ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 10 (level, low) -> IRQ 10
    ACPI: PCI interrupt 0000:02:0e.0[A] -> GSI 10 (level, low) -> IRQ 10
    ACPI: PCI interrupt 0000:02:0e.1[B] -> GSI 10 (level, low) -> IRQ 10
    ACPI: PCI interrupt 0000:02:0e.2[C] -> GSI 10 (level, low) -> IRQ 10
    vesafb: framebuffer at 0x48000000, mapped to 0xe0810000, size 1875k
    vesafb: mode is 800x600x16, linelength=1600, pages=33
    vesafb: protected mode interface info at c000:5687
    vesafb: scrolling: redraw
    vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
    fb0: VESA VGA frame buffer device
    apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
    apm: overridden by ACPI.
    audit: initializing netlink socket (disabled)
    audit(1105971236.360:0): initialized
    VFS: Disk quotas dquot_6.5.1
    Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
    devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x0
    Initializing Cryptographic API
    isapnp: Scanning for PnP cards...
    isapnp: No Plug & Play device found
    bootsplash 3.1.6-2004/03/31: looking for picture.... silentjpeg size
    14554 bytes, found (800x600, 14506 bytes, v3).
    Console: switching to colour frame buffer device 92x32
    Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS2 at I/O 0x3e8 (irq = 4) is a NS16550A
    RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ICH3M: IDE controller at PCI slot 0000:00:1f.1
    PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
    ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 11 (level, low) -> IRQ 11
    ICH3M: chipset revision 2
    ICH3M: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x4440-0x4447, BIOS settings: hdaMA, hdbio
    ide1: BM-DMA at 0x4448-0x444f, BIOS settings: hdcMA, hddio
    Probing IDE interface ide0...
    hda: TOSHIBA MK4019GAX, ATA DISK drive
    Using anticipatory io scheduler
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    Probing IDE interface ide1...
    hdc: HL-DT-STCD-RW/DVD DRIVE GCC-4241N, ATAPI CD/DVD-ROM drive
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: max request size: 128KiB
    hda: 78140160 sectors (40007 MB), CHS=65535/16/63, UDMA(100)
    /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 >
    mice: PS/2 mouse device common for all mice
    i8042.c: Detected active multiplexing controller, rev 1.1.
    serio: i8042 AUX0 port at 0x60,0x64 irq 12
    serio: i8042 AUX1 port at 0x60,0x64 irq 12
    serio: i8042 AUX2 port at 0x60,0x64 irq 12
    serio: i8042 AUX3 port at 0x60,0x64 irq 12
    Synaptics Touchpad, model: 1
    Firmware: 5.9
    Sensor: 51
    new absolute packet format
    Touchpad has extended capability bits
    -> 4 multi-buttons, i.e. besides standard buttons
    -> multifinger detection
    -> palm detection
    input: SynPS/2 Synaptics TouchPad on isa0060/serio4
    serio: i8042 KBD port at 0x60,0x64 irq 1
    input: AT Translated Set 2 keyboard on isa0060/serio0
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    NET: Registered protocol family 2
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP: Hash tables configured (established 32768 bind 65536)
    NET: Registered protocol family 1
    ACPI: (supports S0 S3 S4 S5)
    BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
    init init/main.c:726
    md: Autodetecting RAID arrays.
    md: autorun ...
    md: ... autorun DONE.
    RAMDISK: Compressed image found at block 0
    VFS: Mounted root (ext2 filesystem).
    Freeing unused kernel memory: 200k freed
    usbcore: registered new driver usbfs
    usbcore: registered new driver hub
    ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
    ohci_hcd: block sizes: ed 64 td 64
    ACPI: PCI interrupt 0000:02:0e.0[A] -> GSI 10 (level, low) -> IRQ 10
    ohci_hcd 0000:02:0e.0: OHCI Host Controller
    ohci_hcd 0000:02:0e.0: irq 10, pci mem e09f5000
    ohci_hcd 0000:02:0e.0: new USB bus registered, assigned bus number 1
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 3 ports detected
    ACPI: PCI interrupt 0000:02:0e.1[B] -> GSI 10 (level, low) -> IRQ 10
    ohci_hcd 0000:02:0e.1: OHCI Host Controller
    ohci_hcd 0000:02:0e.1: irq 10, pci mem e09f7000
    ohci_hcd 0000:02:0e.1: new USB bus registered, assigned bus number 2
    hub 2-0:1.0: USB hub found
    hub 2-0:1.0: 2 ports detected
    usb 1-1: new low speed USB device using address 2
    ACPI: PCI interrupt 0000:02:0e.2[C] -> GSI 10 (level, low) -> IRQ 10
    ehci_hcd 0000:02:0e.2: EHCI Host Controller
    ehci_hcd 0000:02:0e.2: irq 10, pci mem e0a14000
    ehci_hcd 0000:02:0e.2: new USB bus registered, assigned bus number 3
    ehci_hcd 0000:02:0e.2: USB 2.0 enabled, EHCI 0.95, driver 2004-May-10
    hub 3-0:1.0: USB hub found
    hub 3-0:1.0: 5 ports detected
    usb 1-1: USB disconnect, address 2
    usbcore: registered new driver hiddev
    usbcore: registered new driver usbhid
    drivers/usb/input/hid-core.c: v2.0:USB HID core driver
    usbcore: registered new driver usbmouse
    drivers/usb/input/usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
    ohci_hcd 0000:02:0e.0: wakeup
    usb 1-1: new low speed USB device using address 3
    input: USB HID v1.10 Mouse [Wireless Mouse Wireless Mouse] on
    usb-0000:02:0e.0-1
    ts: Compaq touchscreen protocol output
    Adding 1005440k swap on /dev/hda7. Priority:-1 extents:1
    Non-volatile memory driver v1.2
    Linux agpgart interface v0.100 (c) Dave Jones
    agpgart: Detected an Intel i845 Chipset.
    agpgart: Maximum main memory to use for agp memory: 439M
    agpgart: AGP aperture is 256M @ 0x60000000
    NTFS driver 2.1.15 [Flags: R/O DEBUG MODULE].
    NTFS volume version 3.1.
    loop: loaded (max 8 devices)
    hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, DMA
    Uniform CD-ROM driver Revision: 3.20
    e100: Intel(R) PRO/100 Network Driver, 3.0.18
    e100: Copyright(c) 1999-2004 Intel Corporation
    ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 10 (level, low) -> IRQ 10
    e100: eth0: e100_probe: addr 0x40100000, irq 10, MAC addr 00:08:02:6E:0E:37
    ACPI: AC Adapter [C130] (on-line)
    ACPI: Battery Slot [C132] (battery present)
    ACPI: Battery Slot [C131] (battery absent)
    ACPI: Power Button (FF) [PWRF]
    ACPI: Sleep Button (CM) [C134]
    ACPI: Lid Switch [C133]
    ACPI: Fan [C1EF] (off)
    ACPI: Fan [C1F0] (off)
    ACPI: Fan [C1F1] (off)
    ACPI: Fan [C1F2] (off)
    ACPI: Processor [C000] (supports C1 C2 C3, 8 throttling states)
    wmi_add device=dffa5c00
    calling WQBA
    ACPI: Thermal Zone [TZ1] (52 C)
    ACPI: Thermal Zone [TZ2] (41 C)
    ACPI: Thermal Zone [TZ3] (16 C)
    Linux Kernel Card Services
    options: [pci] [cardbus] [pm]
    ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 11 (level, low) -> IRQ 11
    Yenta: CardBus bridge found at 0000:02:06.0 [0e11:004a]
    Yenta: Enabling burst memory read transactions
    Yenta: Using CSCINT to route CSC interrupts to PCI
    Yenta: Routing CardBus interrupts to PCI
    Yenta TI: socket 0000:02:06.0, mfunc 0x012c1202, devctl 0x64
    Yenta: ISA IRQ mask 0x0098, PCI irq 11
    Socket status: 30000006
    cs: IO port probe 0x0c00-0x0cff: clean.
    cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
    cs: IO port probe 0x0a00-0x0aff: clean.
    inserting floppy driver for 2.6.8.1-12mdk
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a National Semiconductor PC87306
    NET: Registered protocol family 17
    e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
    Intel 810 + AC97 Audio, version 1.01, 12:45:05 Oct 1 2004
    ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
    PCI: Setting latency timer of device 0000:00:1f.5 to 64
    i810: Intel ICH3 found at IO 0x4400 and 0x4000, MEM 0x0000 and 0x0000, IRQ 5
    i810_audio: Audio Controller supports 6 channels.
    i810_audio: Defaulting to base 2 channel mode.
    i810_audio: Resetting connection 0
    ac97_codec: AC97 Audio codec, id: ADS99 (Unknown)
    i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not
    present), total channels = 2
    Bluetooth: Core ver 2.6
    NET: Registered protocol family 31
    Bluetooth: HCI device and connection manager initialized
    Bluetooth: HCI socket layer initialized
    Bluetooth: L2CAP ver 2.3
    Bluetooth: L2CAP socket layer initialized
    Bluetooth: RFCOMM ver 1.3
    Bluetooth: RFCOMM socket layer initialized
    Bluetooth: RFCOMM TTY layer initialized
    NET: Registered protocol family 10
    Disabled Privacy Extensions on device c0322b60(lo)
    IPv6 over IPv4 tunneling driver
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 0 changed to on
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 1 changed to on
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 2 changed to on
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 3 changed to on
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 4 changed to on
    bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    10377 bytes, v3).
    bootsplash: status on console 5 changed to on
    mtrr: 0x48000000,0x2000000 overlaps existing 0x48000000,0x100000
    ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 11 (level, low) -> IRQ 11
    [drm] Initialized radeon 1.11.0 20020828 on minor 0:
    mtrr: 0x48000000,0x2000000 overlaps existing 0x48000000,0x100000
    agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
    agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
    eth0: no IPv6 routers present
    cdrom: This disc doesn't have any tracks I recognize!

  2. Re: fan control on evo n800v

    Hi Yayel,
    I cannot help a lot just give some ideas. The fan is running everytime
    during boot-up even with Windows-OS. This is because the ACPI is not
    activate at this time and the bios starts with a "secure" means full
    speed fan mode. Otherwise you will run in trouble if you use your Evo up
    to the limit, shut it down and then restart it directly (e.g. a system
    crash). During boot up the CPU will die because of the released heating.
    This is the reason, that during boot up th fan run at full speed to be
    sure everything goes fine. However, after starting ACPI it should detect
    the CPU temperature and decrease the fan-speed.

    I used a Suse-Live CD 9.2. and it works well with it (Evo 800w). Suse
    announced better ACPI-support. You may give it a try.

    Greetings
    Torsten

    Yayel wrote:
    > Hello
    >
    > I have a compaq evo n800v on which I want to use linux.
    >
    > I have install Mandrake 10.1 and all seem working except the fan
    > control... Acpi seem ok and seeing the dmesg, the dsdt of my laptop is
    > used (see dmesg at the end of the post).
    >
    > In fact, when I boot, the processor's fan is active (but not detected by
    > acpi) :
    >
    > When I do an acpi -V, I've a message like this :
    > Battery 1 : charged, 100%
    > Thermal 1 : ok, 46.0 degrees C
    > Thermal 2 : ok, 43.0 degrees C
    > Thermal 3 : ok, 16.0 degrees C
    >
    > Something else is supprising :
    >
    > When I use more cpu, the temperature increase and when I reach 55
    > degrees C, the fan should start. Of course, because it was running,
    > nothing is changed... except it's detected !
    >
    > acpi -V gives :
    >
    > Battery 1 : charged, 100%
    > Thermal 1 : active[3], 58.0 degrees C
    > Thermal 2 : ok, 45.0 degrees C
    > Thermal 3 : ok, 16.0 degrees C
    >
    > And when the temperature goes down 41 degrees C, the fan stop !!
    >
    > So I'm looking for a way to stop fan at boot time : it's active even if
    > the temperature is 30 degrees... if I do simple think which dont use to
    > many processor time (just emacs for example), the temperature never
    > increase and the fan is always on...
    >
    > Thank you in advance for your help and sorry for my english (I'm french)
    >
    > Yayel
    >
    > ================================================== ====================================
    >
    >
    > dmesg :
    >
    >
    > Linux version 2.6.8.1-12mdk (quintela@n5.mandrakesoft.com) (gcc version
    > 3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)) #1 Fri Oct 1 12:53:41 CEST 2004
    > BIOS-provided physical RAM map:
    > BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    > BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    > BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
    > BIOS-e820: 0000000000100000 - 000000001ffd0000 (usable)
    > BIOS-e820: 000000001ffd0000 - 000000001fff0c00 (reserved)
    > BIOS-e820: 000000001fff0c00 - 000000001fffc000 (ACPI NVS)
    > BIOS-e820: 000000001fffc000 - 0000000020000000 (reserved)
    > 0MB HIGHMEM available.
    > 511MB LOWMEM available.
    > On node 0 totalpages: 131024
    > DMA zone: 4096 pages, LIFO batch:1
    > Normal zone: 126928 pages, LIFO batch:16
    > HighMem zone: 0 pages, LIFO batch:1
    > DMI 2.3 present.
    > ACPI: RSDP (v000 COMPAQ ) @ 0x000f60c0
    > ACPI: RSDT (v001 COMPAQ CPQ004A 0x26040420 CPQ 0x00000001) @ 0x1fff0c84
    > ACPI: FADT (v002 COMPAQ CPQ004A 0x00000002 CPQ 0x00000001) @ 0x1fff0c00
    > ACPI: SSDT (v001 COMPAQ CPQGysr 0x00001001 MSFT 0x0100000e) @ 0x1fff69b8
    > ACPI: SSDT (v001 COMPAQ CPQMag 0x00001001 MSFT 0x0100000e) @ 0x1fff6ac6
    > ACPI: DSDT (v001 COMPAQ EVON800 0x00010000 MSFT 0x0100000e) @ 0x00000000
    > ACPI: PM-Timer IO Port: 0x1008
    > Built 1 zonelists
    > No local APIC present or hardware disabled
    > Initializing CPU#0
    > Kernel command line: BOOT_IMAGE=linux ro root=305 acpi=on
    > resume=/dev/hda7 splash=silent
    > bootsplash: silent mode.
    > PID hash table entries: 2048 (order 11: 16384 bytes)
    > Detected 2392.636 MHz processor.
    > Using pmtmr for high-res timesource
    > Console: colour dummy device 80x25
    > Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
    > Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
    > Memory: 515252k/524096k available (1859k kernel code, 8080k reserved,
    > 578k data, 200k init, 0k highmem, 0k BadRAM)
    > Checking if this processor honours the WP bit even in supervisor mode...
    > Ok.
    > Calibrating delay loop... 4734.97 BogoMIPS
    > Security Scaffold v1.0.0 initialized
    > SELinux: Disabled at boot.
    > Capability LSM initialized
    > Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
    > CPU: After generic identify, caps: bfebf9ff 00000000 00000000 00000000
    > CPU: After vendor identify, caps: bfebf9ff 00000000 00000000 00000000
    > CPU: Trace cache: 12K uops, L1 D cache: 8K
    > CPU: L2 cache: 512K
    > CPU: After all inits, caps: bfebf9ff 00000000 00000000 00000080
    > Intel machine check architecture supported.
    > Intel machine check reporting enabled on CPU#0.
    > CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
    > CPU0: Thermal monitoring enabled
    > CPU: Intel Mobile Intel(R) Pentium(R) 4 - M CPU 2.40GHz stepping 09
    > Enabling fast FPU save and restore... done.
    > Enabling unmasked SIMD FPU exception support... done.
    > Checking 'hlt' instruction... OK.
    > init init/main.c:689
    > init init/main.c:702
    > init init/main.c:707
    > do_pre_smp_initcalls init/main.c:653
    > do_pre_smp_initcalls init/main.c:659
    > init init/main.c:711
    > init init/main.c:714
    > init init/main.c:716
    > init init/main.c:718
    > checking if image is initramfs...it isn't (no cpio magic); looks like an
    > initrd
    > ACPI: Looking for DSDT in initrd ... not found!
    > Freeing initrd memory: 84k freed
    > init init/main.c:724
    > do_basic_setup init/main.c:634
    > do_basic_setup init/main.c:636
    > NET: Registered protocol family 16
    > PCI: PCI BIOS revision 2.10 entry at 0xf031f, last bus=3
    > PCI: Using configuration type 1
    > mtrr: v2.0 (20020519)
    > ACPI: Subsystem revision 20040326
    > ACPI: IRQ9 SCI: Edge set to Level Trigger.
    > ACPI: Interpreter enabled
    > ACPI: Using PIC for interrupt routing
    > ACPI: PCI Root Bridge [C046] (00:00)
    > PCI: Probing PCI hardware (bus 00)
    > PCI: Transparent bridge - 0000:00:1e.0
    > ACPI: PCI Interrupt Routing Table [\_SB_.C046._PRT]
    > ACPI: PCI Interrupt Routing Table [\_SB_.C046.C047._PRT]
    > ACPI: PCI Interrupt Routing Table [\_SB_.C046.C058._PRT]
    > ACPI: Embedded Controller [C0E4] (gpe 29)
    > ACPI: Power Resource [C155] (off)
    > ACPI: Power Resource [C169] (off)
    > ACPI: Power Resource [C16D] (off)
    > ACPI: Power Resource [C171] (off)
    > ACPI: Power Resource [C17A] (on)
    > ACPI: PCI Interrupt Link [C0C0] (IRQs 5 10 *11)
    > ACPI: PCI Interrupt Link [C0C1] (IRQs *5 10 11)
    > ACPI: PCI Interrupt Link [C0C2] (IRQs 5 10 11) *0, disabled.
    > ACPI: PCI Interrupt Link [C0C3] (IRQs 5 10 *11)
    > ACPI: PCI Interrupt Link [C0C4] (IRQs 5 *10 11)
    > ACPI: PCI Interrupt Link [C0C5] (IRQs) *0, disabled.
    > ACPI: PCI Interrupt Link [C0C6] (IRQs) *0, disabled.
    > ACPI: PCI Interrupt Link [C0C7] (IRQs) *0, disabled.
    > ACPI: Power Resource [C0E3] (on)
    > ACPI: Power Resource [C1EB] (off)
    > ACPI: Power Resource [C1EC] (off)
    > ACPI: Power Resource [C1ED] (off)
    > ACPI: Power Resource [C1EE] (off)
    > Linux Plug and Play Support v0.97 (c) Adam Belay
    > PnPBIOS: Disabled
    > PCI: Using ACPI for IRQ routing
    > ACPI: PCI Interrupt Link [C0C2] enabled at IRQ 11
    > ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 11 (level, low) -> IRQ 11
    > ACPI: PCI Interrupt Link [C0C1] enabled at IRQ 5
    > ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
    > ACPI: PCI Interrupt Link [C0C0] enabled at IRQ 11
    > ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 11 (level, low) -> IRQ 11
    > ACPI: PCI interrupt 0000:02:04.0[A] -> GSI 5 (level, low) -> IRQ 5
    > ACPI: PCI Interrupt Link [C0C3] enabled at IRQ 11
    > ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 11 (level, low) -> IRQ 11
    > ACPI: PCI Interrupt Link [C0C4] enabled at IRQ 10
    > ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 10 (level, low) -> IRQ 10
    > ACPI: PCI interrupt 0000:02:0e.0[A] -> GSI 10 (level, low) -> IRQ 10
    > ACPI: PCI interrupt 0000:02:0e.1[B] -> GSI 10 (level, low) -> IRQ 10
    > ACPI: PCI interrupt 0000:02:0e.2[C] -> GSI 10 (level, low) -> IRQ 10
    > vesafb: framebuffer at 0x48000000, mapped to 0xe0810000, size 1875k
    > vesafb: mode is 800x600x16, linelength=1600, pages=33
    > vesafb: protected mode interface info at c000:5687
    > vesafb: scrolling: redraw
    > vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
    > fb0: VESA VGA frame buffer device
    > apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
    > apm: overridden by ACPI.
    > audit: initializing netlink socket (disabled)
    > audit(1105971236.360:0): initialized
    > VFS: Disk quotas dquot_6.5.1
    > Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
    > devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
    > devfs: boot_options: 0x0
    > Initializing Cryptographic API
    > isapnp: Scanning for PnP cards...
    > isapnp: No Plug & Play device found
    > bootsplash 3.1.6-2004/03/31: looking for picture.... silentjpeg size
    > 14554 bytes, found (800x600, 14506 bytes, v3).
    > Console: switching to colour frame buffer device 92x32
    > Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
    > ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    > ttyS2 at I/O 0x3e8 (irq = 4) is a NS16550A
    > RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
    > Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    > ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    > ICH3M: IDE controller at PCI slot 0000:00:1f.1
    > PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
    > ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 11 (level, low) -> IRQ 11
    > ICH3M: chipset revision 2
    > ICH3M: not 100% native mode: will probe irqs later
    > ide0: BM-DMA at 0x4440-0x4447, BIOS settings: hdaMA, hdbio
    > ide1: BM-DMA at 0x4448-0x444f, BIOS settings: hdcMA, hddio
    > Probing IDE interface ide0...
    > hda: TOSHIBA MK4019GAX, ATA DISK drive
    > Using anticipatory io scheduler
    > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    > Probing IDE interface ide1...
    > hdc: HL-DT-STCD-RW/DVD DRIVE GCC-4241N, ATAPI CD/DVD-ROM drive
    > ide1 at 0x170-0x177,0x376 on irq 15
    > hda: max request size: 128KiB
    > hda: 78140160 sectors (40007 MB), CHS=65535/16/63, UDMA(100)
    > /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 >
    > mice: PS/2 mouse device common for all mice
    > i8042.c: Detected active multiplexing controller, rev 1.1.
    > serio: i8042 AUX0 port at 0x60,0x64 irq 12
    > serio: i8042 AUX1 port at 0x60,0x64 irq 12
    > serio: i8042 AUX2 port at 0x60,0x64 irq 12
    > serio: i8042 AUX3 port at 0x60,0x64 irq 12
    > Synaptics Touchpad, model: 1
    > Firmware: 5.9
    > Sensor: 51
    > new absolute packet format
    > Touchpad has extended capability bits
    > -> 4 multi-buttons, i.e. besides standard buttons
    > -> multifinger detection
    > -> palm detection
    > input: SynPS/2 Synaptics TouchPad on isa0060/serio4
    > serio: i8042 KBD port at 0x60,0x64 irq 1
    > input: AT Translated Set 2 keyboard on isa0060/serio0
    > md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    > NET: Registered protocol family 2
    > IP: routing cache hash table of 4096 buckets, 32Kbytes
    > TCP: Hash tables configured (established 32768 bind 65536)
    > NET: Registered protocol family 1
    > ACPI: (supports S0 S3 S4 S5)
    > BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
    > init init/main.c:726
    > md: Autodetecting RAID arrays.
    > md: autorun ...
    > md: ... autorun DONE.
    > RAMDISK: Compressed image found at block 0
    > VFS: Mounted root (ext2 filesystem).
    > Freeing unused kernel memory: 200k freed
    > usbcore: registered new driver usbfs
    > usbcore: registered new driver hub
    > ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
    > ohci_hcd: block sizes: ed 64 td 64
    > ACPI: PCI interrupt 0000:02:0e.0[A] -> GSI 10 (level, low) -> IRQ 10
    > ohci_hcd 0000:02:0e.0: OHCI Host Controller
    > ohci_hcd 0000:02:0e.0: irq 10, pci mem e09f5000
    > ohci_hcd 0000:02:0e.0: new USB bus registered, assigned bus number 1
    > hub 1-0:1.0: USB hub found
    > hub 1-0:1.0: 3 ports detected
    > ACPI: PCI interrupt 0000:02:0e.1[B] -> GSI 10 (level, low) -> IRQ 10
    > ohci_hcd 0000:02:0e.1: OHCI Host Controller
    > ohci_hcd 0000:02:0e.1: irq 10, pci mem e09f7000
    > ohci_hcd 0000:02:0e.1: new USB bus registered, assigned bus number 2
    > hub 2-0:1.0: USB hub found
    > hub 2-0:1.0: 2 ports detected
    > usb 1-1: new low speed USB device using address 2
    > ACPI: PCI interrupt 0000:02:0e.2[C] -> GSI 10 (level, low) -> IRQ 10
    > ehci_hcd 0000:02:0e.2: EHCI Host Controller
    > ehci_hcd 0000:02:0e.2: irq 10, pci mem e0a14000
    > ehci_hcd 0000:02:0e.2: new USB bus registered, assigned bus number 3
    > ehci_hcd 0000:02:0e.2: USB 2.0 enabled, EHCI 0.95, driver 2004-May-10
    > hub 3-0:1.0: USB hub found
    > hub 3-0:1.0: 5 ports detected
    > usb 1-1: USB disconnect, address 2
    > usbcore: registered new driver hiddev
    > usbcore: registered new driver usbhid
    > drivers/usb/input/hid-core.c: v2.0:USB HID core driver
    > usbcore: registered new driver usbmouse
    > drivers/usb/input/usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
    > ohci_hcd 0000:02:0e.0: wakeup
    > usb 1-1: new low speed USB device using address 3
    > input: USB HID v1.10 Mouse [Wireless Mouse Wireless Mouse] on
    > usb-0000:02:0e.0-1
    > ts: Compaq touchscreen protocol output
    > Adding 1005440k swap on /dev/hda7. Priority:-1 extents:1
    > Non-volatile memory driver v1.2
    > Linux agpgart interface v0.100 (c) Dave Jones
    > agpgart: Detected an Intel i845 Chipset.
    > agpgart: Maximum main memory to use for agp memory: 439M
    > agpgart: AGP aperture is 256M @ 0x60000000
    > NTFS driver 2.1.15 [Flags: R/O DEBUG MODULE].
    > NTFS volume version 3.1.
    > loop: loaded (max 8 devices)
    > hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, DMA
    > Uniform CD-ROM driver Revision: 3.20
    > e100: Intel(R) PRO/100 Network Driver, 3.0.18
    > e100: Copyright(c) 1999-2004 Intel Corporation
    > ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 10 (level, low) -> IRQ 10
    > e100: eth0: e100_probe: addr 0x40100000, irq 10, MAC addr 00:08:02:6E:0E:37
    > ACPI: AC Adapter [C130] (on-line)
    > ACPI: Battery Slot [C132] (battery present)
    > ACPI: Battery Slot [C131] (battery absent)
    > ACPI: Power Button (FF) [PWRF]
    > ACPI: Sleep Button (CM) [C134]
    > ACPI: Lid Switch [C133]
    > ACPI: Fan [C1EF] (off)
    > ACPI: Fan [C1F0] (off)
    > ACPI: Fan [C1F1] (off)
    > ACPI: Fan [C1F2] (off)
    > ACPI: Processor [C000] (supports C1 C2 C3, 8 throttling states)
    > wmi_add device=dffa5c00
    > calling WQBA
    > ACPI: Thermal Zone [TZ1] (52 C)
    > ACPI: Thermal Zone [TZ2] (41 C)
    > ACPI: Thermal Zone [TZ3] (16 C)
    > Linux Kernel Card Services
    > options: [pci] [cardbus] [pm]
    > ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 11 (level, low) -> IRQ 11
    > Yenta: CardBus bridge found at 0000:02:06.0 [0e11:004a]
    > Yenta: Enabling burst memory read transactions
    > Yenta: Using CSCINT to route CSC interrupts to PCI
    > Yenta: Routing CardBus interrupts to PCI
    > Yenta TI: socket 0000:02:06.0, mfunc 0x012c1202, devctl 0x64
    > Yenta: ISA IRQ mask 0x0098, PCI irq 11
    > Socket status: 30000006
    > cs: IO port probe 0x0c00-0x0cff: clean.
    > cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
    > cs: IO port probe 0x0a00-0x0aff: clean.
    > inserting floppy driver for 2.6.8.1-12mdk
    > Floppy drive(s): fd0 is 1.44M
    > FDC 0 is a National Semiconductor PC87306
    > NET: Registered protocol family 17
    > e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
    > Intel 810 + AC97 Audio, version 1.01, 12:45:05 Oct 1 2004
    > ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
    > PCI: Setting latency timer of device 0000:00:1f.5 to 64
    > i810: Intel ICH3 found at IO 0x4400 and 0x4000, MEM 0x0000 and 0x0000,
    > IRQ 5
    > i810_audio: Audio Controller supports 6 channels.
    > i810_audio: Defaulting to base 2 channel mode.
    > i810_audio: Resetting connection 0
    > ac97_codec: AC97 Audio codec, id: ADS99 (Unknown)
    > i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not
    > present), total channels = 2
    > Bluetooth: Core ver 2.6
    > NET: Registered protocol family 31
    > Bluetooth: HCI device and connection manager initialized
    > Bluetooth: HCI socket layer initialized
    > Bluetooth: L2CAP ver 2.3
    > Bluetooth: L2CAP socket layer initialized
    > Bluetooth: RFCOMM ver 1.3
    > Bluetooth: RFCOMM socket layer initialized
    > Bluetooth: RFCOMM TTY layer initialized
    > NET: Registered protocol family 10
    > Disabled Privacy Extensions on device c0322b60(lo)
    > IPv6 over IPv4 tunneling driver
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 0 changed to on
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 1 changed to on
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 2 changed to on
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 3 changed to on
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 4 changed to on
    > bootsplash 3.1.6-2004/03/31: looking for picture.... found (800x600,
    > 10377 bytes, v3).
    > bootsplash: status on console 5 changed to on
    > mtrr: 0x48000000,0x2000000 overlaps existing 0x48000000,0x100000
    > ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 11 (level, low) -> IRQ 11
    > [drm] Initialized radeon 1.11.0 20020828 on minor 0:
    > mtrr: 0x48000000,0x2000000 overlaps existing 0x48000000,0x100000
    > agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
    > agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
    > agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
    > eth0: no IPv6 routers present
    > cdrom: This disc doesn't have any tracks I recognize!


  3. Re: fan control on evo n800v

    Yayel wrote:
    >
    > I have a compaq evo n800v on which I want to use linux.
    > ...
    > So I'm looking for a way to stop fan at boot time : it's active even if
    > the temperature is 30 degrees... if I do simple think which dont use to
    > many processor time (just emacs for example), the temperature never
    > increase and the fan is always on...
    >

    on my compaq presario 2825ea (which uses the same bios as the evo n800v)
    with Debian sarge I use a script /etc/init.d/fan-switchoff:

    #!/bin/sh
    #
    # Switch of the cooling fan (to correct kernel ACPI flaw).
    #
    PATH=/bin:/usr/bin:/sbin:/usr/sbin

    TZ1_TEMPERATURE=/proc/acpi/thermal_zone/TZ1/temperature
    FAN_STATE=/proc/acpi/fan/C1F2/state
    #FAN_STATE=/proc/acpi/fan/C1D8/state

    test -r $TZ1_TEMPERATURE || exit 0
    test -w $FAN_STATE || exit 0

    temp=`cat $TZ1_TEMPERATURE | awk '{ print $2 }'`
    if [ $temp -lt 45 ]; then
    echo "Switching off cooling fan."
    echo -n 0 > $FAN_STATE
    echo -n 3 > $FAN_STATE
    fi

    exit 0

    which is linked to /etc/rcS.d/S71fan-switchoff. I don't use ACPI
    modules, all is compiled into the kernel. Otherwise you have to load the
    "fan" and "thermal" module before running this script. Also the
    directory names in /proc/acpi/fan/ may be something else.
    For SuSE you place these code lines into the script /etc/init.d/boot.local.

    The relevant thing are the last two echo commands.
    I found a hint for this on www.moosherr.de/linux/~mooz/evo_install.html.

    Regards,
    Jörg-Volker.

+ Reply to Thread