3Com Mini-PCI (net) initialization problem with 2.4.23 - Portable

This is a discussion on 3Com Mini-PCI (net) initialization problem with 2.4.23 - Portable ; My Thinkpad T21 has a combined 3Com Mini-PCI V.90 56Kb modem and 100/10 Ethernet Combination card. It had CRUX 1.2 installed with kernel 2.4.21 When upgrading to CRUX 1.3 (kernel 2.4.23) there was a problem initializing the network card at ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: 3Com Mini-PCI (net) initialization problem with 2.4.23

  1. 3Com Mini-PCI (net) initialization problem with 2.4.23

    My Thinkpad T21 has a combined 3Com Mini-PCI V.90 56Kb modem and 100/10
    Ethernet Combination card. It had CRUX 1.2 installed with kernel 2.4.21
    When upgrading to CRUX 1.3 (kernel 2.4.23) there was a problem
    initializing the network card at startup (just booting, not waking up
    from either suspend or hibernation):

    starting services: net
    eth0: command 0x5800 did not complete! Status=0xffff
    eth0: command 0x2804 did not complete! Status=0xffff
    eth0: command 0x3002 did not complete! Status=0xffff (8 times)

    I would really appreciate some leads regarding the cause of this
    problem, and a possible solution/workaround.

    Does this have anything to do with Wakeup-On-LAN and power management
    changes in the kernel? If so, how do I turn off WOL? (see also
    http://www.scyld.com/pipermail/vorte...ly/001223.html)

    Thanks in advance,
    Theo


  2. Re: 3Com Mini-PCI (net) initialization problem with 2.4.23

    Solved after discovering a reference to a problem with ACPI in
    http://www.google.se/search?q=cache:...hl=sv&ie=UTF-8

    I simply added 'acpi=off' to the list of parameters passed to the kernel
    in Grub.

    PS Turning off wakeup-on-lan as suggested elsewhere did not make the
    problem go away (enable_wol=0) when I tried that.

    --theo


    Theo Kanter wrote:
    > My Thinkpad T21 has a combined 3Com Mini-PCI V.90 56Kb modem and 100/10
    > Ethernet Combination card. It had CRUX 1.2 installed with kernel 2.4.21
    > When upgrading to CRUX 1.3 (kernel 2.4.23) there was a problem
    > initializing the network card at startup (just booting, not waking up
    > from either suspend or hibernation):
    >
    > starting services: net
    > eth0: command 0x5800 did not complete! Status=0xffff
    > eth0: command 0x2804 did not complete! Status=0xffff
    > eth0: command 0x3002 did not complete! Status=0xffff (8 times)
    >
    > I would really appreciate some leads regarding the cause of this
    > problem, and a possible solution/workaround.
    >
    > Does this have anything to do with Wakeup-On-LAN and power management
    > changes in the kernel? If so, how do I turn off WOL? (see also
    > http://www.scyld.com/pipermail/vorte...ly/001223.html)
    >
    > Thanks in advance,
    > Theo
    >



+ Reply to Thread