Pb newbie carte pcmia lecteur memoire flash - Portable

This is a discussion on Pb newbie carte pcmia lecteur memoire flash - Portable ; Bonsoir, J'ai installé une mandrake sur un toshiba Satellite SA10 S213 et j'ai quelques soucis: Je ne sais pas comment configurer la carte pcmia lecteur de memoire compact-flash Lorsque j'insère la carte à chaud, elle semble bien reconnue lorsque l'on ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Pb newbie carte pcmia lecteur memoire flash

  1. Pb newbie carte pcmia lecteur memoire flash

    Bonsoir,
    J'ai installé une mandrake sur un toshiba Satellite SA10 S213 et j'ai
    quelques soucis:

    Je ne sais pas comment configurer la carte pcmia lecteur de memoire
    compact-flash
    Lorsque j'insère la carte à chaud, elle semble bien reconnue lorsque l'on
    regarde le fichier /var/log/messages:
    Nov 13 21:17:23 localhost kernel: hde: TOSHIBA THNCF256MAA, CFA DISK drive
    Nov 13 21:17:23 localhost kernel: ide2 at 0x100-0x107,0x10e on irq 3
    Nov 13 21:17:23 localhost kernel: hde: attached ide-disk driver.
    Nov 13 21:17:23 localhost kernel: hde: task_no_data_intr: status=0x51 {
    DriveReady SeekComplete Error }
    Nov 13 21:17:23 localhost kernel: hde: task_no_data_intr: error=0x04 {
    DriveStatusError }
    Nov 13 21:17:23 localhost kernel: hde: 500736 sectors (256 MB) w/2KiB Cache,
    CHS=978/16/32
    Nov 13 21:17:23 localhost kernel: /dev/ide/host2/bus0/target0/lun0: p1
    Nov 13 21:17:23 localhost kernel: devfs_do_symlink(disc0): could not append
    to parent, err: -17
    Nov 13 21:17:23 localhost kernel: ide_cs: hde: Vcc = 3.3, Vpp = 0.0
    Nov 13 21:17:24 localhost kernel: /dev/ide/host2/bus0/target0/lun0: p1
    Nov 13 21:17:24 localhost kernel: devfs_do_symlink(disc0): could not append
    to parent, err: -17
    Nov 13 21:17:24 localhost kernel: /dev/ide/host2/bus0/target0/lun0: p1


    Mais il manque une instruction quelque part pour monter cette carte?

    Quelqu'un pourrait-il me venir en aide?

    J'ai aussi une autre erreur lors du boot:
    Nov 13 20:24:56 localhost insmod:
    /lib/modules/2.4.22-10mdk/kernel/drivers/parport/parport_pc.o.gz:
    init_module: Device or resource busy
    Nov 13 20:24:56 localhost insmod: Hint: insmod errors can be caused by
    incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    Nov 13 20:24:56 localhost modprobe: modprobe: insmod parport_lowlevel failed

    Je crois comprendre qu'il ne peut pas installer le parport_pc.o.gz,
    ce qui semble normal car ce micro n'a pas de port parallele. Ce qui
    m'ennuie, c'est que je ne sais pas comment lui interdire la recherche de
    port parallele.Dans /etc/modules.conf, je n'ai que les instructions
    suivantes:
    above snd-intel8x0 snd-pcm-oss
    probeall usb-interface usb-uhci ehci-hcd
    probeall scsi_hostadapter ide-scsi
    alias sound-slot-0 snd-intel8x0

    Merci par avance à ceux qui voudront bien m'aider à solutionner mes
    problèmes.

  2. Re: Pb newbie carte pcmia lecteur memoire flash

    On Thu, 13 Nov 2003 22:31:44 +0100, andre staggered into the Black Sun
    and said:
    > J'ai installé une mandrake sur un toshiba Satellite SA10 S213 et j'ai
    > quelques soucis:


    Je peux lire français, mais on parle anglais dans ce newsgroup-ci.
    Utilisez Babelfish si vous avez des problèmes avec anglais.

    > Lorsque j'insère la carte à chaud, elle semble bien reconnue lorsque
    > l'on regarde le fichier /var/log/messages:
    > kernel: hde: TOSHIBA THNCF256MAA, CFA DISK drive


    This is good.

    > kernel: hde: task_no_data_intr: status=0x51 {DriveReady SeekComplete Error}
    > kernel: hde: task_no_data_intr: error=0x04 { DriveStatusError }


    Don't worry; PCMCIA CompactFlash cards always do this when first
    inserted.

    > kernel: hde: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
    > kernel: /dev/ide/host2/bus0/target0/lun0: p1
    > kernel: devfs_do_symlink(disc0): could not append to parent, err: -17


    Bizarre. I've never seen this message.

    > Mais il manque une instruction quelque part pour monter cette carte?


    mkdir /mnt/cf (only do this once)
    mount /dev/hde1 /mnt/cf

    > J'ai aussi une autre erreur lors du boot:
    > /lib/modules/2.4.22-10mdk/kernel/drivers/parport/parport_pc.o.gz:
    > init_module: Device or resource busy
    > modprobe: insmod parport_lowlevel failed


    > Je crois comprendre qu'il ne peut pas installer le parport_pc.o.gz,
    > ce qui semble normal car ce micro n'a pas de port parallele.


    The machine has no parallel port? Never seen an x86 machine without
    one, but anyway: Edit /etc/modules.conf , find the line that says:

    alias parport_lowlevel parport_pc

    change it to

    alias parport_lowlevel off

    Hope this helps, bonne chance!

    --
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
    Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
    http://www.brainbench.com / "He is a rhythmic movement of the
    -----------------------------/ penguins, is Tux." --MegaHAL

  3. Re: Pb newbie carte pcmia lecteur memoire flash

    Dances With Crows wrote:

    > On Thu, 13 Nov 2003 22:31:44 +0100, andre staggered into the Black Sun
    > and said:
    >> J'ai installé une mandrake sur un toshiba Satellite SA10 S213 et j'ai
    >> quelques soucis:

    >
    > Je peux lire français, mais on parle anglais dans ce newsgroup-ci.
    > Utilisez Babelfish si vous avez des problèmes avec anglais.
    >
    >> Lorsque j'insère la carte à chaud, elle semble bien reconnue lorsque
    >> l'on regarde le fichier /var/log/messages:
    >> kernel: hde: TOSHIBA THNCF256MAA, CFA DISK drive

    >
    > This is good.
    >
    >> kernel: hde: task_no_data_intr: status=0x51 {DriveReady SeekComplete
    >> Error} kernel: hde: task_no_data_intr: error=0x04 { DriveStatusError }

    >
    > Don't worry; PCMCIA CompactFlash cards always do this when first
    > inserted.
    >
    >> kernel: hde: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
    >> kernel: /dev/ide/host2/bus0/target0/lun0: p1
    >> kernel: devfs_do_symlink(disc0): could not append to parent, err: -17

    >
    > Bizarre. I've never seen this message.
    >
    >> Mais il manque une instruction quelque part pour monter cette carte?

    >
    > mkdir /mnt/cf (only do this once)
    > mount /dev/hde1 /mnt/cf
    >
    >> J'ai aussi une autre erreur lors du boot:
    >> /lib/modules/2.4.22-10mdk/kernel/drivers/parport/parport_pc.o.gz:
    >> init_module: Device or resource busy
    >> modprobe: insmod parport_lowlevel failed

    >
    >> Je crois comprendre qu'il ne peut pas installer le parport_pc.o.gz,
    >> ce qui semble normal car ce micro n'a pas de port parallele.

    >
    > The machine has no parallel port? Never seen an x86 machine without
    > one, but anyway: Edit /etc/modules.conf , find the line that says:
    >
    > alias parport_lowlevel parport_pc
    >
    > change it to
    >
    > alias parport_lowlevel off
    >
    > Hope this helps, bonne chance!
    >

    In further information of my problem I provided to you messages appearing in
    dmesg when I insert the card:

    cs: memory probe 0xa0000000-0xa0ffffff: clean.
    hde: TOSHIBA THNCF256MAA, CFA DISK drive
    ide2 at 0x100-0x107,0x10e on irq 3
    hde: attached ide-disk driver.
    hde: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
    hde: task_no_data_intr: error=0x04 { DriveStatusError }
    hde: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
    /dev/ide/host2/bus0/target0/lun0: p1
    devfs_do_symlink(disc0): could not append to parent, err: -17
    ide_cs: hde: Vcc = 3.3, Vpp = 0.0
    VFS: Disk change detected on device 21:00
    /dev/ide/host2/bus0/target0/lun0: p1
    devfs_do_symlink(disc0): could not append to parent, err: -17
    VFS: Disk change detected on device 21:00
    /dev/ide/host2/bus0/target0/lun0: p1

    When I launch knoppix the card is automatically recognized like hde1 without
    error. Can you help me to finish configuring my Mandrake 9.2?

    I created a repertory /mnt/hde1 and I try to launch mount /mnt/hde1
    or mount /dev/hde /mnt/hde1 and it do not run!

    thanks..

  4. Re: Pb newbie carte pcmia lecteur memoire flash

    On Thu, 20 Nov 2003 21:05:51 +0100, andre staggered into the Black Sun
    and said:
    > hde: TOSHIBA THNCF256MAA, CFA DISK drive
    > ide2 at 0x100-0x107,0x10e on irq 3
    > hde: attached ide-disk driver.
    > hde: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
    > hde: task_no_data_intr: error=0x04 { DriveStatusError }


    This is, as far as I can tell, normal with all PCMCIA CF adapters.

    > hde: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
    > /dev/ide/host2/bus0/target0/lun0: p1
    > devfs_do_symlink(disc0): could not append to parent, err: -17


    I've never seen this error before.

    > I created a repertory /mnt/hde1 and I try to launch mount /mnt/hde1 or
    > mount /dev/hde /mnt/hde1 and it do not run!


    The kernel messages say that there's one partition on this device.
    Doing "mount /dev/hde /mnt/somewhere" won't work, since it's
    partitioned. Do "mount /dev/hde1 /mnt/somewhere" and see if it works.

    --
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
    Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
    http://www.brainbench.com / "He is a rhythmic movement of the
    -----------------------------/ penguins, is Tux." --MegaHAL

  5. Re: Pb newbie carte pcmia lecteur memoire flash

    Dances With Crows wrote:

    > On Thu, 20 Nov 2003 21:05:51 +0100, andre staggered into the Black Sun
    > and said:
    >> hde: TOSHIBA THNCF256MAA, CFA DISK drive
    >> ide2 at 0x100-0x107,0x10e on irq 3
    >> hde: attached ide-disk driver.
    >> hde: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
    >> hde: task_no_data_intr: error=0x04 { DriveStatusError }

    >
    > This is, as far as I can tell, normal with all PCMCIA CF adapters.
    >
    >> hde: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
    >> /dev/ide/host2/bus0/target0/lun0: p1
    >> devfs_do_symlink(disc0): could not append to parent, err: -17

    >
    > I've never seen this error before.
    >
    >> I created a repertory /mnt/hde1 and I try to launch mount /mnt/hde1 or
    >> mount /dev/hde /mnt/hde1 and it do not run!

    >
    > The kernel messages say that there's one partition on this device.
    > Doing "mount /dev/hde /mnt/somewhere" won't work, since it's
    > partitioned. Do "mount /dev/hde1 /mnt/somewhere" and see if it works.
    >

    When I do mount /dev/hde1 /mnt/hde1 on the console root : no reponse
    on a other console dmesg say always the same error (err -17).

+ Reply to Thread