Keyboard model under XFree86-4.3 on a ThinkpPad T40 - Portable

This is a discussion on Keyboard model under XFree86-4.3 on a ThinkpPad T40 - Portable ; I've the following problem: XFree86-4.3 loads the wrong keyboard model on my IBM ThinkPad T40. I am using Debian and have a german keyboard-layout. The Problem is, that the ALT and ALT-GT keys doesn't work, and in a console-window the ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Keyboard model under XFree86-4.3 on a ThinkpPad T40

  1. Keyboard model under XFree86-4.3 on a ThinkpPad T40

    I've the following problem:
    XFree86-4.3 loads the wrong keyboard model on my IBM ThinkPad T40. I am
    using Debian and have a german keyboard-layout.
    The Problem is, that the ALT and ALT-GT keys doesn't work, and in a
    console-window the ,, also don't work.

    Thanks for help...

  2. Re: Keyboard model under XFree86-4.3 on a ThinkpPad T40

    Alexander Naumann wrote:
    > XFree86-4.3 loads the wrong keyboard model on my IBM ThinkPad T40. I am


    It doesn't load it, you do. You load it by editing the config file to
    say what keyboard you want, or you do it key by key with xmodmap.

    > using Debian and have a german keyboard-layout.


    Then you want something like

    Option "XkbLayout" "de"

    in your config file.

    > The Problem is, that the ALT and ALT-GT keys doesn't work, and in a


    Well, break out xev and test why. Then modify to taste with xmodmap.

    > console-window the [umlaut letters] also don't work.


    I bet they do! This is not the same sort of thing at all. It's up to
    your console window to show the ascii codes corresponding to the keys,
    but the keys will work. This might well be a LANG setting, but someone
    else will know.

    Peter

+ Reply to Thread