[9fans] $sysname isn't set in the 'live' part of the iso - Plan9

This is a discussion on [9fans] $sysname isn't set in the 'live' part of the iso - Plan9 ; Hi, as Wes noted in his mail "Error booting from latest plan9.iso download", booting the 'live' part of the iso gives an error, because $sysname isn't set (booting the installer does work, $sysname is set to "gnot" in that case). ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [9fans] $sysname isn't set in the 'live' part of the iso

  1. [9fans] $sysname isn't set in the 'live' part of the iso

    Hi,

    as Wes noted in his mail "Error booting from latest plan9.iso
    download", booting the 'live' part of the iso gives an error, because
    $sysname isn't set (booting the installer does work, $sysname is set
    to "gnot" in that case).
    It seems however that the focus of that thread was, from there on, on
    fixing this issue on a freshly installed plan9 system; the fact that
    the 'live' part of the iso isn't working either seems to have lost
    attention. Since this is the first thing many newcomers (including
    myself) are going to see, I guess it deserves a fix. Sorry for the
    noise if work is already being done on this.

    Greetings, Sander.

  2. Re: [9fans] $sysname isn't set in the 'live' part of the iso

    > as Wes noted in his mail "Error booting from latest plan9.iso
    > download", booting the 'live' part of the iso gives an error, because
    > $sysname isn't set (booting the installer does work, $sysname is set
    > to "gnot" in that case).
    > It seems however that the focus of that thread was, from there on, on
    > fixing this issue on a freshly installed plan9 system; the fact that
    > the 'live' part of the iso isn't working either seems to have lost
    > attention. Since this is the first thing many newcomers (including
    > myself) are going to see, I guess it deserves a fix. Sorry for the
    > noise if work is already being done on this.
    >
    > Greetings, Sander.


    See "sorry: termrc-error" on plan9changes list for the fix.
    Indeed, It doesn't seem to have been applied yet.

    david

  3. Re: [9fans] $sysname isn't set in the 'live' part of the iso

    On 5/17/07, David JEANNOT wrote:
    > See "sorry: termrc-error" on plan9changes list for the fix.
    > Indeed, It doesn't seem to have been applied yet.


    Considering it was sorried, I doubt it's going to be applied. I guess
    it was deemed an incorrect fix. I lack knowledge to judge whether this
    is right or wrong, but regardless of that, the original problem is
    still there.

    Greetings, Sander.

+ Reply to Thread